Bug 413706 - Akonadi Crash During Removal of Duplicates in a Folder
Summary: Akonadi Crash During Removal of Duplicates in a Folder
Status: RESOLVED DUPLICATE of bug 408897
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: server (show other bugs)
Version: 5.12.2
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2019-11-01 13:17 UTC by Marek Paśnikowski
Modified: 2020-03-23 18:04 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marek Paśnikowski 2019-11-01 13:17:16 UTC
Application: akonadiserver (5.12.2)

Qt Version: 5.13.1
Frameworks Version: 5.63.0
Operating System: Linux 5.3.7-1-default x86_64
Distribution: "openSUSE Tumbleweed"

-- Information about the crash:
I am removing duplicates in my e-mail archives and this particular folder (one of the big ones) causes Akonadi to crash every time. It seems to do so on the "deleting" phase, according to the status bar.

The crash can be reproduced every time.

-- Backtrace (Reduced):
#7  0x00007fcab32ccabe in std::__atomic_base<int>::load (__m=std::memory_order_relaxed, this=0x6e0061006a0024) at /usr/include/c++/9/bits/atomic_base.h:413
#8  QAtomicOps<int>::load<int> (_q_value=...) at ../../include/QtCore/../../src/corelib/thread/qatomic_cxx11.h:227
#9  QBasicAtomicInteger<int>::load (this=0x6e0061006a0024) at ../../include/QtCore/../../src/corelib/thread/qbasicatomic.h:103
[...]
#11 QString::operator= (this=this@entry=0x7fca4406d828, other=...) at tools/qstring.cpp:2434
#12 0x0000558bfe64af01 in Akonadi::Server::ItemRetrievalManager::retrievalJobFinished (this=0x558bfee3a6c0, request=0x7fca4406d810, errorMsg=...) at /usr/src/debug/akonadi-server-19.08.2-1.1.x86_64/src/server/storage/itemretrievalmanager.cpp:224


Possible duplicates by query: bug 413301, bug 411886, bug 410782, bug 410345, bug 410267.

Reported using DrKonqi
Comment 1 Daniel Vrátil 2020-03-23 18:04:16 UTC

*** This bug has been marked as a duplicate of bug 408897 ***