Bug 413301 - Kmail crashed when check email
Summary: Kmail crashed when check email
Status: RESOLVED DUPLICATE of bug 408897
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: server (show other bugs)
Version: 5.12.2
Platform: OpenSUSE Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2019-10-22 05:55 UTC by Norbert Blobel
Modified: 2020-03-23 18:03 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
New crash information added by DrKonqi (105.42 KB, text/plain)
2019-10-22 05:55 UTC, Norbert Blobel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Norbert Blobel 2019-10-22 05:55:57 UTC
Application: akonadiserver (5.12.2)

Qt Version: 5.13.1
Frameworks Version: 5.63.0
Operating System: Linux 4.12.14-lp151.28.20-default x86_64
Distribution: openSUSE Leap 15.1

-- Information about the crash:
- What I was doing when the application crashed:
Kmail simply crashes when check email is finised. Reproducable every time.

-- Backtrace (Reduced):
#6  0x00007f172a5e5f6c in std::__atomic_base<int>::load (__m=std::memory_order_relaxed, this=0x52004f00200029) at /usr/include/c++/7/bits/atomic_base.h:396
#7  QAtomicOps<int>::load<int> (_q_value=...) at ../../include/QtCore/../../src/corelib/thread/qatomic_cxx11.h:227
#8  QBasicAtomicInteger<int>::load (this=0x52004f00200029) at ../../include/QtCore/../../src/corelib/thread/qbasicatomic.h:103
[...]
#10 QString::operator= (this=this@entry=0x7f16f00719f8, other=...) at tools/qstring.cpp:2434
#11 0x00005635013e5dfc in Akonadi::Server::ItemRetrievalManager::retrievalJobFinished (this=0x563502ff9fb0, request=0x7f16f00719e0, errorMsg=...) at /usr/src/debug/akonadi-server-19.08.2-lp151.201.1.x86_64/src/server/storage/itemretrievalmanager.cpp:224


Possible duplicates by query: bug 411886, bug 410782, bug 410345, bug 410267, bug 409970.

Reported using DrKonqi
Comment 1 Norbert Blobel 2019-10-22 05:55:58 UTC
Created attachment 123394 [details]
New crash information added by DrKonqi

DrKonqi auto-attaching complete backtrace.
Comment 2 Daniel Vrátil 2020-03-23 18:03:47 UTC

*** This bug has been marked as a duplicate of bug 408897 ***