Bug 413542 - Can't UNbind Meta+Space from the global shortcuts
Summary: Can't UNbind Meta+Space from the global shortcuts
Status: RESOLVED DUPLICATE of bug 341817
Alias: None
Product: krunner
Classification: Plasma
Component: general (show other bugs)
Version: 5.17.1
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Kai Uwe Broulik
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-10-28 10:24 UTC by Yaroslav Sidlovsky
Modified: 2020-03-17 12:02 UTC (History)
10 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
All shortcuts disabled for the KRunner in the System Settings. (79.93 KB, image/png)
2019-10-28 10:24 UTC, Yaroslav Sidlovsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yaroslav Sidlovsky 2019-10-28 10:24:31 UTC
Created attachment 123535 [details]
All shortcuts disabled for the KRunner in the System Settings.

I can't unbind Meta+Space from the KRunner shortcuts.
Another guy on the Reddit has the same bug as me: https://www.reddit.com/r/kde/comments/dncy41/cant_unassign_winspace_from_krunner/.

STEPS TO REPRODUCE
1. Open `System Settings` -> `Global Shortcuts` -> `Krunner`
2. Unbind all shortcuts with `File` -> `Set All Shortcuts To None`
3. Export shortcuts for the KRunner to the file.

OBSERVED RESULT
Exported file MUST NOT contain Meta+Space, still it does.
It looks like this after export:

[krunner.desktop][Global Shortcuts]
RunClipboard=none
_launch=; ; Meta+Space; Search



EXPECTED RESULT


SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 
KDE Frameworks Version: 
Qt Version: 

ADDITIONAL INFORMATION
Comment 1 Sam Dyer 2019-10-28 19:38:14 UTC
Could you add your software versions to your report.
Comment 2 Yaroslav Sidlovsky 2019-10-28 20:49:21 UTC
Sorry.

Operating System: Fedora 30
KDE Plasma Version: 5.17.1
KDE Frameworks Version: 5.63.0
Qt Version: 5.12.5
Kernel Version: 5.3.7-200.fc30.x86_64
OS Type: 64-bit
Processors: 4 × AMD FX(tm)-9590 Eight-Core Processor
Memory: 22,4 ГиБ
Comment 3 Sam Dyer 2019-10-28 20:50:09 UTC
No problem
Comment 4 Yaroslav Sidlovsky 2019-10-28 21:12:06 UTC
This bug looks very similar to this one: https://bugs.kde.org/show_bug.cgi?id=413368 (at least to me).
Comment 5 Yaroslav Sidlovsky 2019-10-28 21:21:26 UTC
Just started /usr/lib64/kconf_update_bin/krunnerglobalshortcuts by hands and bug is gone... 🤔

And file with exported keybindings for KRunner looks like this:

[krunner.desktop][Global Shortcuts]
RunClipboard=none
_launch=Meta+R
Comment 6 Christoph Feck 2019-10-29 01:32:13 UTC
Sam, please be more careful with status changes.
Comment 7 Sam Dyer 2019-10-29 06:18:50 UTC
(In reply to Christoph Feck from comment #6)
> Sam, please be more careful with status changes.

Ok sorry I will try to remember in future.
Comment 8 Andy Great 2019-11-12 19:13:47 UTC
I can confirm this.
When I hold down meta + space, KRunner show up (the drop down windows)
Which it interfere with my shortcut to change keyboard layout.
I check to see if KRunner is using meta+space but in the keyboard setting, KRunner is not set to anything.

Operating System: openSUSE Tumbleweed 20191107

KDE Plasma Version: 5.17.2

KDE Frameworks Version: 5.63.0

Qt Version: 5.13.1

Kernel Version: 5.3.8-1-default

OS Type: 64-bit

Processors: 8 × Intel® Core™ i7-3770 CPU @ 3.40GHz

Memory: 7.5 GiB of RAM
Comment 9 Tareef Mando 2019-11-16 15:34:59 UTC
I have exactly the same problem here. 

Operating System: Arch Linux 
KDE Plasma Version: 5.17.3
KDE Frameworks Version: 5.64.0
Qt Version: 5.13.2
Kernel Version: 5.3.11-arch1-1
OS Type: 64-bit
Processors: 16 × AMD Ryzen 7 2700X Eight-Core Processor
Memory: 15.6 GiB of RAM
Comment 10 Jacob Li 2019-11-25 04:21:53 UTC
I've got exactly the same problem. Meta+Space for KRunner is default but there's not a way to change it. 

Did some search. Perhaps it has to do with this recent change? https://phabricator.kde.org/D24033

Operating System: KDE neon 5.17
KDE Plasma Version: 5.17.3
KDE Frameworks Version: 5.64.0
Qt Version: 5.13.2
Kernel Version: 5.0.0-36-generic
OS Type: 64-bit
Processors: 16 × AMD Ryzen 7 2700X Eight-Core Processor
Memory: 31.4 GiB of RAM
Comment 11 Nate Graham 2019-11-25 05:11:05 UTC
Yep, that's the change. Looks like it was me lol.

The problem here is that you can set any number of global shortcuts, but the Shortcuts KCM only displays the first two. I set Meta+Space as the third one, so it's not visible in the UI. As a workaround, you can remove the shortcut from the X-KDE-Shortcuts key of /usr/share/kglobalaccel/krunner.desktop.

The ultimate fix should be made in the Shortcuts KCM: if an action currently has more than two shortcuts bound to it, the 3rd and any additional shortcuts should be visible and unassignable in the UI. Marking this as a duplicate of the bug report tracking that issue.

*** This bug has been marked as a duplicate of bug 341817 ***
Comment 12 Tareef Mando 2019-11-25 07:35:50 UTC
I deleted the shortcut from /usr/share/kglobalaccel/krunner.desktop, restarted the system, but nothing changed, pressing on Meta+Space still run the Krunner.
Comment 13 Jacob Li 2019-11-26 06:54:28 UTC
Per my test, Nate's workaround will work for newly created users.

For an existing user, I think they also need to modify $HOME/.config/kglobalshortcutsrc . I edited out all occurrences of Meta+Space in the [krunner.desktop] section, and the problem is fixed.
Comment 14 Tareef Mando 2019-11-26 07:02:43 UTC
Editing $HOME/.config/kglobalshortcutsrc too, solves the problem on my PC. Thanks.
Comment 15 Andy Great 2020-02-15 19:36:10 UTC
I upgrade my openSUSE Tumbleweed which upgrade KDE from 5.17 to 5.18 and this same bug come back after doing the work around.

Operating System: openSUSE Tumbleweed 20200213
KDE Plasma Version: 5.18.0
KDE Frameworks Version: 5.66.0
Qt Version: 5.14.1
Kernel Version: 5.5.2-1-default
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-3770 CPU @ 3.40GHz
Memory: 7.5 GiB of RAM
Comment 16 Fülöp Kóta 2020-02-23 16:39:02 UTC
Hello!
May I join in too???

Same error here.
Operating System: Manjaro Linux 
KDE Plasma Version: 5.17.5
KDE Frameworks Version: 5.66.0
Qt Version: 5.14.1
Kernel-Version: 5.4.18-1-MANJARO
OS Type: 64-bit
Processors: 4 × Intel® Core™ i5-3320M CPU @ 2.60GHz
Memory: 7,5 GiB of RAM

Editing $HOME/.config/kglobalshortcutsrc does not helped.
Running /usr/lib64/kconf_update_bin/krunnerglobalshortcuts rewrites the meta+space parts.

What else needs to be changed?

Thanks:
F
Comment 17 Kirill Berezin 2020-03-17 12:02:43 UTC
sudo rm /usr/bin/krunner

Fixes it for me after each reboot. But this isn't serious. When its going to be fixed?

Operating System: Arch Linux 
KDE Plasma Version: 5.18.3
KDE Frameworks Version: 5.67.0
Qt Version: 5.14.1
Kernel Version: 5.4.23-1
OS Type: 64-bit
Processors: 4 × Intel® Core™ i3-4005U CPU @ 1.70GHz
Memory: 15,6 GiB of RAM