Bug 413368 - upgraded to 5.17.x, krunner alt-f2 shortcut stopped working
Summary: upgraded to 5.17.x, krunner alt-f2 shortcut stopped working
Status: RESOLVED DUPLICATE of bug 437364
Alias: None
Product: krunner
Classification: Unclassified
Component: general (show other bugs)
Version: 5.17.3
Platform: Fedora RPMs Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Alexander Lohnau
URL:
Keywords:
: 412250 433271 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-10-23 16:09 UTC by Rex Dieter
Modified: 2021-06-20 13:28 UTC (History)
16 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
contents of ~/.config/kglobalshortcutsrc (13.65 KB, text/plain)
2019-12-06 14:26 UTC, Rex Dieter
Details
Shortcuts back for Krunner (6.06 KB, patch)
2020-08-08 10:54 UTC, vector
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rex Dieter 2019-10-23 16:09:09 UTC
I'd upgraded to plasma-5.17.0 recently (from 5.15.4 I think?), and today noticed that krunner shortcut alt-f2 that I'd been used-to forever no longer worked.

meta+space works.

Going into plasma shortcuts says
application shortcuts:

krunner says custom: None is selected for both Global, Global Alternate are set to Custom: None (odd?)

other shortcuts: 
"Run command" has Global Default: Alt+Space, Global Alternate: Custom: Alt+F2
"Run Command on clipboard contents" has Global Default: Alt+Shift+F2

Honestly, don't recall ever changing/custominzing any of these (but still possible I forgot).
Comment 2 Rex Dieter 2019-10-28 17:50:40 UTC
You sure, that reverted commit appears to only be in master/ branch ?

in 5.17, krunner.desktop doesn't have any NoDisplay that I can tell.
Comment 3 Nate Graham 2019-10-28 17:52:59 UTC
Darn. Fabian and Méven, any idea what's going on here?
Comment 4 Fabian Vogt 2019-10-28 17:58:33 UTC
What's the content of ~/.config/kglobalshortcutsrc?

I assume the krunnerglobalshortcuts.upd kconf_update script failed or didn't run for some reason.
Comment 5 Yaroslav Sidlovsky 2019-10-28 21:32:58 UTC
Very similar bug - https://bugs.kde.org/show_bug.cgi?id=413542, the difference is that I can't unbind default shortcut.

Issue gone after executing /usr/lib64/kconf_update_bin/krunnerglobalshortcuts.
Comment 6 Rex Dieter 2019-10-29 14:58:01 UTC
I can confirm manually running,
/usr/lib64/kconf_update_bin/krunnerglobalshortcuts
made F2 start working again for me, thanks!

Rat's, I did that before fetching contents of
~/.config/kglobalshortcutsrc
(do you still want that?)
Comment 7 Bug Janitor Service 2019-11-13 04:33:08 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 8 Bug Janitor Service 2019-11-28 04:33:12 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!
Comment 9 Rex Dieter 2019-12-06 14:24:44 UTC
Confirmed (still) issue with 5.17.3 at least (will test 5.17.4 soon)
Comment 10 Rex Dieter 2019-12-06 14:26:32 UTC
Created attachment 124341 [details]
contents of ~/.config/kglobalshortcutsrc
Comment 11 Rex Dieter 2019-12-06 14:29:15 UTC
And ~/.config/kconf_updaterc includes:

[krunnerglobalshortcuts.upd]
ctime=1575494799
mtime=1573554644

(I'll wait to manually run 
/usr/lib64/kconf_update_bin/krunnerglobalshortcuts

in case there's more debugging requested.
Comment 12 Rex Dieter 2019-12-06 14:39:10 UTC
Fwiw, I'd updated while in a plasma < 5.17, then did logout/login, in case that matters.
Comment 13 Tomas Trnka 2020-01-08 14:20:54 UTC
I have just hit this after updating to 5.17.4 (Fedora 31), after not having used  Plasma for at least a year. Manually running "krunnerglobalshortcuts" fixed it (if it helps, I can attach both versions of "kglobalshortcutsrc" before and after running the fix).
Comment 14 Graeme Hewson 2020-06-03 08:10:18 UTC
The shortcuts stopped working for me too, upgrading from Kubuntu 19.10 to 20.04.

Instead of running krunnerglobalshortcuts as detailed above, I chose to change the settings back to the defaults using System Settings.

See https://bugs.launchpad.net/ubuntu/+source/krunner/+bug/1872051
Comment 15 Alexander Lohnau 2020-06-14 16:09:30 UTC
*** Bug 412250 has been marked as a duplicate of this bug. ***
Comment 16 Raphael Groner 2020-06-16 15:29:16 UTC
Reproducible for me, with Fedora 31.
Comment 17 vector 2020-08-06 10:08:33 UTC
I can fixed in blackPanther OS. The problem origin is krunner are renamed to krunner.desktop and old globalshortcuts conflicting with old settings group.
Comment 18 Rex Dieter 2020-08-06 14:52:11 UTC
Can you be more specific about how you fixed it?  Is it something you'd advocated for kde upstream to adopt?
Comment 19 vector 2020-08-08 10:54:59 UTC
Created attachment 130723 [details]
Shortcuts back for Krunner
Comment 20 vector 2020-08-08 11:04:04 UTC
Comment on attachment 130723 [details]
Shortcuts back for Krunner

(In reply to Rex Dieter from comment #18)
> Can you be more specific about how you fixed it?  Is it something you'd
> advocated for kde upstream to adopt?

I've renamed KRunner in krunner.desktop.cmake and patched plasma-workspace. So and get back immediately shortcuts functionally Alt+F2 / Alt+Space as well

i uploaded previously my patch for test.
Comment 21 Nate Graham 2021-05-19 17:54:24 UTC
*** Bug 433271 has been marked as a duplicate of this bug. ***
Comment 22 Justin Zobel 2021-06-20 06:36:17 UTC
(In reply to vector from comment #19)
> Created attachment 130723 [details]
> Shortcuts back for Krunner

Are you able to please send this patch via a merge request: https://invent.kde.org/frameworks/krunner/-/merge_requests
Comment 23 Nate Graham 2021-06-20 13:28:45 UTC
That patch isn't sane, sorry. We fixed this permanently in Bug 437364. :)

*** This bug has been marked as a duplicate of bug 437364 ***