Bug 413502 - Restore/Add Double Click Speed setting that used to live in the mouse KCM
Summary: Restore/Add Double Click Speed setting that used to live in the mouse KCM
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_accessibility (show other bugs)
Version: unspecified
Platform: unspecified Linux
: NOR normal
Target Milestone: ---
Assignee: Gunnar Schmidt
URL:
Keywords:
: 460164 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-10-27 05:53 UTC by Ivaylo Atanasov
Modified: 2023-12-22 19:48 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In: 6.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ivaylo Atanasov 2019-10-27 05:53:15 UTC
SUMMARY
Single click to open files/folders is great (I use it constantly) but in the newer versions of Plasma 5 mouse configuration options decreased significantly as opposed to KDE Plasma 4. Please, consider adding/restoring Double Click Speed Control as it is much needed for coming users from Windows, some old or slow moving people who can't be always fast enough to double click and want to change the time interval ...

SOFTWARE/OS VERSIONS:
Linux/KDE Plasma: Kubuntu 19.10
(available in About System)
KDE Plasma Version: 5.17.1
KDE Frameworks Version: 5.62.0
Qt Version: 5.12.4

ADDITIONAL INFORMATION:
Plus Kubuntu backports PPA.
Comment 1 Nate Graham 2019-10-27 21:35:45 UTC
This got lost with the Libinput KCM. The accessibility-related features were recently re-added in https://phabricator.kde.org/D22823, but this feature wasn't included.

I would advocate for putting it in the Accessibility KCM alongside the others, since it is basically an accessibility feature and strictly speaking doesn't belong on the Mouse page (you can double-click with a touchpad too).
Comment 2 Ivaylo Atanasov 2019-10-29 05:10:48 UTC
Yes, you are right - Double Click Speed Control should be in the Accessibility KCM.
It would be good if there was a shortcut (More options) from Input Devices -> Mouse to Accessibility -> Mouse Navigation for easier, more comfortable access (not everyone is visiting Accessibility options and the additional settings may get skipped from first sight), too ...
Comment 3 Ivaylo Atanasov 2020-02-06 05:24:36 UTC Comment hidden (spam)
Comment 4 Nate Graham 2022-10-10 15:44:57 UTC
*** Bug 460164 has been marked as a duplicate of this bug. ***
Comment 5 dsyrzm0fy 2023-03-16 07:59:35 UTC
After upgrading my plasma version it seemed that i couldn't double click anymore, which turned out to be just a way too short default interval. And i'm also missing the advanced settings to adjust for that.
After looking around i found that it's possible to set DoubleClickInterval in ~/.config/kdeglobals. But the value set there, for some reason doesn't seem to match the actual timing value when double clicking (it must be set to around twice the desired value).
It would be better if the double click setting was properly exposed somewhere, so misbehaving manual tweaks like this are not required and left to the user to even find.
And changing to evdev, as suggested by some posts online, seems like the wrong action when libinput is meant to be its replacement, from what i read.
Comment 6 Bug Janitor Service 2023-04-01 13:23:25 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-desktop/-/merge_requests/1455
Comment 7 local10 2023-06-13 16:07:45 UTC
Is there some config file one could edit to set the minimum double click interval?

Operating System: Debian GNU/Linux 12
KDE Plasma Version: 5.27.5  KDE Frameworks Version: 5.103.0  Qt Version: 5.15.8
Kernel Version: 6.1.0-9-amd64 (64-bit)
Graphics Platform: X11
Comment 8 Mace 2023-08-17 13:39:03 UTC
I don't know if this could be relevant but I noticed my double-click speed speed interval gets very short, to the point of me having to try multiple times to open something via double-click sometimes. In my case it was caused by using xrandr to re-enable a temporarily disabled display output, but only when using the --rate option.

The following would cause my double-click rate to be too fast until I logged out and back in:

/usr/bin/xrandr --output HDMI-A-0 --auto --pos 3440x0 --mode 1920x1080 --rate 75

where the following did not seem to change my double-click rate at all:

/usr/bin/xrandr --output HDMI-A-0 --auto --pos 3440x0 --mode 1920x1080
Comment 9 Nate Graham 2023-08-17 13:51:03 UTC
That's something else; See Bug 419421.
Comment 10 Nicolas Fella 2023-11-04 11:59:15 UTC
Git commit 901b1b8c2db64130209d52482df93e7cab435dfb by Nicolas Fella.
Committed on 04/11/2023 at 12:30.
Pushed by nicolasfella into branch 'master'.

[kcms/workspaceoptions] Add setting for double click interval

This is part of the legacy mouse KCM, but not the libinput-based one

This is odd because it's not actually a driver-level feature, it's implemented on the toolkit (Qt) level

The KCM only writes a value to kdeglobals that plasma-integration then passes to Qt

It also does not only affect mice, it also applies to touchpads

This patch adds it to the 'General Behavior' KCM, where we already have similar 'Mouse but not acutally mouse' settings like single/double click settings

M  +42   -0    kcms/workspaceoptions/ui/main.qml
M  +6    -0    kcms/workspaceoptions/workspaceoptions_kdeglobalssettings.kcfg
M  +1    -1    kcms/workspaceoptions/workspaceoptions_kdeglobalssettings.kcfgc

https://invent.kde.org/plasma/plasma-desktop/-/commit/901b1b8c2db64130209d52482df93e7cab435dfb
Comment 11 d7ghrrkcz 2023-11-27 16:15:35 UTC
I am also affected by this issue.
Is it possible to tweak this setting by hand? I want to increase default double click interval, default value is just too short, and sometimes it misses my clicks. I had a look into ~/.config/kdeglobals, but unfortunately it doesn't have DoubleClickInterval entry.

Operating System: Debian GNU/Linux 12
KDE Plasma Version: 5.27.5
KDE Frameworks Version: 5.103.0
Qt Version: 5.15.8
Kernel Version: 6.1.0-13-amd64 (64-bit)
Graphics Platform: X11
Processors: 16 × AMD Ryzen 7 5800X 8-Core Processor
Memory: 62.7 GiB of RAM
Graphics Processor: AMD Radeon RX 6800 XT
Product Name: X570 Steel Legend
Comment 12 local10 2023-11-30 14:08:59 UTC
> Is it possible to tweak this setting by hand? 

I asked similar question some time ago but never got any response. Still, is there some config file or whatever one could edit to set the minimum double click interval instead of using the GUI fix, which isn't available in some KDE versions?

Regards,

Operating System: Debian GNU/Linux 12
KDE Plasma Version: 5.27.5  KDE Frameworks Version: 5.103.0  Qt Version: 5.15.8
Kernel Version: 6.1.0-13-amd64 (64-bit)
Graphics Platform: X11
Comment 13 Nate Graham 2023-11-30 20:17:06 UTC
To use the feature now, open ~/.config/kdeglobals, find the "[KDE]" group, and add this line

> DoubleClickInterval=500

...with "500" replaced with the desired number of milliseconds.
Comment 14 Jeffrey Walton 2023-12-20 20:52:59 UTC Comment hidden (spam)
Comment 15 Nate Graham 2023-12-20 20:53:52 UTC Comment hidden (spam)
Comment 16 Jeffrey Walton 2023-12-20 21:22:24 UTC Comment hidden (spam)
Comment 17 Nate Graham 2023-12-20 22:22:36 UTC Comment hidden (spam)
Comment 18 Jeffrey Walton 2023-12-22 19:43:22 UTC Comment hidden (spam)
Comment 19 Nate Graham 2023-12-22 19:48:58 UTC Comment hidden (spam)