Bug 411453 - Falkon won't launch because it's missing kf5-locale-gen
Summary: Falkon won't launch because it's missing kf5-locale-gen
Status: RESOLVED DUPLICATE of bug 414014
Alias: None
Product: Falkon
Classification: Unclassified
Component: general (show other bugs)
Version: 3.1.0
Platform: Snap Linux
: NOR normal
Target Milestone: ---
Assignee: David Rosca
URL:
Keywords:
: 411535 422297 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-08-30 16:25 UTC by techxgames
Modified: 2021-02-02 14:51 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description techxgames 2019-08-30 16:25:55 UTC
SUMMARY
Falkon won't launch because it's missing kf5-locale-gen.

STEPS TO REPRODUCE
1. Launch Falkon from the terminal

OBSERVED RESULT
$ snap run falkon
/snap/falkon/60/kf5-launch: line 209: /snap/falkon/60/kf5-locale-gen: No such file or directory

$ snap connections falkon
Interface                             Plug                          Slot                                                  Notes
browser-support                       falkon:browser-support        :browser-support                                      -
content[kde-frameworks-5-core18-all]  falkon:kde-frameworks-5-plug  kde-frameworks-5-core18:kde-frameworks-5-core18-slot  -
desktop                               falkon:desktop                :desktop                                              -
desktop-legacy                        falkon:desktop-legacy         :desktop-legacy                                       -
home                                  falkon:home                   :home                                                 -
network                               falkon:network                :network                                              -
network-bind                          falkon:network-bind           :network-bind                                         -
opengl                                falkon:opengl                 :opengl                                               -
pulseaudio                            falkon:pulseaudio             :pulseaudio                                           -
unity7                                falkon:unity7                 :unity7                                               -
x11                                   falkon:x11                    :x11                                                  -


EXPECTED RESULT
Supposed to launch normally

SOFTWARE/OS VERSIONS
Operating System: Kubuntu 19.04
KDE Plasma Version: 5.16.4
KDE Frameworks Version: 5.61.0
Qt Version: 5.12.2
Kernel Version: 5.0.0-25-generic
OS Type: 64-bit
Processors: 4 × Intel® Core™ i5-6500 CPU @ 3.20GHz
Memory: 15.6 GiB of RAM

ADDITIONAL INFORMATION
Reinstalling doesn't work.
Comment 1 Alexander Browne 2019-09-04 02:18:01 UTC
*** Bug 411535 has been marked as a duplicate of this bug. ***
Comment 2 Sam Shiell 2020-03-04 22:01:00 UTC
Same issue for me. Falkon won't launch because of of the following: 

/snap/falkon/60/kf5-launch: line 209: /snap/falkon/60/kf5-locale-gen: No such file or directory

Other than subfolders (.cache, .config, .icons and .local) there's nothing in that folder. the .local folder is also empty.
Comment 3 Marcus Larborg 2020-05-09 08:02:47 UTC
I can confirm. I get the same error when trying to launch falkon.

snap run falkon
/snap/falkon/60/kf5-launch: line 209: /snap/falkon/60/kf5-locale-gen: No such file or directory
Comment 4 TW3 2020-06-16 03:19:35 UTC
*** Bug 422297 has been marked as a duplicate of this bug. ***
Comment 5 TW3 2020-06-17 00:57:09 UTC
Actually, it might be an idea to change this report to be against Ubuntu and not Mint.
Mint recently announced that they won't support snaps by default:
https://blog.linuxmint.com/?p=3906
My guess is that going forward that if you install Falkon on Mint it will be a deb and likely not produce this issue.
Comment 6 Jeffrey Bouter 2020-08-11 22:55:32 UTC
Let's file it against platform "snap" instead.
Comment 7 hrwy 2020-09-02 10:39:03 UTC
SUMMARY
Snap hasn't
3.0.1, 3.0.0 channel !!

All 'latest' channels can't be launched because of this bug 

File that needed:
https://invent.kde.org/graphics/krita/-/blob/adbe90fd47dc81173a3442c0d920dcc2dddd4a75/packaging/linux/snap/scripts/kf5-locale-gen
Comment 8 hrwy 2020-09-02 10:44:02 UTC
Let's change also importance to high/critical. Affected all machines with OS elementary OS 5.1.7 Hera.
Comment 9 hrwy 2020-09-02 10:56:10 UTC
please add last line to snapcraft.yaml

  launcher:
    plugin: dump
    source: .
    organize:
...
      kf5-locale-gen: bin/kf5-locale-gen
Comment 10 techxgames 2020-12-28 02:27:04 UTC
Any updates?  Candidate branch doesn't work either. Did comment 9 work?
Comment 11 Harald Sitter 2021-02-02 14:51:15 UTC

*** This bug has been marked as a duplicate of bug 414014 ***