Bug 410236 - Right click on selected text while moving mouse to the right -> text gets cut
Summary: Right click on selected text while moving mouse to the right -> text gets cut
Status: RESOLVED DUPLICATE of bug 374311
Alias: None
Product: kate
Classification: Unclassified
Component: kwrite (show other bugs)
Version: 19.04.3
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWrite Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-26 15:02 UTC by Mark Smith
Modified: 2020-10-24 16:09 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Smith 2019-07-26 15:02:07 UTC
SUMMARY
If you select text, right click while moving the mouse slightly to the right (so that it overlaps with "cut" on the rightclick menu) it acts as if you clicked on cut and text gets cut

STEPS TO REPRODUCE
1. Select text
2. While moving the mouse to the right and slightly down, right click
3. Text gets cut 

EXPECTED RESULT
The "cut" menu item shouldn't be executed. It can be pretty annoying if you're working fast and you keep triggering this.

SOFTWARE/OS VERSIONS
KDE Plasma 5.16.3
KDE Frameworks Version: 5.60
Qt Version: 5.12.3
Comment 1 Mark Smith 2019-07-26 15:15:05 UTC
Actually I just realized it happens system-wide. I made a forum post here. 

https://forum.kde.org/viewtopic.php?f=289&t=161733
Comment 2 Christoph Feck 2019-07-26 16:21:15 UTC

*** This bug has been marked as a duplicate of bug 374311 ***
Comment 3 Nate Graham 2019-08-01 19:30:06 UTC

*** This bug has been marked as a duplicate of bug 410493 ***
Comment 4 Nate Graham 2020-10-24 16:09:34 UTC

*** This bug has been marked as a duplicate of bug 374311 ***