Bug 410034 - Gradient labels are not translated (and two are not translatable)
Summary: Gradient labels are not translated (and two are not translatable)
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: Translation (show other bugs)
Version: git master (please specify the git hash!)
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: vanyossi
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-07-20 13:34 UTC by Karl Ove Hufthammer
Modified: 2019-07-29 08:35 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Karl Ove Hufthammer 2019-07-20 13:34:18 UTC
SUMMARY
The text ‘Foreground to Transparent’ and ‘Foreground to Background’, which appears when you click on the ‘Gradients’ icons on the toolbar are not translatable, i.e., they don’t appear as a string in the krita.pot file.

Also, for the gradient names that *are* translatable in the krita.pot file, e.g. ‘GPS Fire Blueish’ and ‘GPS Nature random greens’, the translations are not actually used in the UI; they strings are always shown in English.



STEPS TO REPRODUCE
1. Launch Krita in a language different than English, e.g. Norwegian Nynorsk: ‘LANGUAGE=nn krita’
2. Click the ‘Gradients’ icon on the toolbar
3. Read the text ‘Foreground to Transparent’ or ‘Foreground to Background’ (English)
4. Check that the corresponding strings are missing from the POT file: https://websvn.kde.org/*checkout*/trunk/l10n-kf5/templates/messages/extragear-graphics/krita.pot
5. Click on one of the other gradients, e.g. ‘GPS Nature random greens’.
6. Observe that the gradient name is shown in English, even though the string is translated in the PO file: https://websvn.kde.org/*checkout*/trunk/l10n-kf5/nn/messages/extragear-graphics/krita.po


OBSERVED RESULT
Strings are missing from POT file.
Translations from PO file are not used.

EXPECTED RESULT
All gradient name strings should available for translation in the POT file.
The translations in the PO file should be shown in the actual UI.

SOFTWARE/OS VERSIONS
Operating System: openSUSE Tumbleweed 20190717
KDE Plasma Version: 5.16.2
KDE Frameworks Version: 5.59.0
Qt Version: 5.13.0
Kernel Version: 5.1.16-1-default
OS Type: 64-bit
Processors: 4 × Intel® Core™ i5-2500 CPU @ 3.30GHz
Memory: 15,6 GiB
Comment 1 vanyossi 2019-07-22 01:32:58 UTC
Git commit 76e2b76b1607443f5e079aa6f8000199f98dcda3 by Ivan Yossi.
Committed on 22/07/2019 at 01:32.
Pushed by ivany into branch 'master'.

Make generated gradient's names translatable

M  +3    -2    libs/widgets/KoResourceServerProvider.cpp

https://invent.kde.org/kde/krita/commit/76e2b76b1607443f5e079aa6f8000199f98dcda3
Comment 2 Karl Ove Hufthammer 2019-07-23 09:11:25 UTC
Reopening. The ‘Foreground to Transparent’ and ‘Foreground to Background’ strings are now translatable, and show up as translated in the UI, but the *other* gradient names (from the .ggr files) are still not shown as translated in the UI.

To clarify, it’s possible to *translate* all the gradient names (e.g. ‘GPS Fire Blueish’). But the translations (except ‘Foreground to Transparent’ and ‘Foreground to Background’) are not actually used in the UI.
Comment 3 wolthera 2019-07-28 12:12:26 UTC
That is at it's heart the same issue as https://bugs.kde.org/show_bug.cgi?id=410307, so marking as a duplicate.

*** This bug has been marked as a duplicate of bug 410307 ***
Comment 4 Halla Rempt 2019-07-29 08:35:39 UTC
Git commit 4cdbb2e727db75e7bca2641a943ffe3218247976 by Boudewijn Rempt, on behalf of Ivan Yossi.
Committed on 29/07/2019 at 08:34.
Pushed by rempt into branch 'krita/4.2'.

Make generated gradient's names translatable

M  +3    -2    libs/widgets/KoResourceServerProvider.cpp

https://invent.kde.org/kde/krita/commit/4cdbb2e727db75e7bca2641a943ffe3218247976