Bug 409338 - Remember window size & position by default
Summary: Remember window size & position by default
Status: RESOLVED DUPLICATE of bug 15329
Alias: None
Product: kwin
Classification: Plasma
Component: general (show other bugs)
Version: 5.16.2
Platform: Neon Linux
: NOR wishlist (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords: usability
Depends on:
Blocks:
 
Reported: 2019-06-30 18:04 UTC by Unknown
Modified: 2019-08-28 15:31 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot showing KDE Reddit community members who upvoted idea. (213.59 KB, image/png)
2019-06-30 18:04 UTC, Unknown
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Unknown 2019-06-30 18:04:24 UTC
Created attachment 121242 [details]
Screenshot showing KDE Reddit community members who upvoted idea.

SUMMARY
The out-of-the-box experience in Plasma when I open a Qt/KDE program (when window behavior position is set to "smart") is that the size of a window is small, often hiding elements of the program, and has to be re-scaled to make it use-able. The position is also away from the center of the window, which is often the main area of activity on a screen. I asked on Reddit if users preferred Plasma remembering window position & size by default (in order to fix this issue) and so far 286 have agreed.

I'm requesting Plasma dev's consider changing the default behavior to remember window size & position by default, whether that means changing how the "smart" window placement setting behaves or adding a "Remember" setting so when a user re-sizes a window and moves it, then they close and re-open it, the window will retain the window size and position as before.

ADDITIONAL INFORMATION
Suggested while using KDE Neon 5.16.2
Comment 1 Nate Graham 2019-06-30 22:58:00 UTC
+1, I would like this too, as it matches both what I expect, and also what other major platforms do.
Comment 2 Christoph Feck 2019-06-30 23:23:17 UTC
It is the application that decides how big the window gets. Ignoring that request from the application is against the NETWM specification, and thus is only available as per-application rule overrides.

-1, to me it is a WONTFIX in KWin.

KDE applications should remember window sizes. For applications that do not, please report an issue for that application. Some specific applications also remember window positions, mostly when you expect that you only start them once.
Comment 3 Christoph Feck 2019-06-30 23:24:44 UTC
> The position is also away from the center of the window

For windows which do not request a specific position, you can instruct KWin to automatically center them.
Comment 4 Nate Graham 2019-06-30 23:51:26 UTC
There are two parts of this. KDE apps generally do remember their window sizes, but with the default Smart window positioning strategy, they do not remember their prior positions.

It seems reasonable to expect apps to remember their own sizes per the spec, but since KWin can and currently does have its own logic to determine window positions, I think it's reasonable to request a "remember prior position" mode. I have filed a new bug to track that so it can be discussed with a clean history: Bug 409349

*** This bug has been marked as a duplicate of bug 409349 ***
Comment 5 Nate Graham 2019-08-28 15:31:10 UTC

*** This bug has been marked as a duplicate of bug 15329 ***