Bug 408790 - The new blur in 5.16 isn't neutral and darkens everything, clashing with other program's settings
Summary: The new blur in 5.16 isn't neutral and darkens everything, clashing with othe...
Status: RESOLVED DUPLICATE of bug 408594
Alias: None
Product: kwin
Classification: Plasma
Component: effects-various (show other bugs)
Version: 5.16.0
Platform: Manjaro Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-16 16:11 UTC by Michał Dybczak
Modified: 2019-06-16 18:06 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments
Konsole-and-latte-full-transparency-problem-5.16 (391.06 KB, image/jpeg)
2019-06-16 16:11 UTC, Michał Dybczak
Details
Proper-neutral-color-Plasma-5.15 (110.27 KB, image/png)
2019-06-16 16:15 UTC, Michał Dybczak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michał Dybczak 2019-06-16 16:11:26 UTC
Created attachment 120918 [details]
Konsole-and-latte-full-transparency-problem-5.16

SUMMARY

The new blur isn't neutral anymore and when 100% transparency is added it produces a STRONGLY DARK effect which is:

- ugly
- undesirable (I don't wish it and I have no way to get rid of it, previously I had a spectrum of colors that I could use if the app had such option)
- conflicts with app settings, creating different result than expected or wished, so for example, with added white tone it makes it darker, with dark color it makes even darker and there is no longer possible to achieve that nice, neutral "frozen glass" effect which was desirable in some places where readability was not an issue (like dock background).

Because of that new effect, I thought something was broken in latte, so I posted a bug report:

https://bugs.kde.org/show_bug.cgi?id=408773


STEPS TO REPRODUCE
1. update Plasma to 5.16
2. set Konsole transparency to 100%
3. set Latte-dock background opacity to 0%

OBSERVED RESULT
Lack of control over the effect that always darkens everything whether I like it or not.

EXPECTED RESULT

Full control over blur effect.

SOFTWARE/OS VERSIONS
Operating System: Manjaro Linux 
KDE Plasma Version: 5.16.0
KDE Frameworks Version: 5.59.0
Qt Version: 5.12.3
Kernel Version: 5.1.9-2-MANJARO
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-6700HQ CPU @ 2.60GHz
Memory: 7,7 GiB
 

ADDITIONAL INFORMATION
Comment 1 Michał Dybczak 2019-06-16 16:15:01 UTC
Created attachment 120919 [details]
Proper-neutral-color-Plasma-5.15
Comment 2 Vlad Zahorodnii 2019-06-16 18:06:39 UTC

*** This bug has been marked as a duplicate of bug 408594 ***