Bug 408773 - Blur won't work correctly in Plasma 5.16
Summary: Blur won't work correctly in Plasma 5.16
Status: RESOLVED DUPLICATE of bug 408594
Alias: None
Product: lattedock
Classification: Plasma
Component: application (show other bugs)
Version: git (master)
Platform: Manjaro Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Michail Vourlakos
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-06-16 10:56 UTC by Michał Dybczak
Modified: 2019-06-16 20:02 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
solid-background-1 (412.14 KB, image/jpeg)
2019-06-16 10:56 UTC, Michał Dybczak
Details
solid-background-2 (442.70 KB, image/jpeg)
2019-06-16 10:57 UTC, Michał Dybczak
Details
correct-blurr-but-with-color (261.52 KB, image/png)
2019-06-16 10:59 UTC, Michał Dybczak
Details
correct-bur-with-smart-color-opacity-0 (393.24 KB, image/jpeg)
2019-06-16 11:34 UTC, Michał Dybczak
Details
video-darkening-of-background-opacity-0 (3.88 MB, video/x-flv)
2019-06-16 15:28 UTC, Michał Dybczak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michał Dybczak 2019-06-16 10:56:08 UTC
Created attachment 120910 [details]
solid-background-1

SUMMARY

Previously it worked great. However, I noticed on your screens that your blur is more neutral, without color. It took me a while until I figured out how to disable color from my dock to achieve the same effect. I set it and now I have absolutely no idea what I did and can't find it in the options.

Anyway, after updating to Plasma 5.16 two issues happened:

1. That no-color but still blur effect was disabled (the color is applied with full strength, so that previous, mysterious and hard to figure out color adjustment option is no longer working.
2. On some wallpapers (using latte-wallpaper) blur doesn't seem to work and produces solid color (usually black), while on others it does work but somewhat differently than before (probably that "improved" blur in 5.16 is at fault). Disabling blur makes the whole background go transparent, enabling blur adds a solid black background (on some wallpapers)

I'm attaching some screenshots of dock having a solid background because of the blur.

STEPS TO REPRODUCE
1. Use latte-git and have dock with Smart colors
2. Update to Plasma 5.13
3. Use latte-wallpaper plugin (maybe it needs updating? but discover isn't finding any update for this component that I downloaded by Plasma GUI "get more online") and observe the result on some wallpapers.



EXPECTED RESULT

Just as it worked with Plasma 5.15

Operating System: Manjaro Linux 
KDE Plasma Version: 5.16.0
KDE Frameworks Version: 5.59.0
Qt Version: 5.12.3
Kernel Version: 5.1.9-2-MANJARO
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-6700HQ CPU @ 2.60GHz
Memory: 7,7 GiB
Comment 1 Michał Dybczak 2019-06-16 10:57:19 UTC
Created attachment 120911 [details]
solid-background-2
Comment 2 Michał Dybczak 2019-06-16 10:59:01 UTC
Created attachment 120912 [details]
correct-blurr-but-with-color
Comment 3 Michail Vourlakos 2019-06-16 11:23:31 UTC
1. Latest Latte considers solid as SOLID meaning NO Transparency at ALL.
If you want to see the BLUR underneath you must lower the Background Opacity Level

2. If [1] does not work, what is your plasma theme?
Comment 4 Michał Dybczak 2019-06-16 11:31:05 UTC
My opacity level is 0%... and as you see, sometimes blur does work, sometimes it gets solid. Even if the blur is visible, there is a dark color adjusted on it.
My current theme is Breeze with Kvantum theme KvGlassWhite.

Both in the upper panel as well in the dock I have Smart-None.

Actually, blur is working on the majority of wallpapers, only on few, it seems to get solid. But even if the blur is OK, latte is usually adding dark, smart color and coloring dock background accordingly.

Is Opacity this mysterious option that I lowered to get so nice, neutral blur before? If so, Opacity stopped working correctly and that is probably the issue.
Comment 5 Michał Dybczak 2019-06-16 11:34:21 UTC
Created attachment 120913 [details]
correct-bur-with-smart-color-opacity-0
Comment 6 Michał Dybczak 2019-06-16 11:37:06 UTC
OK, I tested it and when changing Opacity, I see the effect in real time and it works but as quick as my settings panel disappears, this gets replaced with this colored, dark version. I could create a video if that would help.
Comment 7 Michail Vourlakos 2019-06-16 12:04:19 UTC
(In reply to Michał Dybczak from comment #6)
> OK, I tested it and when changing Opacity, I see the effect in real time and
> it works but as quick as my settings panel disappears, this gets replaced
> with this colored, dark version. I could create a video if that would help.

that would help to understand
Comment 8 Michail Vourlakos 2019-06-16 14:51:30 UTC
Are you using Materia?

https://github.com/PapirusDevelopmentTeam/materia-kde/issues/56
Comment 9 Michał Dybczak 2019-06-16 15:28:40 UTC
Created attachment 120917 [details]
video-darkening-of-background-opacity-0

Here is the video.
No, as I said I use Breeze at the moment but I checked with other desktop themes and the result is identical.
Comment 10 Michail Vourlakos 2019-06-16 15:34:21 UTC
(In reply to Michał Dybczak from comment #9)
> Created attachment 120917 [details]
> video-darkening-of-background-opacity-0
> 
> Here is the video.
> No, as I said I use Breeze at the moment but I checked with other desktop
> themes and the result is identical.

yep, this is the new Blur Effect, I also dont like it... it darkens some areas very much!!!

1. You can see at the left edge of your Latte Dock the yellowish background underneath
2. You can reproduce this with any app providing Blur and Full transparency for the window:
e.g.
a) open a Konsole window
b) set at its profile to use Blur and set Transparency to 100%
c) overlay the same area that Latte now overlays, you will get the same DARKISH results
Comment 11 Michał Dybczak 2019-06-16 15:52:56 UTC
I guess we need to call a "bug" for the "improved" blur effect, link this and probably other threads and see what happens.

However, when you see right-click menu blur, it looks all right, whiteish so I'm not sure why sometimes the blur adds this dark tone and sometimes isn't.

The original blur was awesome and I have no idea who thought this will be better. I never saw any discussion about the blur but I guess Nate will know more where it took place.

The original blur was neutral and thus subject to the individual program settings. Now it will be cross wiring with them, which is a problem and a bug in my book. Or, given how inconsitent blur now is, this is really a bug?
Comment 12 Michał Dybczak 2019-06-16 15:58:03 UTC
You're right, I gave full transparency in Konsole and it looks exactly like the dock background and ugly. I see no point of that effect :(.
Comment 13 Michail Vourlakos 2019-06-16 16:05:33 UTC
It can be bug because the intended commit to plasma was to make it more natural, exactly the reverse...

Can you open a bug at kwin, Effects, Blur with a video from konsole or screenshots showing the issue?
Comment 14 Michał Dybczak 2019-06-16 16:17:00 UTC
OK, here is the bug report for the new blur. Let's see if it will be marked as duplicate. If so, it's even better because it means more people have noticed and didn't like it.

https://bugs.kde.org/show_bug.cgi?id=408790
Comment 15 Nate Graham 2019-06-16 20:02:30 UTC

*** This bug has been marked as a duplicate of bug 408594 ***