Bug 407685 - Tries to use http proxy for imap
Summary: Tries to use http proxy for imap
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Applications
Component: general (show other bugs)
Version: 5.11.1
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 410643 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-05-18 11:49 UTC by Sascha Gaspar
Modified: 2019-08-06 10:41 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sascha Gaspar 2019-05-18 11:49:34 UTC
SUMMARY
Kmail/Kontact uses the http proxy from the system settings for IMAP (and probably POP/SMTP).

STEPS TO REPRODUCE
1. Configure a proxy in the system settings
2. Try to receive mails

OBSERVED RESULT
Kmail shows the state "offline"


EXPECTED RESULT
Kmail should receive new mails from the server.


SOFTWARE/OS VERSIONS
Linux/KDE Plasma: OpenSuSE Tumbleweed / Plasma 5
KDE Plasma Version: 5.15.5
KDE Frameworks Version: 5.57.0
Qt Version: 5.0.13.1

ADDITIONAL INFORMATION

I think the proxy should not be used because a http/https/ftp proxy (Squid in my case) can not handle IMAP/POP/SMTP. And I set only http, https and ftp proxy, no socks and no other protocol. Besides I added the IMAP server in the no-proxy settings and it is ignored.

It seems that Kmail does not use the environment but the Plasma settings.
Comment 1 Jonathan Marten 2019-05-18 17:43:10 UTC
Sending or receiving mail through a proxy is an unusual case, so a couple of years ago the default for POP3 and SMTP was changed to explicitly use no proxy, with an option in the advanced account settings to enable the proxy if it really is required.  However, doing the same for IMAP appears to have been overlooked.

See https://phabricator.kde.org/T7430 and linked reviews.
Comment 2 Marlos 2019-05-23 18:12:17 UTC
I have the same issue. But, in my case, kmail is using http_proxy environment variable, even if I mark the no proxy option in system settings. As a matter of fact, proxy options in system settings seems not to be relevant for kmail (imap and smtp).

I reported this in https://bugs.kde.org/show_bug.cgi?id=373870.
Comment 5 Wolfgang Bauer 2019-08-06 10:41:41 UTC
*** Bug 410643 has been marked as a duplicate of this bug. ***