Bug 407277 - KOrganizer crash on start after upgrade to 19.04
Summary: KOrganizer crash on start after upgrade to 19.04
Status: RESOLVED DUPLICATE of bug 406411
Alias: None
Product: korgac
Classification: Applications
Component: general (show other bugs)
Version: unspecified
Platform: Kubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 413575 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-05-06 21:05 UTC by wdmlist
Modified: 2019-10-29 06:11 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description wdmlist 2019-05-06 21:05:55 UTC
SUMMARY
Application: KOrganizer Reminder Daemon (korgac), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fcac6d18a80 (LWP 20248))]

Thread 5 (Thread 0x7fcabedee700 (LWP 20252)):
#0  0x00007fcace0a1729 in __GI___poll (fds=0x7fcaac004e30, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fcacbad9cb6 in g_main_context_poll (priority=<optimized out>, n_fds=1, fds=0x7fcaac004e30, timeout=<optimized out>, context=0x7fcaac000bf0) at ../../../glib/gmain.c:4228
#2  g_main_context_iterate (context=context@entry=0x7fcaac000bf0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../../../glib/gmain.c:3922
#3  0x00007fcacbad9ddc in g_main_context_iteration (context=0x7fcaac000bf0, may_block=may_block@entry=1) at ../../../glib/gmain.c:3988
#4  0x00007fcace63e063 in QEventDispatcherGlib::processEvents (this=0x7fcaac000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007fcace5e95bb in QEventLoop::exec (this=this@entry=0x7fcabededb20, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:140
#6  0x00007fcace4342c6 in QThread::exec (this=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qflags.h:120
#7  0x00007fcace435612 in QThreadPrivate::start (arg=0x55fa9899f790) at thread/qthread_unix.cpp:361
#8  0x00007fcacc329182 in start_thread (arg=<optimized out>) at pthread_create.c:486
#9  0x00007fcace0adb1f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7fcabf5ef700 (LWP 20251)):
#0  0x00007fcacbb24949 in g_mutex_lock (mutex=mutex@entry=0x7fcab4000bf0) at ../../../glib/gthread-posix.c:1354
#1  0x00007fcacbad91f5 in g_main_context_prepare (context=context@entry=0x7fcab4000bf0, priority=priority@entry=0x7fcabf5ee9d0) at ../../../glib/gmain.c:3502
#2  0x00007fcacbad9beb in g_main_context_iterate (context=context@entry=0x7fcab4000bf0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../../../glib/gmain.c:3907
#3  0x00007fcacbad9ddc in g_main_context_iteration (context=0x7fcab4000bf0, may_block=may_block@entry=1) at ../../../glib/gmain.c:3988
#4  0x00007fcace63e063 in QEventDispatcherGlib::processEvents (this=0x7fcab4000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#5  0x00007fcace5e95bb in QEventLoop::exec (this=this@entry=0x7fcabf5eeb20, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:140
#6  0x00007fcace4342c6 in QThread::exec (this=<optimized out>) at ../../include/QtCore/../../src/corelib/global/qflags.h:120
#7  0x00007fcace435612 in QThreadPrivate::start (arg=0x55fa988dd930) at thread/qthread_unix.cpp:361
#8  0x00007fcacc329182 in start_thread (arg=<optimized out>) at pthread_create.c:486
#9  0x00007fcace0adb1f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7fcac4aa5700 (LWP 20250)):
#0  __GI___libc_read (nbytes=16, buf=0x7fcac4aa48d0, fd=7) at ../sysdeps/unix/sysv/linux/read.c:26
#1  __GI___libc_read (fd=7, buf=buf@entry=0x7fcac4aa48d0, nbytes=nbytes@entry=16) at ../sysdeps/unix/sysv/linux/read.c:24
#2  0x00007fcacbb20550 in read (__nbytes=16, __buf=0x7fcac4aa48d0, __fd=<optimized out>) at /usr/include/x86_64-linux-gnu/bits/unistd.h:44
#3  g_wakeup_acknowledge (wakeup=0x55fa98949fb0) at ../../../glib/gwakeup.c:210
#4  0x00007fcacbad978f in g_main_context_check (context=context@entry=0x7fcab8000bf0, max_priority=2147483647, fds=fds@entry=0x7fcab8025200, n_fds=n_fds@entry=1) at ../../../glib/gmain.c:3705
#5  0x00007fcacbad9c60 in g_main_context_iterate (context=context@entry=0x7fcab8000bf0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../../../glib/gmain.c:3924
#6  0x00007fcacbad9ddc in g_main_context_iteration (context=0x7fcab8000bf0, may_block=may_block@entry=1) at ../../../glib/gmain.c:3988
#7  0x00007fcace63e063 in QEventDispatcherGlib::processEvents (this=0x7fcab8000b20, flags=...) at kernel/qeventdispatcher_glib.cpp:424
#8  0x00007fcace5e95bb in QEventLoop::exec (this=this@entry=0x7fcac4aa4af0, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:140
#9  0x00007fcace4342c6 in QThread::exec (this=this@entry=0x7fcace936d80 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at ../../include/QtCore/../../src/corelib/global/qflags.h:120
#10 0x00007fcace8b6565 in QDBusConnectionManager::run (this=0x7fcace936d80 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at qdbusconnection.cpp:178
#11 0x00007fcace435612 in QThreadPrivate::start (arg=0x7fcace936d80 <(anonymous namespace)::Q_QGS__q_manager::innerFunction()::holder>) at thread/qthread_unix.cpp:361
#12 0x00007fcacc329182 in start_thread (arg=<optimized out>) at pthread_create.c:486
#13 0x00007fcace0adb1f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7fcac5a6f700 (LWP 20249)):
#0  0x00007fcace0a1729 in __GI___poll (fds=fds@entry=0x7fcac5a6ea28, nfds=nfds@entry=1, timeout=timeout@entry=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fcacc559917 in poll (__timeout=-1, __nfds=1, __fds=0x7fcac5a6ea28) at /usr/include/x86_64-linux-gnu/bits/poll2.h:46
#2  _xcb_conn_wait (c=c@entry=0x55fa988e30a0, cond=cond@entry=0x55fa988e30e0, vector=vector@entry=0x0, count=count@entry=0x0) at ../../src/xcb_conn.c:479
#3  0x00007fcacc55b53a in xcb_wait_for_event (c=c@entry=0x55fa988e30a0) at ../../src/xcb_in.c:697
#4  0x00007fcac66566a8 in QXcbEventQueue::run (this=0x55fa988d4140) at qxcbeventqueue.cpp:228
#5  0x00007fcace435612 in QThreadPrivate::start (arg=0x55fa988d4140) at thread/qthread_unix.cpp:361
#6  0x00007fcacc329182 in start_thread (arg=<optimized out>) at pthread_create.c:486
#7  0x00007fcace0adb1f in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7fcac6d18a80 (LWP 20248)):
[KCrash Handler]
#6  0x00007fcad0095904 in Akonadi::BlockAlarmsAttribute::isAlarmTypeBlocked(KCalCore::Alarm::Type) const () from /usr/lib/x86_64-linux-gnu/libKF5AkonadiCalendar.so.5abi2
#7  0x00007fcad00a854c in Akonadi::ETMCalendar::alarms(QDateTime const&, QDateTime const&, bool) const () from /usr/lib/x86_64-linux-gnu/libKF5AkonadiCalendar.so.5abi2
#8  0x000055fa9767cb39 in KOAlarmClient::checkAlarms (this=0x7ffc9d840690) at /usr/include/x86_64-linux-gnu/qt5/QtCore/qsharedpointer_impl.h:312
#9  0x000055fa9767d915 in KOAlarmClient::deferredInit (this=0x7ffc9d840690) at ./korgac/koalarmclient.cpp:169
#10 0x00007fcace614563 in QtPrivate::QSlotObjectBase::call (a=0x7ffc9d83fd80, r=0x7ffc9d840690, this=0x55fa989e46c0) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#11 QMetaObject::activate (sender=0x7fcaac005960, signalOffset=<optimized out>, local_signal_index=<optimized out>, argv=<optimized out>) at kernel/qobject.cpp:3774
#12 0x00007fcacfb6b042 in Akonadi::EntityTreeModel::collectionPopulated (this=<optimized out>, _t1=<optimized out>) at ./obj-x86_64-linux-gnu/src/core/KF5AkonadiCore_autogen/include/moc_entitytreemodel.cpp:513
#13 0x00007fcacfb768db in Akonadi::EntityTreeModelPrivate::itemFetchJobDone (this=0x55fa989db150, job=<optimized out>) at ./src/core/models/entitytreemodel_p.cpp:1384
#14 0x00007fcacfb6c250 in Akonadi::EntityTreeModel::qt_static_metacall (_o=<optimized out>, _c=<optimized out>, _id=<optimized out>, _a=<optimized out>) at ./src/core/models/entitytreemodel.h:681
#15 0x00007fcace614426 in QMetaObject::activate (sender=0x55fa98a16ee0, signalOffset=<optimized out>, local_signal_index=<optimized out>, argv=<optimized out>) at kernel/qobject.cpp:3793
#16 0x00007fcacf5f2f5c in KJob::result(KJob*, KJob::QPrivateSignal) () from /usr/lib/x86_64-linux-gnu/libKF5CoreAddons.so.5
#17 0x00007fcacf5f3a23 in KJob::finishJob(bool) () from /usr/lib/x86_64-linux-gnu/libKF5CoreAddons.so.5
#18 0x00007fcace620166 in QtPrivate::QSlotObjectBase::call (a=0x7ffc9d840000, r=<optimized out>, this=<optimized out>) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:394
#19 QSingleShotTimer::timerEvent (this=0x55fa99922ed0) at kernel/qtimer.cpp:318
#20 0x00007fcace614c5b in QObject::event (this=0x55fa99922ed0, e=<optimized out>) at kernel/qobject.cpp:1241
#21 0x00007fcacf0b0551 in QApplicationPrivate::notify_helper (this=this@entry=0x55fa988d1310, receiver=receiver@entry=0x55fa99922ed0, e=e@entry=0x7ffc9d840320) at kernel/qapplication.cpp:3736
#22 0x00007fcacf0b7930 in QApplication::notify (this=0x7ffc9d840660, receiver=0x55fa99922ed0, e=0x7ffc9d840320) at kernel/qapplication.cpp:3483
#23 0x00007fcace5ea8e9 in QCoreApplication::notifyInternal2 (receiver=0x55fa99922ed0, event=0x7ffc9d840320) at ../../include/QtCore/5.12.2/QtCore/private/../../../../../src/corelib/thread/qthread_p.h:322
#24 0x00007fcace63d453 in QTimerInfoList::activateTimers (this=0x55fa98943310) at kernel/qtimerinfo_unix.cpp:643
#25 0x00007fcace63dca4 in timerSourceDispatch (source=<optimized out>) at kernel/qeventdispatcher_glib.cpp:182
#26 0x00007fcacbad9aae in g_main_dispatch (context=0x7fcac0004fd0) at ../../../glib/gmain.c:3189
#27 g_main_context_dispatch (context=context@entry=0x7fcac0004fd0) at ../../../glib/gmain.c:3854
#28 0x00007fcacbad9d48 in g_main_context_iterate (context=context@entry=0x7fcac0004fd0, block=block@entry=1, dispatch=dispatch@entry=1, self=<optimized out>) at ../../../glib/gmain.c:3927
#29 0x00007fcacbad9ddc in g_main_context_iteration (context=0x7fcac0004fd0, may_block=may_block@entry=1) at ../../../glib/gmain.c:3988
#30 0x00007fcace63e047 in QEventDispatcherGlib::processEvents (this=0x55fa98944af0, flags=...) at kernel/qeventdispatcher_glib.cpp:422
#31 0x00007fcace5e95bb in QEventLoop::exec (this=this@entry=0x7ffc9d840580, flags=..., flags@entry=...) at ../../include/QtCore/../../src/corelib/global/qflags.h:140
#32 0x00007fcace5f15e2 in QCoreApplication::exec () at ../../include/QtCore/../../src/corelib/global/qflags.h:120
#33 0x00007fcaceab4e4c in QGuiApplication::exec () at kernel/qguiapplication.cpp:1779
#34 0x00007fcacf0b04c5 in QApplication::exec () at kernel/qapplication.cpp:2893
#35 0x000055fa9767b4af in main (argc=<optimized out>, argv=<optimized out>) at ./korgac/korgacmain.cpp:68
[Inferior 1 (process 20248) detached]


STEPS TO REPRODUCE
1. Setup Akonadi with useful calendars and have reminders
2. Upgrade from Kubuntu 18.10, to 19.04
3. Start Kubuntu 19.04 with pending reminders

OBSERVED RESULT
Crash

EXPECTED RESULT


SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 
KDE Frameworks Version: 
Qt Version: 

ADDITIONAL INFORMATION
Comment 1 Wolfgang Bauer 2019-05-07 07:41:13 UTC

*** This bug has been marked as a duplicate of bug 406411 ***
Comment 2 Wolfgang Bauer 2019-10-29 06:11:43 UTC
*** Bug 413575 has been marked as a duplicate of this bug. ***