Bug 406428 - Video preview - no sound
Summary: Video preview - no sound
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Preview-Video (show other bugs)
Version: 6.1.0
Platform: Appimage Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-04-11 09:17 UTC by andrej.valencic
Modified: 2019-07-23 20:18 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 6.2.0


Attachments
Video codec info (66.06 KB, image/png)
2019-04-11 09:17 UTC, andrej.valencic
Details
Log (56.30 KB, text/plain)
2019-04-11 12:17 UTC, andrej.valencic
Details
No sound log file DK 6.2.0 AppImage (54.99 KB, text/plain)
2019-07-17 07:44 UTC, andrej.valencic
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andrej.valencic 2019-04-11 09:17:14 UTC
Created attachment 119351 [details]
Video codec info

SUMMARY
During video preview there is no sound

OBSERVED RESULT
When I try to preview a video (mp4) in digiKam, the playback of video is OK but there is no sound. Do I have to do something else to get the sound - install some additional packages and/or set something in digiKam? The sound is OK when I play the same video with VLC.

EXPECTED RESULT


SOFTWARE/OS VERSIONS
Windows: 
macOS: 
Linux/KDE Plasma: 

Ubuntu 18.10
KDE Frameworks 5.56.0
Qt 5.11.3 (built against 5.11.3)
The xcb windowing system

KDE Plasma Version: 
KDE Frameworks Version: 
Qt Version: 

ADDITIONAL INFORMATION
The sound is OK on my Windows 10 machine with digiKam 5.9 installed.
Comment 1 caulier.gilles 2019-04-11 09:39:37 UTC
Hi,

Can you share the video on the cloud to try to reproduce the dysfunction here on my computer. I must investiguate to see if it miss something, as i updated the ffmpeg version to last 3.3.9 stable release (not yet the 4.1.0 which require more works)

Best

Gilles Caulier
Comment 3 Maik Qualmann 2019-04-11 10:37:22 UTC
This video has with the AppImage sound here. in digiKam-6.1.0 there is now a volume control which is set to 50% after the start of digiKam. Maybe too quiet?

Maik
Comment 4 andrej.valencic 2019-04-11 10:53:02 UTC
No, the volume level was the first thing I checked (forgot to mention, sorry) - even on 100% there is no sound.

In the meantime I tried on my laptop with Linux Mint 19.1 and also no sound is present (but Mint is Ubuntu based so it is not much of a difference).

Which Linux distribution are you using?
Comment 5 Maik Qualmann 2019-04-11 11:24:08 UTC
My native developer version and AppImage run here under openSUSE Tumbleweed. Just tested under Windows7, also here is sound. Please post the console log from the the beginning of digiKam until the video is played.

Maik
Comment 6 andrej.valencic 2019-04-11 12:17:05 UTC
Created attachment 119354 [details]
Log
Comment 7 andrej.valencic 2019-04-11 12:18:39 UTC
I'm not sure I get the log that you asked for - I never did this before. If you need something else, please let me know how to get it.

Andrej
Comment 8 Maik Qualmann 2019-04-11 16:32:37 UTC
Yes, that's the right log. It has no abnormalities, also here in the AppImage is only the OpenAL sound backend available. My Native digiKam version also finds Pulse. Do not you only have no sound with this video or generally no sound?

>Digikam::MediaPlayerView::MediaPlayerView: AudioOutput backends: ("OpenAL", "null")

Maik
Comment 9 Maik Qualmann 2019-04-11 16:41:00 UTC
OpenAL packages installed?

Maik
Comment 10 andrej.valencic 2019-04-12 06:35:41 UTC
That I wouldn't know. I never installed anything about OpenAL explicitly - so maybe not?! I'll check this out and report back.
Comment 11 caulier.gilles 2019-04-12 07:18:59 UTC
Note : AppImage maintainer report me that OpenAL must be included in the bundle to prevent this problem but... if i do it digiKAm crash into QtAV.

Also OpenAL is a low level layer near Linux kernel. this one must be installed on the system, there is no choice (as plenty of other low level libraries).

If it's not installed, there is no sound with video, but application do not crash. So for me it's acceptable.

Gilles Caulier
Comment 12 andrej.valencic 2019-04-12 07:30:10 UTC
So I installed some packages (libopenal1, libopenal-dev, openal-info) but still no sound is comming from videos. Here is the output of openal-info:

root@aval-mint:~# openal-info 
Available playback devices:
    Built-in Audio Analog Stereo
Available capture devices:
    Built-in Audio Analog Stereo
    Monitor of Built-in Audio Analog Stereo
Default playback device: Built-in Audio Analog Stereo
Default capture device: Built-in Audio Analog Stereo
ALC version: 1.1

** Info for device "Built-in Audio Analog Stereo" **
ALC version: 1.1
ALC extensions:
    ALC_ENUMERATE_ALL_EXT, ALC_ENUMERATION_EXT, ALC_EXT_CAPTURE,
    ALC_EXT_DEDICATED, ALC_EXT_disconnect, ALC_EXT_EFX,
    ALC_EXT_thread_local_context, ALC_SOFTX_device_clock, ALC_SOFT_HRTF,
    ALC_SOFT_loopback, ALC_SOFT_output_limiter, ALC_SOFT_pause_device
Available HRTFs:
    default-44100
    default-48000
OpenAL vendor string: OpenAL Community
OpenAL renderer string: OpenAL Soft
OpenAL version string: 1.1 ALSOFT 1.18.2
OpenAL extensions:
    AL_EXT_ALAW, AL_EXT_BFORMAT, AL_EXT_DOUBLE, AL_EXT_EXPONENT_DISTANCE,
    AL_EXT_FLOAT32, AL_EXT_IMA4, AL_EXT_LINEAR_DISTANCE, AL_EXT_MCFORMATS,
    AL_EXT_MULAW, AL_EXT_MULAW_BFORMAT, AL_EXT_MULAW_MCFORMATS, AL_EXT_OFFSET,
    AL_EXT_source_distance_model, AL_EXT_SOURCE_RADIUS, AL_EXT_STEREO_ANGLES,
    AL_LOKI_quadriphonic, AL_SOFT_block_alignment, AL_SOFT_deferred_updates,
    AL_SOFT_direct_channels, AL_SOFT_gain_clamp_ex, AL_SOFT_loop_points,
    AL_SOFT_MSADPCM, AL_SOFT_source_latency, AL_SOFT_source_length,
    AL_SOFT_source_resampler, AL_SOFT_source_spatialize
Available resamplers:
    Nearest
    Linear *
    4-Point Sinc
    Band-limited Sinc (12/24)
EFX version: 1.0
Max auxiliary sends: 2
Supported filters:
    Low-pass, High-pass, Band-pass
Supported effects:
    EAX Reverb, Reverb, Chorus, Distortion, Echo, Flanger, Ring Modulator,
    Compressor, Equalizer, Dedicated Dialog, Dedicated LFE
root@aval-mint:~# 

Enything else I need to install perhaps?
Comment 13 caulier.gilles 2019-04-12 07:37:42 UTC
Look here :

https://cgit.kde.org/digikam.git/tree/project/bundles/appimage/04-build-appimage.sh#n354

This script clean up the low level dependencies while AppImage bundle is packaged.

libopenal1.so is removed, abut also libasound.so.2

https://cgit.kde.org/digikam.git/tree/project/bundles/appimage/04-build-appimage.sh#n277

So check well if both shared libraries are installed on your system.

Gilles Caulier
Comment 14 andrej.valencic 2019-04-12 08:53:54 UTC
I've checked for the libraries and both are installed (I presume you ment libopenal.so.1 and not libopenal1.so):

/usr/lib/x86_64-linux-gnu/libopenal.so.1
/usr/lib/x86_64-linux-gnu/libasound.so.2
Comment 15 andrej.valencic 2019-04-12 08:59:49 UTC
(In reply to Maik Qualmann from comment #8)
> Yes, that's the right log. It has no abnormalities, also here in the
> AppImage is only the OpenAL sound backend available. My Native digiKam
> version also finds Pulse. Do not you only have no sound with this video or
> generally no sound?
> 
> >Digikam::MediaPlayerView::MediaPlayerView: AudioOutput backends: ("OpenAL", "null")
> 
> Maik

I've checked about the Pulse and it is installed on my system - don't know why it is not detected.
I only have prob)lems with sound within digiKam, all the others media players installed work fine (VLC, Media Player)
Comment 16 Maik Qualmann 2019-05-18 08:58:26 UTC
*** Bug 407680 has been marked as a duplicate of this bug. ***
Comment 17 caulier.gilles 2019-05-30 13:34:05 UTC
I back now to investiguate about this problem :

See below the ffmpeg 3.3.9 configuration trace while AppImage build :

[100%] Performing configure step for 'ext_ffmpeg'
install prefix            /usr
source path               /b/ext_ffmpeg/ext_ffmpeg-prefix/src/ext_ffmpeg
C compiler                gcc
C library                 glibc
ARCH                      x86 (generic)
big-endian                no
runtime cpu detection     yes
yasm                      yes
MMX enabled               yes
MMXEXT enabled            yes
3DNow! enabled            yes
3DNow! extended enabled   yes
SSE enabled               yes
SSSE3 enabled             yes
AESNI enabled             yes
AVX enabled               yes
XOP enabled               yes
FMA3 enabled              yes
FMA4 enabled              yes
i686 features enabled     yes
CMOV is fast              yes
EBX available             yes
EBP available             yes
debug symbols             no
strip symbols             yes
optimize for size         no
optimizations             yes
static                    yes
shared                    yes
postprocessing support    yes
network support           yes
threading support         pthreads
safe bitstream reader     yes
texi2html enabled         no
perl enabled              yes
pod2man enabled           yes
makeinfo enabled          no
makeinfo supports HTML    no

External libraries:
bzlib			libopus			libxcb
iconv			librtmp			libxcb_shape
libass			libspeex		libxcb_shm
libfdk_aac		libtheora		libxcb_xfixes
libfreetype		libvorbis		libxvid
libmp3lame		libvpx			lzma
libopencore_amrnb	libx264			xlib
libopencore_amrwb	libx265			zlib

External libraries providing hardware acceleration:
cuda			cuvid			nvenc

Libraries:
avcodec			avformat		swresample
avdevice		avutil			swscale
avfilter		postproc

Programs:
ffmpeg			ffprobe

Enabled decoders:
aac			aura			ffv1
aac_fixed		aura2			ffvhuff
aac_latm		avrn			ffwavesynth
aasc			avrp			fic
ac3			avs			flac
ac3_fixed		avui			flashsv
adpcm_4xm		ayuv			flashsv2
adpcm_adx		bethsoftvid		flic
adpcm_afc		bfi			flv
adpcm_aica		bink			fmvc
adpcm_ct		binkaudio_dct		fourxm
adpcm_dtk		binkaudio_rdft		fraps
adpcm_ea		bintext			frwu
adpcm_ea_maxis_xa	bmp			g2m
adpcm_ea_r1		bmv_audio		g723_1
adpcm_ea_r2		bmv_video		g729
adpcm_ea_r3		brender_pix		gif
adpcm_ea_xas		c93			gsm
adpcm_g722		cavs			gsm_ms
adpcm_g726		ccaption		h261
adpcm_g726le		cdgraphics		h263
adpcm_ima_amv		cdxl			h263i
adpcm_ima_apc		cfhd			h263p
adpcm_ima_dat4		cinepak			h264
adpcm_ima_dk3		clearvideo		h264_cuvid
adpcm_ima_dk4		cljr			hap
adpcm_ima_ea_eacs	cllc			hevc
adpcm_ima_ea_sead	comfortnoise		hevc_cuvid
adpcm_ima_iss		cook			hnm4_video
adpcm_ima_oki		cpia			hq_hqa
adpcm_ima_qt		cscd			hqx
adpcm_ima_rad		cyuv			huffyuv
adpcm_ima_smjpeg	dca			iac
adpcm_ima_wav		dds			idcin
adpcm_ima_ws		dfa			idf
adpcm_ms		dirac			iff_ilbm
adpcm_mtaf		dnxhd			imc
adpcm_psx		dpx			indeo2
adpcm_sbpro_2		dsd_lsbf		indeo3
adpcm_sbpro_3		dsd_lsbf_planar		indeo4
adpcm_sbpro_4		dsd_msbf		indeo5
adpcm_swf		dsd_msbf_planar		interplay_acm
adpcm_thp		dsicinaudio		interplay_dpcm
adpcm_thp_le		dsicinvideo		interplay_video
adpcm_vima		dss_sp			jacosub
adpcm_xa		dst			jpeg2000
adpcm_yamaha		dvaudio			jpegls
aic			dvbsub			jv
alac			dvdsub			kgv1
alias_pix		dvvideo			kmvc
als			dxa			lagarith
amrnb			dxtory			libfdk_aac
amrwb			dxv			libopencore_amrnb
amv			eac3			libopencore_amrwb
anm			eacmv			libopus
ansi			eamad			libspeex
ape			eatgq			libvorbis
apng			eatgv			libvpx_vp8
ass			eatqi			libvpx_vp9
asv1			eightbps		loco
asv2			eightsvx_exp		m101
atrac1			eightsvx_fib		mace3
atrac3			escape124		mace6
atrac3al		escape130		magicyuv
atrac3p			evrc			mdec
atrac3pal		exr			metasound
microdvd		pcm_s24daud		smc
mimic			pcm_s24le		smvjpeg
mjpeg			pcm_s24le_planar	snow
mjpeg_cuvid		pcm_s32be		sol_dpcm
mjpegb			pcm_s32le		sonic
mlp			pcm_s32le_planar	sp5x
mmvideo			pcm_s64be		speedhq
motionpixels		pcm_s64le		srt
movtext			pcm_s8			ssa
mp1			pcm_s8_planar		stl
mp1float		pcm_u16be		subrip
mp2			pcm_u16le		subviewer
mp2float		pcm_u24be		subviewer1
mp3			pcm_u24le		sunrast
mp3adu			pcm_u32be		svq1
mp3adufloat		pcm_u32le		svq3
mp3float		pcm_u8			tak
mp3on4			pcm_zork		targa
mp3on4float		pcx			targa_y216
mpc7			pgm			tdsc
mpc8			pgmyuv			text
mpeg1_cuvid		pgssub			theora
mpeg1video		pictor			thp
mpeg2_cuvid		pixlet			tiertexseqvideo
mpeg2video		pjs			tiff
mpeg4			png			tmv
mpeg4_cuvid		ppm			truehd
mpegvideo		prores			truemotion1
mpl2			prores_lgpl		truemotion2
msa1			psd			truemotion2rt
msmpeg4v1		ptx			truespeech
msmpeg4v2		qcelp			tscc
msmpeg4v3		qdm2			tscc2
msrle			qdmc			tta
mss1			qdraw			twinvq
mss2			qpeg			txd
msvideo1		qtrle			ulti
mszh			r10k			utvideo
mts2			r210			v210
mvc1			ra_144			v210x
mvc2			ra_288			v308
mxpeg			ralf			v408
nellymoser		rawvideo		v410
nuv			realtext		vb
on2avc			rl2			vble
opus			roq			vc1
paf_audio		roq_dpcm		vc1_cuvid
paf_video		rpza			vc1image
pam			rscc			vcr1
pbm			rv10			vmdaudio
pcm_alaw		rv20			vmdvideo
pcm_bluray		rv30			vmnc
pcm_dvd			rv40			vorbis
pcm_f16le		s302m			vp3
pcm_f24le		sami			vp5
pcm_f32be		sanm			vp6
pcm_f32le		scpr			vp6a
pcm_f64be		screenpresso		vp6f
pcm_f64le		sdx2_dpcm		vp7
pcm_lxf			sgi			vp8
pcm_mulaw		sgirle			vp8_cuvid
pcm_s16be		sheervideo		vp9
pcm_s16be_planar	shorten			vp9_cuvid
pcm_s16le		sipr			vplayer
pcm_s16le_planar	smackaud		vqa
pcm_s24be		smacker			wavpack
webp			wnv1			xpm
webvtt			ws_snd1			xsub
wmalossless		xan_dpcm		xwd
wmapro			xan_wc3			y41p
wmav1			xan_wc4			ylc
wmav2			xbin			yop
wmavoice		xbm			yuv4
wmv1			xface			zero12v
wmv2			xl			zerocodec
wmv3			xma1			zlib
wmv3image		xma2			zmbv

Enabled encoders:
a64multi		libtheora		pcx
a64multi5		libvorbis		pgm
aac			libvpx_vp8		pgmyuv
ac3			libvpx_vp9		png
ac3_fixed		libx264			ppm
adpcm_adx		libx264rgb		prores
adpcm_g722		libx265			prores_aw
adpcm_g726		libxvid			prores_ks
adpcm_ima_qt		ljpeg			qtrle
adpcm_ima_wav		mjpeg			r10k
adpcm_ms		mlp			r210
adpcm_swf		movtext			ra_144
adpcm_yamaha		mp2			rawvideo
alac			mp2fixed		roq
alias_pix		mpeg1video		roq_dpcm
amv			mpeg2video		rv10
apng			mpeg4			rv20
ass			msmpeg4v2		s302m
asv1			msmpeg4v3		sgi
asv2			msvideo1		snow
avrp			nellymoser		sonic
avui			nvenc			sonic_ls
ayuv			nvenc_h264		srt
bmp			nvenc_hevc		ssa
cinepak			opus			subrip
cljr			pam			sunrast
comfortnoise		pbm			svq1
dca			pcm_alaw		targa
dnxhd			pcm_f32be		text
dpx			pcm_f32le		tiff
dvbsub			pcm_f64be		truehd
dvdsub			pcm_f64le		tta
dvvideo			pcm_mulaw		utvideo
eac3			pcm_s16be		v210
ffv1			pcm_s16be_planar	v308
ffvhuff			pcm_s16le		v408
flac			pcm_s16le_planar	v410
flashsv			pcm_s24be		vc2
flashsv2		pcm_s24daud		vorbis
flv			pcm_s24le		wavpack
g723_1			pcm_s24le_planar	webvtt
gif			pcm_s32be		wmav1
h261			pcm_s32le		wmav2
h263			pcm_s32le_planar	wmv1
h263p			pcm_s64be		wmv2
h264_nvenc		pcm_s64le		wrapped_avframe
hevc_nvenc		pcm_s8			xbm
huffyuv			pcm_s8_planar		xface
jpeg2000		pcm_u16be		xsub
jpegls			pcm_u16le		xwd
libfdk_aac		pcm_u24be		y41p
libmp3lame		pcm_u24le		yuv4
libopencore_amrnb	pcm_u32be		zlib
libopus			pcm_u32le		zmbv
libspeex		pcm_u8

Enabled hwaccels:
h264_cuvid		mpeg1_cuvid		vc1_cuvid
hevc_cuvid		mpeg2_cuvid		vp8_cuvid
mjpeg_cuvid		mpeg4_cuvid		vp9_cuvid

Enabled parsers:
aac			dvdsub			opus
aac_latm		flac			png
ac3			g729			pnm
adx			gsm			rv30
bmp			h261			rv40
cavsvideo		h263			sipr
cook			h264			tak
dca			hevc			vc1
dirac			mjpeg			vorbis
dnxhd			mlp			vp3
dpx			mpeg4video		vp8
dvaudio			mpegaudio		vp9
dvbsub			mpegvideo		xma
dvd_nav

Enabled demuxers:
aa			flic			mgsts
aac			flv			microdvd
ac3			fourxm			mjpeg
acm			frm			mjpeg_2000
act			fsb			mlp
adf			g722			mlv
adp			g723_1			mm
ads			g729			mmf
adx			genh			mov
aea			gif			mp3
afc			gsm			mpc
aiff			gxf			mpc8
aix			h261			mpegps
amr			h263			mpegts
anm			h264			mpegtsraw
apc			hevc			mpegvideo
ape			hls			mpjpeg
apng			hnm			mpl2
aqtitle			ico			mpsub
asf			idcin			msf
asf_o			idf			msnwc_tcp
ass			iff			mtaf
ast			ilbc			mtv
au			image2			musx
avi			image2_alias_pix	mv
avr			image2_brender_pix	mvi
avs			image2pipe		mxf
bethsoftvid		image_bmp_pipe		mxg
bfi			image_dds_pipe		nc
bfstm			image_dpx_pipe		nistsphere
bink			image_exr_pipe		nsv
bintext			image_j2k_pipe		nut
bit			image_jpeg_pipe		nuv
bmv			image_jpegls_pipe	ogg
boa			image_pam_pipe		oma
brstm			image_pbm_pipe		paf
c93			image_pcx_pipe		pcm_alaw
caf			image_pgm_pipe		pcm_f32be
cavsvideo		image_pgmyuv_pipe	pcm_f32le
cdg			image_pictor_pipe	pcm_f64be
cdxl			image_png_pipe		pcm_f64le
cine			image_ppm_pipe		pcm_mulaw
concat			image_psd_pipe		pcm_s16be
data			image_qdraw_pipe	pcm_s16le
daud			image_sgi_pipe		pcm_s24be
dcstr			image_sunrast_pipe	pcm_s24le
dfa			image_tiff_pipe		pcm_s32be
dirac			image_webp_pipe		pcm_s32le
dnxhd			image_xpm_pipe		pcm_s8
dsf			ingenient		pcm_u16be
dsicin			ipmovie			pcm_u16le
dss			ircam			pcm_u24be
dts			iss			pcm_u24le
dtshd			iv8			pcm_u32be
dv			ivf			pcm_u32le
dvbsub			ivr			pcm_u8
dvbtxt			jacosub			pjs
dxa			jv			pmp
ea			live_flv		pva
ea_cdata		lmlm4			pvf
eac3			loas			qcp
epaf			lrc			r3d
ffm			lvf			rawvideo
ffmetadata		lxf			realtext
filmstrip		m4v			redspark
flac			matroska		rl2
rm			srt			vmd
roq			stl			vobsub
rpl			str			voc
rsd			subviewer		vpk
rso			subviewer1		vplayer
rtp			sup			vqf
rtsp			svag			w64
sami			swf			wav
sap			tak			wc3
sbg			tedcaptions		webm_dash_manifest
scc			thp			webvtt
sdp			threedostr		wsaud
sdr2			tiertexseq		wsd
sds			tmv			wsvqa
sdx			truehd			wtv
segafilm		tta			wv
shorten			tty			wve
siff			txd			xa
sln			v210			xbin
smacker			v210x			xmv
smjpeg			vag			xvag
smush			vc1			xwma
sol			vc1t			yop
sox			vivo			yuv4mpegpipe
spdif

Enabled muxers:
a64			image2			pcm_s24le
ac3			image2pipe		pcm_s32be
adts			ipod			pcm_s32le
adx			ircam			pcm_s8
aiff			ismv			pcm_u16be
amr			ivf			pcm_u16le
apng			jacosub			pcm_u24be
asf			latm			pcm_u24le
asf_stream		lrc			pcm_u32be
ass			m4v			pcm_u32le
ast			matroska		pcm_u8
au			matroska_audio		psp
avi			md5			rawvideo
avm2			microdvd		rm
bit			mjpeg			roq
caf			mkvtimestamp_v2		rso
cavsvideo		mlp			rtp
crc			mmf			rtp_mpegts
dash			mov			rtsp
data			mp2			sap
daud			mp3			scc
dirac			mp4			segment
dnxhd			mpeg1system		singlejpeg
dts			mpeg1vcd		smjpeg
dv			mpeg1video		smoothstreaming
eac3			mpeg2dvd		sox
f4v			mpeg2svcd		spdif
ffm			mpeg2video		spx
ffmetadata		mpeg2vob		srt
fifo			mpegts			stream_segment
filmstrip		mpjpeg			swf
flac			mxf			tee
flv			mxf_d10			tg2
framecrc		mxf_opatom		tgp
framehash		null			truehd
framemd5		nut			tta
g722			oga			uncodedframecrc
g723_1			ogg			vc1
gif			ogv			vc1t
gsm			oma			voc
gxf			opus			w64
h261			pcm_alaw		wav
h263			pcm_f32be		webm
h264			pcm_f32le		webm_chunk
hash			pcm_f64be		webm_dash_manifest
hds			pcm_f64le		webp
hevc			pcm_mulaw		webvtt
hls			pcm_s16be		wtv
ico			pcm_s16le		wv
ilbc			pcm_s24be		yuv4mpegpipe

Enabled protocols:
async			httpproxy		pipe
cache			icecast			prompeg
concat			librtmp			rtp
crypto			librtmpe		srtp
data			librtmps		subfile
file			librtmpt		tcp
ftp			librtmpte		tee
gopher			md5			udp
hls			mmsh			udplite
http			mmst			unix

Enabled filters:
abench			blackframe		framerate
abitscope		blend			framestep
acompressor		boxblur			fspp
acrossfade		bwdif			gblur
acrusher		cellauto		geq
adelay			channelmap		gradfun
adrawgraph		channelsplit		haldclut
aecho			chorus			haldclutsrc
aemphasis		chromakey		hdcd
aeval			ciescope		hflip
aevalsrc		codecview		highpass
afade			color			histeq
afftfilt		colorbalance		histogram
aformat			colorchannelmixer	hqdn3d
agate			colorkey		hqx
ahistogram		colorlevels		hstack
ainterleave		colormatrix		hue
alimiter		colorspace		hwdownload
allpass			compand			hwmap
allrgb			compensationdelay	hwupload
allyuv			concat			hwupload_cuda
aloop			convolution		hysteresis
alphaextract		copy			idet
alphamerge		cover_rect		il
amerge			crop			inflate
ametadata		cropdetect		interlace
amix			crystalizer		interleave
amovie			curves			join
anequalizer		datascope		kerndeint
anoisesrc		dcshift			lenscorrection
anull			dctdnoiz		life
anullsink		deband			loop
anullsrc		decimate		loudnorm
apad			deflate			lowpass
aperms			dejudder		lut
aphasemeter		delogo			lut2
aphaser			deshake			lut3d
apulsator		detelecine		lutrgb
arealtime		dilation		lutyuv
aresample		displace		mandelbrot
areverse		drawbox			maskedclamp
aselect			drawgraph		maskedmerge
asendcmd		drawgrid		mcdeint
asetnsamples		drawtext		mergeplanes
asetpts			dynaudnorm		mestimate
asetrate		earwax			metadata
asettb			ebur128			midequalizer
ashowinfo		edgedetect		minterpolate
asidedata		elbg			movie
asplit			eq			mpdecimate
ass			equalizer		mptestsrc
astats			erosion			negate
astreamselect		extractplanes		nlmeans
atadenoise		extrastereo		nnedi
atempo			fade			noformat
atrim			fftfilt			noise
avectorscope		field			null
avgblur			fieldhint		nullsink
bandpass		fieldmatch		nullsrc
bandreject		fieldorder		overlay
bass			find_rect		owdenoise
bbox			firequalizer		pad
bench			flanger			palettegen
biquad			format			paletteuse
bitplanenoise		fps			pan
blackdetect		framepack		perms
perspective		settb			super2xsai
phase			showcqt			swaprect
pixdesctest		showfreqs		swapuv
pp			showinfo		tblend
pp7			showpalette		telecine
premultiply		showspectrum		testsrc
prewitt			showspectrumpic		testsrc2
psnr			showvolume		threshold
pullup			showwaves		thumbnail
qp			showwavespic		tile
random			shuffleframes		tinterlace
readeia608		shuffleplanes		transpose
readvitc		sidechaincompress	treble
realtime		sidechaingate		tremolo
remap			sidedata		trim
removegrain		signalstats		unsharp
removelogo		signature		uspp
repeatfields		silencedetect		vaguedenoiser
replaygain		silenceremove		vectorscope
reverse			sine			vflip
rgbtestsrc		smartblur		vibrato
rotate			smptebars		vignette
sab			smptehdbars		volume
scale			sobel			volumedetect
scale2ref		spectrumsynth		vstack
select			split			w3fdif
selectivecolor		spp			waveform
sendcmd			ssim			weave
separatefields		stereo3d		xbr
setdar			stereotools		yadif
setfield		stereowiden		yuvtestsrc
setpts			streamselect		zoompan
setsar			subtitles

Enabled bsfs:
aac_adtstoasc		hevc_mp4toannexb	mpeg4_unpack_bframes
chomp			imx_dump_header		noise
dca_core		mjpeg2jpeg		remove_extradata
dump_extradata		mjpega_dump_header	text2movsub
extract_extradata	mov2textsub		vp9_superframe
h264_mp4toannexb	mp3_header_decompress

Enabled indevs:
alsa			lavfi			v4l2
dv1394			oss			xcbgrab
fbdev

Enabled outdevs:

License: nonfree and unredistributable
Creating configuration files ...

Nothing special to see. All possible codec are avaialble, including proprietary ones of course.

ffmpeg compile fine until end, no error.

Second trace is QtAV configuration stage, after ffmpeg installation :

[100%] Performing configure step for 'ext_qtav'
-- The C compiler identification is GNU 6.3.1
-- The CXX compiler identification is GNU 6.3.1
-- Check for working C compiler: /opt/rh/devtoolset-6/root/usr/bin/cc
-- Check for working C compiler: /opt/rh/devtoolset-6/root/usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /opt/rh/devtoolset-6/root/usr/bin/c++
-- Check for working CXX compiler: /opt/rh/devtoolset-6/root/usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Qt version: 5.11.3
-- Qt prefix: /usr
-- QtAV headers prefix: /usr/include
-- QtAV libs prefix: /usr/lib
-- QtAV bins prefix: /usr/bin
-- QtAV qml prefix: /usr/qml
HAVE_AVFORMAT: /usr/include/libavformat/avformat.h
HAVE_AVCODEC: /usr/include/libavcodec/avcodec.h
HAVE_SWSCALE: /usr/include/libswscale/swscale.h
HAVE_AVUTIL: /usr/include/libavutil/avutil.h
HAVE_AVFILTER: /usr/include/libavfilter/avfilter.h
HAVE_AVDEVICE: /usr/include/libavdevice/avdevice.h
HAVE_AVRESAMPLE: HAVE_AVRESAMPLE-NOTFOUND
HAVE_SWRESAMPLE: /usr/include/libswresample/swresample.h
-- Looking for ass/ass.h
-- Looking for ass/ass.h - found
-- Looking for include file AL/al.h
-- Looking for include file AL/al.h - found
-- Looking for Pa_Initialize in portaudio
-- Looking for Pa_Initialize in portaudio - not found
-- Looking for pa_threaded_mainloop_new in pulse
-- Looking for pa_threaded_mainloop_new in pulse - not found
-- Looking for slCreateEngine in OpenSLES
-- Looking for slCreateEngine in OpenSLES - not found
-- Looking for vaInitialize in va
-- Looking for vaInitialize in va - not found
-- Configuring done
-- Generating done
 This is QtAV code from git/master branch, so the current implementation from gitHub, not the last stable 1.12.0.

As you can see only AVRESAMPLE ffmpeg component is not detected. Perhaps it's the problem...

Gilles Caulier
Comment 18 nttkde 2019-06-20 08:17:39 UTC
Hi,
I have similar bug with Digikam 6.1.0 appimage. I tried the 6.0.0 appimage as it was mentioned on some forum, and it worked.
Digikam 6.0.0 appears in PulseAudio Volume Control but 6.1.0 doesn't.
Both 6.0.0(QtAV 1.12.0) and 6.1.0(QtAV 1.12.1) have same line "Digikam::MediaPlayerView::MediaPlayerView: AudioOutput backends: ("OpenAL", "null")" in their console output.
digikam-6.2.0-git-20190503T152230-qtwebengine-x86-64.appimage did not play sound.

I'm using KDE neon 5.16
KDE Plasma Version: 5.16.1
KDE Frameworks Version: 5.59.0
Qt Version: 5.12.3

I tried with H.264(.mts) files.
I have libopenal.so.1 and libasound.so.2 installed on my system.

Let me know if I could provide some helpful logs etc.
Comment 19 deanobats 2019-06-29 09:24:14 UTC
Same issue here, appimage 6.0.0 plays sound from videos and a slider appears in the audio applications volume control in the systems tray. Appimage 6.1.0 (and 6.2.0 nightly builds) do not play audio and no application volume slider appears for digikam.

Kubuntu 18.04
KDE Plasma 5.12.7
KDA frameworks 5.44.0
Qt 5.9.5
Kernel 4.15.0-54
Comment 20 caulier.gilles 2019-06-29 10:00:24 UTC
I investiguated about this problem and the only big difference between 6.0 and 6.1 is the switch from ffmpeg 3.6 to 3.9

I check the compilation log and i cannot see anything special which can explain the dysfunction

I plan to switch back to ffmpeg 3.6

Gilles Caulier
Comment 21 caulier.gilles 2019-07-13 10:40:40 UTC
Git commit 0000cbb3169e8baf3be9133ad0cf398a0a08cead by Gilles Caulier.
Committed on 13/07/2019 at 10:37.
Pushed by cgilles into branch 'master'.

Revert back ffmpeg version from 3.3.9 to 3.3.6 for AppImage, as sound do not work while playing video.
Now QtAV is upgraded to 1.12.0 to 1.13.0 (just released)
Related: bug 399305, bug 395200

M  +3    -2    project/bundles/3rdparty/ext_ffmpeg/CMakeLists.txt

https://invent.kde.org/kde/digikam/commit/0000cbb3169e8baf3be9133ad0cf398a0a08cead
Comment 22 caulier.gilles 2019-07-13 13:18:59 UTC
In one hour, a new version of digiKam 6.2.0 pre-release 64 bits of Linux Bundle AppImage will be available in this download area :

https://files.kde.org/digikam/

Please test and report if the problem remain on your computer.

Thanks in advance

Gilles Caulier
Comment 23 nttkde 2019-07-14 07:47:16 UTC
Hi,
I tried the new appimage digikam-6.2.0-git-20190713T150018-qtwebkit-x86-64.appimage, but unfortunately it didn't seem to fix anything for me. It still doesn't appear in Pulseaudio Volume Control, and there is not sound.
Comment 24 Maik Qualmann 2019-07-14 15:44:56 UTC
I still have a 6.1.0 AppImage where the sound works.
QtAV outputs some messages, homepage etc. and at the end "capi::version: 0.6.0". This message is also available in my native digiKam version, but not in the 6.2.0 AppImage. I do not know if it's related.

Maik
Comment 25 caulier.gilles 2019-07-14 15:50:30 UTC
Maik, so you suspect a problem with QtAV, not ffmpeg. Right.

One solution can be to use official QtAv 1.12.0 instead 1.13.0 just released.

Gilles
Comment 26 Maik Qualmann 2019-07-14 16:07:53 UTC
When I clone QtAV or download the ZIP I get a empty folder "contrib/capi". But if I browse to gitlab has the folder content, but he is called there "capi @ 6a5f300". I can not do anything with it. Regardless of whether it is the cause.

Maik
Comment 27 caulier.gilles 2019-07-14 16:23:02 UTC
QtAv cloning with git is not enough. There is more to do. Look the doc:

https://github.com/wang-bin/QtAV/wiki/Build-QtAV

git clone https://github.com/wang-bin/QtAV.git
cd QtAV && git submodule update --init          <<<<<<<<< THIS LINE

Look like my CMake script miss these rules:

https://cgit.kde.org/digikam.git/tree/project/bundles/3rdparty/ext_qtav/CMakeLists.txt

With digiKAm 6.0.0 and 6.1.0, i use QtAv 1.12.0 official tarball. Since 6.1.0 release date i switch to git master code which need this second step after to checkout code...

Voilà, the explanation of the dysfunction (i hope)

Gilles
Comment 28 caulier.gilles 2019-07-14 16:28:59 UTC
Git commit 9d85916e0cae985adc46384f89a6bcd3f3a8ed74 by Gilles Caulier.
Committed on 14/07/2019 at 16:27.
Pushed by cgilles into branch 'master'.

missing to checkout QtAV extra modules
Related: bug 395200, bug 399305

M  +11   -8    project/bundles/3rdparty/ext_qtav/CMakeLists.txt

https://invent.kde.org/kde/digikam/commit/9d85916e0cae985adc46384f89a6bcd3f3a8ed74
Comment 29 caulier.gilles 2019-07-17 05:57:32 UTC
Andrej,

I switch back QtAv to 1.12.0 branch as for DK 6.1.0. AppImage 64 bits have been rebuild and uploaded to https://files.kde.org/digikam/

Problem remain on your computer ?

Gilles Caulier
Comment 30 andrej.valencic 2019-07-17 07:44:08 UTC
Created attachment 121573 [details]
No sound log file DK 6.2.0 AppImage
Comment 31 andrej.valencic 2019-07-17 07:49:12 UTC
(In reply to caulier.gilles from comment #29)

> 
> I switch back QtAv to 1.12.0 branch as for DK 6.1.0. AppImage 64 bits have
> been rebuild and uploaded to https://files.kde.org/digikam/
> 
> Problem remain on your computer ?
> 

Gilles, I'm sorry for late reply but I could not access my Linux machine for some days.

I guess you mean the 6.2.0 version not the 6.1.0? Or do you want me to test the 6.1.0 version from the main download page?

I downloaded the latest 6.2.0 this morning and tried it out. Unfortunately this problem still persists - no sounds from videos. There is a log in the new attachment if you find it useful.

Andrej
Comment 32 nttkde 2019-07-17 08:11:42 UTC
No sound here either.
Maik mentioned earlier the capi version string; I can see it in the working 6.0.0 Digikam output, but not in 6.1.0/6.2.0 where I don't have sound.
Comment 33 deanobats 2019-07-17 13:04:22 UTC
Yes, same here, appimages 6.0.0 have sound but nothing after does. Also no application volume slider in pulseaudio. Tried the latest nightly build but still no sound...appreciate your efforts to solve this one though!
Comment 34 caulier.gilles 2019-07-17 16:58:12 UTC
log from comment #30 : 

Digikam::MediaPlayerView::MediaPlayerView: Audio output backends: ("OpenAL", "null")

why the second argument for OpenAL backend is null

Gilles Culier
Comment 35 Maik Qualmann 2019-07-17 17:05:34 UTC
This is not a mistake. This is a list of audio output backends. It's a "Null" backend for no sound output. QtAV always chooses the OpenAl backend.

Maik
Comment 36 caulier.gilles 2019-07-17 17:12:50 UTC
Ok, i found another difference between 6.1.0 an 6.2.0 : libasound.so (Alsa project) was not removed from the bundle before. Now, it's deleted.

I will regenerate the AppImage now including this library.

Gilles Caulier
Comment 37 caulier.gilles 2019-07-17 17:27:48 UTC
new AppImage file will be avaialble in 5 mns at usual place. Please test and report...

Gilles Caulier
Comment 38 andrej.valencic 2019-07-17 17:31:39 UTC
I will not be able to test till Monday. I'll let you then.
Comment 39 nttkde 2019-07-17 18:06:36 UTC
(In reply to caulier.gilles from comment #37)
> new AppImage file will be avaialble in 5 mns at usual place. Please test and
> report...
> 
> Gilles Caulier

Unfortunately, didn't seem to fix it for me.
Comment 40 Maik Qualmann 2019-07-17 20:19:03 UTC
It's definitely QtAV. I started the working digiKam-6.1.0 AppImage and copied the content in the temp directory with new name. The same with the current 6.2 AppImage. Both directories are now available and can be started via the AppRun script. Now I've copied the libQtAV.so.1 and libQtAVWidgets.so.1 from 6.1 to 6.2. Then the 6.2 installation also has sound and the "capi" entry also appears.

Maik
Comment 41 Maik Qualmann 2019-07-17 20:43:42 UTC
An objdump of the two libQtAV.so.1 states that the 6.2 version is less linked to 3 libs:

libGL.so.1
libX11.so.6
libpthread.so.0

Maik
Comment 42 nttkde 2019-07-18 11:16:20 UTC
Can confirm Maik's findings; if I extract the Appimages with --appimage-extract and then copy libQtAV & libQtAVWidgets from Digikam 6.0.0 to 6.1.0 or the new 6.2.0, they start working.

objdump -p ./libQtAV.so.1 shows that 6.0.0 has those 3 extra libraries mentioned in libQtAV's "Dynamic segment", unlike in 6.1.0 or the new 6.2.0.
So, QtAV 1.12.0 in Digikam 6.0.0 and QtAV 1.12.0 in the new 6.2.0 don't seem to be similar in that way.

Apparently my (non-working) Digikam 6.1.0 is not compiled in same way as Maik's if we have different objdump output for libQtAV?
Comment 43 caulier.gilles 2019-07-20 09:47:06 UTC
Ok. now it's clear that problem is located in QtAV.

Maik, you talking about capi message fron startup trace. Look mine when i compile my native DK under Mageia7 with official QtAv devel package :

QtAV 1.12.0(Apr  1 2019, 08:40:54)
Multimedia framework base on Qt and FFmpeg.
Distributed under the terms of LGPLv2.1 or later.
Shanghai University->S3 Graphics->Deepin->PPTV, Shanghai, China Copyright (C) 2012-2016 Wang Bin (aka. Lucas Wang) wbsecg1@gmail.com
Donate: http://qtav.org/donate.html
Source: https://github.com/wang-bin/QtAV
Home page: http://qtav.org
AL lib: (WW) GetSymbol: Failed to load jack_error_callback: /lib64/libjack.so.0: undefined symbol: jack_error_callback
AL lib: (WW) jack_msg_handler: Cannot connect to server socket err = Aucun fichier ou dossier de ce type
AL lib: (WW) jack_msg_handler: Cannot connect to server request channel
AL lib: (WW) jack_msg_handler: jack server is not running or cannot be started
AL lib: (WW) jack_msg_handler: JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
AL lib: (WW) jack_msg_handler: JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
AL lib: (WW) ALCjackBackendFactory_init: jack_client_open() failed, 0x11
AL lib: (WW) alc_initconfig: Failed to initialize backend "jack"
digikam.general: Audio output backends: ("OpenAL", "Pulse", "null")
digikam.general: Number of supported audio codecs: 185
digikam.general: Number of supported video codecs: 245

Here sound is played fine...

Gilles Caulier
Comment 44 Maik Qualmann 2019-07-20 12:59:05 UTC
I also think that the "capi" entry is not relevant to this problem. Rather, those missing the linked libs, especially "libpthread.so.0".

Maik
Comment 45 caulier.gilles 2019-07-21 09:24:31 UTC
Ok, after plenty of investigations, i can said that problem is really located in QtAV.

In fact i cn reproduce the problem under Centos6 : no sound with video.

I tried to recompile QtAV 1.12 or 1.13 with cmake or qmake : same result.

I can see capi message on the console, i not sure if it's the orign of the problem.

There is nothing special to see in the console at compilation time.

The only common change to build AppImage which can influence with QtAV, is the Qt5 upgrade to 5.11.3.

I never tested before QtAV with Qt 5.11. Under Mageia 6, QtAV work fine with Qt5.9.8 and under Mageia 7 it's perfect with Qt 5.12.3

So, to fix this problem, we need a more recent and maintained Qt5. Problem: i tried to compile Qt5.12.2 under Centos6 and it fail quickly.

So, it will be time certainly to use another host Linux than Centos6 to build AppImage.

Gilles
Comment 46 caulier.gilles 2019-07-21 18:36:55 UTC
Maik,

The DK AppImage port from Centos6 to Magiea6 is under progress and advance well. All is really simpler to code under Mageia as 85% of packages are already present.

Good news : QtWebkit development is back. I see the tarball updated to time : one time in June, and one time few days ago. This want mean that cross compiling under MXE become more safe for the future.


Gilles
Comment 47 Maik Qualmann 2019-07-21 20:37:11 UTC
That is good news. Excited waiting for the finished AppImage...

Maik
Comment 48 caulier.gilles 2019-07-22 10:31:33 UTC
Good news : whole AppImage compile fine under Mageia6. I will upload the bundle in next minutes. I check the sound from a video and it work fine.

Please test with your computers when file will be available at usual place.

Gilles Caulier
Comment 49 nttkde 2019-07-22 11:32:23 UTC
Nice job, now audio seems to work :)
The newest Appimage has line "Audio output backends: ("Pulse", "OpenAL", "null")" in its console output, previously there was only OpenAL and null. So I suppose it's now using Pulse on my PC?
So I guess I can't verify if it would work on the OpenAL backend but at least for me, the bug is now fixed.
Comment 50 MarcP 2019-07-22 12:31:38 UTC
I can confirm the sound also works for me. Good job devs.
Comment 51 andrej.valencic 2019-07-22 17:32:23 UTC
Sound is back!! :D Great work from developers!
Comment 52 caulier.gilles 2019-07-22 17:42:03 UTC
"Audio output backends: ("Pulse", "OpenAL", "null")"

==> yes, the new device trace from QtAV is due to the native ffmpeg from Mageia6 which has this dependency. The Centos6 version do not have.

To resume : the port from Centos6 to MAgeia6 take 2 days. The same job to write script have take 3-4 weeks in the pass. Magiea6 is to far more easy to control than Centos6 where multimedia packages and specific tools required to compile Qt5 are so far outdated.

I we must forget Centos imediatly. This Linux box is to much complicated. It's good to make server, that all. I use it in my office for these funtions and that all.

Now, i need to build the AppImage for 32 bits target and this task will be completed.

Maik, there is a important step done with Mageia : openssl is now upgraded to a very recent version, which must fix the webservice tools identification dysfunctions.

Gilles
Comment 53 caulier.gilles 2019-07-23 20:18:19 UTC
New bundle AppImage completely rewritten under Mageia6 (instead Cento6) is available at usual place for testing :

https://files.kde.org/digikam/

This fix this sound problem with video.

Gilles Caulier