Bug 399305 - When browsing images in preview mode, videos are often not shown (black preview area), only sound is heard
Summary: When browsing images in preview mode, videos are often not shown (black previ...
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Preview-Video (show other bugs)
Version: 6.0.0
Platform: Appimage Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-10-02 12:50 UTC by Jens
Modified: 2019-07-23 20:18 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In: 6.2.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jens 2018-10-02 12:50:49 UTC
SUMMARY
see $SUBJECT

STEPS TO REPRODUCE
1. open Digikam with album where there are multiple (mp4) video files
2. Enter preview mode with the thumbnail dock at the top
3. browse through images and videos

OBSERVED RESULT
When a video file is reached, it should play back (or at least optionally play back.)

EXPECTED RESULT
Sometimes, videos are played, but no video is shown.
If I then go to the next image, view a few images, and then go back, the video plays normally.
Maybe there is a race condition with multiple consecutive video files?

This happened with Digikam 4.x, 5.x and 6.0-beta, under Ubuntu 14.04 (Unity), 16.04 (Unity) and 18.04 (KDE), on an Intel Haswell i915 graphics system. Maybe it also depends on the hardware (driver).

Currently, using Kubuntu 18.04 with KDE 5.12 and Digikam 6.0-beta 20180926xxxx.
Comment 1 Maik Qualmann 2018-10-02 14:37:54 UTC
Look here also Bug 374355. The problem here under openSUSE Tumbleweed disappeared after an update on FFmpeg 4.x and of QtAV packages. I think in AppImage we still use FFmpeg-3.x.

Maik
Comment 2 Maik Qualmann 2018-10-02 14:47:28 UTC
The problem was independent even with the QtAV own player for me reproducible and was not limited to digiKam.

Maik
Comment 3 Jens 2018-10-03 19:08:36 UTC
So what can we do about it? Move the bug to QtAV?
It is quite annoying and a bad user experience ...
Comment 4 caulier.gilles 2018-10-28 03:51:02 UTC
Yes ffmpeg 3 still used in AppImage.

The problem must be reported to QtAV, and i'm sure that an issue already exists in github project.

Gilles Caulier
Comment 5 caulier.gilles 2019-03-20 15:16:03 UTC
After 3 weeks of work, i finally completed the compilation of AppImage using Qt
5.11.3 + QWebkit 5.212.

New 6.1.0 pre-release AppImage bundle can be found here (64 bits only for the
moment) :

https://files.kde.org/digikam/

Please check if this bugzilla entry still valid.

Thanks in advance

Gilles Caulier
Comment 6 caulier.gilles 2019-07-13 10:40:36 UTC
Git commit 0000cbb3169e8baf3be9133ad0cf398a0a08cead by Gilles Caulier.
Committed on 13/07/2019 at 10:37.
Pushed by cgilles into branch 'master'.

Revert back ffmpeg version from 3.3.9 to 3.3.6 for AppImage, as sound do not work while playing video.
Now QtAV is upgraded to 1.12.0 to 1.13.0 (just released)
Related: bug 406428, bug 395200

M  +3    -2    project/bundles/3rdparty/ext_ffmpeg/CMakeLists.txt

https://invent.kde.org/kde/digikam/commit/0000cbb3169e8baf3be9133ad0cf398a0a08cead
Comment 7 caulier.gilles 2019-07-13 13:19:12 UTC
In one hour, a new version of digiKam 6.2.0 pre-release 64 bits of Linux Bundle AppImage will be available in this download area :

https://files.kde.org/digikam/

Please test and report if the problem remain on your computer.

Thanks in advance

Gilles Caulier
Comment 8 caulier.gilles 2019-07-14 16:28:59 UTC
Git commit 9d85916e0cae985adc46384f89a6bcd3f3a8ed74 by Gilles Caulier.
Committed on 14/07/2019 at 16:27.
Pushed by cgilles into branch 'master'.

missing to checkout QtAV extra modules
Related: bug 406428, bug 395200

M  +11   -8    project/bundles/3rdparty/ext_qtav/CMakeLists.txt

https://invent.kde.org/kde/digikam/commit/9d85916e0cae985adc46384f89a6bcd3f3a8ed74
Comment 9 caulier.gilles 2019-07-23 20:18:58 UTC
New bundle AppImage completely rewritten under Mageia6 (instead Cento6) is available at usual place for testing :

https://files.kde.org/digikam/

This fix this sound problem with video.

Gilles Caulier