Bug 404900 - exporting video, photo to google photo fails
Summary: exporting video, photo to google photo fails
Status: RESOLVED DUPLICATE of bug 400187
Alias: None
Product: digikam
Classification: Unclassified
Component: Plugin-WebService-Google (show other bugs)
Version: 6.2.0
Platform: openSUSE RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-02-28 10:29 UTC by Philippe ROUBACH
Modified: 2019-07-30 06:45 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Philippe ROUBACH 2019-02-28 10:29:56 UTC
SUMMARY

exporting video to google photo fails

STEPS TO REPRODUCE
1. try to export to google photo a video to an an existing album
2. after a delay you get an error message
3. 

OBSERVED RESULT

Error transferring https://photoslibrary.googleapis.com/v1/mediaItems:batchCreate - server replied: Bad Request

and

video is not added to google photo

EXPECTED RESULT

video is added in the google photo album

SOFTWARE/OS VERSIONS
Windows: 
MacOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 5.15.2
KDE Frameworks Version: 5.55.0
Qt Version: 5.12.1

ADDITIONAL INFORMATION
Comment 1 Philippe ROUBACH 2019-02-28 10:41:03 UTC
exporting a photo fails also with same error message

Error transferring https://photoslibrary.googleapis.com/v1/mediaItems:batchCreate - server replied: Bad Request
Comment 2 Philippe ROUBACH 2019-02-28 10:49:51 UTC
if i create a new album then no problem to export a photo or a video
Comment 3 Philippe ROUBACH 2019-02-28 12:32:32 UTC
no problem exporting photo, video to google drive
Comment 4 caulier.gilles 2019-02-28 12:41:23 UTC
I think Gdrive is more generic that GPhoto, and it can host all kind of files.

I'm not sure if Gphoto can really, or can always host video as well. After all Google as YouTube for that (and supporting YouTube web-service is another story). Google service fetaures change in time...

Gilles Caulier
Comment 5 Maik Qualmann 2019-02-28 12:54:43 UTC
This is a bug in the Google Photo API. We can not write in existing albums. You will see a locked folder icon in the album list.

Maik
Comment 6 Maik Qualmann 2019-02-28 12:58:01 UTC

*** This bug has been marked as a duplicate of bug 400187 ***
Comment 7 Philippe ROUBACH 2019-02-28 13:12:25 UTC
(In reply to caulier.gilles from comment #4)

> I'm not sure if Gphoto can really, or can always host video as well. 

yes today if you use G photo import tool you can still import video.
Comment 8 caulier.gilles 2019-07-27 11:51:16 UTC
Please test with 6.2.0 pre-release bundles available here :

https://files.kde.org/digikam/

Thanks in advance

Gilles Caulier
Comment 9 caulier.gilles 2019-07-27 13:14:52 UTC
Please test with 6.2.0 pre-release bundles available here :

https://files.kde.org/digikam/

Thanks in advance

Gilles Caulier
Comment 10 Philippe ROUBACH 2019-07-28 09:06:12 UTC
problem still there.

it seems the google photo api bug is still there.
Comment 11 Maik Qualmann 2019-07-28 16:41:52 UTC
Uploading videos works without problem. Just not to old existing albums and so it is a duplicate of Bug 400187.

Maik
Comment 12 Antonio Rojas 2019-07-30 06:45:09 UTC
*** Bug 410077 has been marked as a duplicate of this bug. ***