Bug 404588 - Unable to create a calendar event from email
Summary: Unable to create a calendar event from email
Status: RESOLVED FIXED
Alias: None
Product: kontact
Classification: Applications
Component: calendar (show other bugs)
Version: unspecified
Platform: Neon Linux
: NOR normal with 1 vote (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 357267 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-02-20 09:05 UTC by Nick Harvey
Modified: 2021-08-22 09:13 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nick Harvey 2019-02-20 09:05:52 UTC
SUMMARY
I am running KDE Neon 5.14.5 and Kontact 5.10.1. I have two GMail accounts configured in Kontact including their associated calendars configured. I wish to drag an email to the calendar to create a new event but this does not currently work.


STEPS TO REPRODUCE
1I want to create a new calendar event from an email, so I drag the mail from my inbox onto the Calendar icon on the left-hand side. According to this page (https://docs.kde.org/stable5/en/pim/kontact/side-pane-drag-and-drop.html) 


OBSERVED RESULT
The event subject looks as follows:

"akonadi:?item=45620&type=message/rfc822&parent=55"

I also do not get any of the email body transferred into the event body, making the feature pretty useless overall.


EXPECTED RESULT
I should get a new calendar event with the subject populated with the same subject from the email.


SOFTWARE/OS VERSIONS
Operating System: KDE neon 5.15
KDE Plasma Version: 5.15.0
KDE Frameworks Version: 5.55.0
Qt Version: 5.12.0
Kernel Version: 4.18.0-15-generic
OS Type: 64-bit
Processors: 8 × Intel® Core™ i7-8550U CPU @ 1.80GHz
Memory: 7.5 GiB of RAM


ADDITIONAL INFORMATION
Another user reports this problem exists on Neon Dev Stable too. See this forum thread for more details:
https://forum.kde.org/viewtopic.php?f=215&t=156828&sid=248f8696ef3b37d0a5b54bd1836a0937&p=411109#p409937
Comment 1 Bug Janitor Service 2021-08-18 23:23:14 UTC
A possibly relevant merge request was started @ https://invent.kde.org/pim/korganizer/-/merge_requests/46
Comment 2 gjditchfield 2021-08-19 22:08:42 UTC
*** Bug 357267 has been marked as a duplicate of this bug. ***
Comment 3 Carl Schwan 2021-08-22 09:13:38 UTC
Fixed with https://invent.kde.org/pim/korganizer/-/merge_requests/46