Bug 403950 - Crash on close, after visiting the settings for Launch Feedback
Summary: Crash on close, after visiting the settings for Launch Feedback
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_launch (show other bugs)
Version: 5.13.5
Platform: Kubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
: 403919 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-02-05 09:49 UTC by kai.klingenhagen
Modified: 2019-04-04 23:35 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.15.0


Attachments
flickering (96.50 KB, image/gif)
2019-02-05 09:49 UTC, kai.klingenhagen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description kai.klingenhagen 2019-02-05 09:49:53 UTC
Created attachment 117836 [details]
flickering

SUMMARY

When visiting Applications / Launch Feedback the star, indicating a edit on this page, begin to flicker and the CPU usage begin to rise.
After that, when you close the systemsettings, the application crashs.


STEPS TO REPRODUCE
1. Open systemsettings
2. Go to the option 'Applications'
3. Go to the option 'Launch Feedback'
4. Watch the flickering
5. Close systemsettings
6. CRASH












Application: systemsettings5 (5.13.5)

Qt Version: 5.11.1
Frameworks Version: 5.50.0
Operating System: Linux 4.18.0-14-generic x86_64
Distribution: Ubuntu 18.10


-- Information about the crash:

The crash can be reproduced every time on my system.


-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7fe2b6626840 (LWP 15383))]

Thread 7 (Thread 0x7fe295dff700 (LWP 15398)):
#0  0x00007fe2bc9f36d9 in __GI___poll (fds=0x7fe28803a800, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fe2b9b22e46 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe2b9b231d2 in g_main_loop_run () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe299d7c7b6 in  () at /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
#4  0x00007fe2b9b4b135 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fe2bae98164 in start_thread (arg=<optimized out>) at pthread_create.c:486
#6  0x00007fe2bc9ffdef in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 6 (Thread 0x7fe2971ba700 (LWP 15397)):
#0  0x00007fe2bc9f36d9 in __GI___poll (fds=0x55966f70a210, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fe2b9b22e46 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe2b9b22f6c in g_main_context_iteration () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe2b9b22fb1 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#4  0x00007fe2b9b4b135 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#5  0x00007fe2bae98164 in start_thread (arg=<optimized out>) at pthread_create.c:486
#6  0x00007fe2bc9ffdef in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 5 (Thread 0x7fe2a49f8700 (LWP 15388)):
#0  0x00007fe2b9b69509 in g_mutex_lock () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007fe2b9b22e2c in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe2b9b22f6c in g_main_context_iteration () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe2bcf1615b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007fe2bcec316b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007fe2bcd120b6 in QThread::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007fe2bbfd31f5 in  () at /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#7  0x00007fe2bcd1bc87 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007fe2bae98164 in start_thread (arg=<optimized out>) at pthread_create.c:486
#9  0x00007fe2bc9ffdef in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 4 (Thread 0x7fe2ac9dc700 (LWP 15386)):
#0  0x00007fe2bae9e2eb in futex_wait_cancelable (private=<optimized out>, expected=0, futex_word=0x55966bf97ff8) at ../sysdeps/unix/sysv/linux/futex-internal.h:88
#1  0x00007fe2bae9e2eb in __pthread_cond_wait_common (abstime=0x0, mutex=0x55966bf97fa8, cond=0x55966bf97fd0) at pthread_cond_wait.c:502
#2  0x00007fe2bae9e2eb in __pthread_cond_wait (cond=0x55966bf97fd0, mutex=0x55966bf97fa8) at pthread_cond_wait.c:655
#3  0x00007fe2ad0cd46b in  () at /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#4  0x00007fe2ad0cd1d7 in  () at /usr/lib/x86_64-linux-gnu/dri/i965_dri.so
#5  0x00007fe2bae98164 in start_thread (arg=<optimized out>) at pthread_create.c:486
#6  0x00007fe2bc9ffdef in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 3 (Thread 0x7fe2af2ab700 (LWP 15385)):
#0  0x00007fe2bc9f36d9 in __GI___poll (fds=0x7fe2a8013b40, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fe2b9b22e46 in  () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007fe2b9b22f6c in g_main_context_iteration () at /usr/lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007fe2bcf1615b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007fe2bcec316b in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007fe2bcd120b6 in QThread::exec() () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007fe2bd1cf545 in  () at /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#7  0x00007fe2bcd1bc87 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007fe2bae98164 in start_thread (arg=<optimized out>) at pthread_create.c:486
#9  0x00007fe2bc9ffdef in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 2 (Thread 0x7fe2b4f6a700 (LWP 15384)):
#0  0x00007fe2bc9f36d9 in __GI___poll (fds=0x7fe2b4f69c78, nfds=1, timeout=-1) at ../sysdeps/unix/sysv/linux/poll.c:29
#1  0x00007fe2bae56917 in  () at /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007fe2bae5853a in xcb_wait_for_event () at /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007fe2b5f07159 in  () at /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#4  0x00007fe2bcd1bc87 in  () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007fe2bae98164 in start_thread (arg=<optimized out>) at pthread_create.c:486
#6  0x00007fe2bc9ffdef in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:95

Thread 1 (Thread 0x7fe2b6626840 (LWP 15383)):
[KCrash Handler]
#6  0x000055966f6e1630 in  ()
#7  0x00007fe2bbf291f3 in QQmlData::signalEmitted(QAbstractDeclarativeData*, QObject*, int, void**) () at /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#8  0x00007fe2bceed00f in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007fe2be255f0f in KCModule::changed(bool) () at /usr/lib/x86_64-linux-gnu/libKF5ConfigWidgets.so.5
#10 0x00007fe2bceed830 in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#11 0x00007fe299688d43 in  () at /usr/lib/x86_64-linux-gnu/qt5/plugins/kcms/kcm_launchfeedback.so
#12 0x00007fe29968b3e3 in  () at /usr/lib/x86_64-linux-gnu/qt5/plugins/kcms/kcm_launchfeedback.so
#13 0x00007fe2bbeef084 in QV4::QObjectWrapper::setProperty(QV4::ExecutionEngine*, QObject*, QQmlPropertyData*, QV4::Value const&) () at /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#14 0x00007fe2bbeefdde in QV4::QObjectWrapper::setQmlProperty(QV4::ExecutionEngine*, QQmlContextData*, QObject*, QV4::String*, QV4::QObjectWrapper::RevisionMode, QV4::Value const&) () at /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#15 0x00007fe2bbeefed4 in QV4::QObjectWrapper::put(QV4::Managed*, QV4::String*, QV4::Value const&) () at /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#16 0x00007fe2bbf02eac in QV4::Runtime::method_storeProperty(QV4::ExecutionEngine*, QV4::Value const&, int, QV4::Value const&) () at /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#17 0x00007fe2bbf0e789 in  () at /usr/lib/x86_64-linux-gnu/libQt5Qml.so.5
#18 0x00007fe29969debd in  ()
#19 0x00007fe29bbc1320 in  ()
#20 0x00007fe29bbc1328 in  ()
#21 0x000055966c4d38b0 in  ()
#22 0x0000000000000000 in  ()
[Inferior 1 (process 15383) detached]
Comment 1 Kai Uwe Broulik 2019-02-05 11:40:42 UTC

*** This bug has been marked as a duplicate of bug 397894 ***
Comment 2 David Edmundson 2019-02-05 11:48:53 UTC
Git commit 70a0c99d08b5fffd859eaf8883ff3c1b0758de2e by David Edmundson.
Committed on 05/02/2019 at 11:48.
Pushed by davidedmundson into branch 'Plasma/5.15'.

[kcms/launch] Avoid infinite loop in button handling

Summary:
When visiting Applications / Launch Feedback the star, indicating a edit
on this page, begin to flicker.

QQC2 allows us to fix it properly.

Test Plan: Made some changes

Reviewers: #plasma, broulik

Reviewed By: #plasma, broulik

Subscribers: plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D18748

M  +6    -7    kcms/launch/package/contents/ui/main.qml

https://commits.kde.org/plasma-desktop/70a0c99d08b5fffd859eaf8883ff3c1b0758de2e
Comment 3 Nate Graham 2019-02-05 20:30:40 UTC
*** Bug 403919 has been marked as a duplicate of this bug. ***
Comment 4 David Edmundson 2019-04-04 23:35:25 UTC
*** Bug 406236 has been marked as a duplicate of this bug. ***