Bug 397894 - Launch Feedback KCM crashes in KQuickAddons::ConfigModule::needsSave()
Summary: Launch Feedback KCM crashes in KQuickAddons::ConfigModule::needsSave()
Status: RESOLVED FIXED
Alias: None
Product: frameworks-kcmutils
Classification: Unclassified
Component: general (show other bugs)
Version: 5.51.0
Platform: Archlinux Packages Linux
: NOR crash
Target Milestone: ---
Assignee: kdelibs bugs
URL:
Keywords: drkonqi
: 392590 393120 397925 398640 400390 400446 400577 400972 401117 402027 402243 403294 405637 405738 406236 406249 406341 407912 409321 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-08-26 16:54 UTC by sn0w
Modified: 2019-06-30 23:29 UTC (History)
23 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.53


Attachments
New crash information added by DrKonqi (6.42 KB, text/plain)
2018-09-14 22:10 UTC, Martin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sn0w 2018-08-26 16:54:20 UTC
Application: systemsettings5 (5.13.4)

Qt Version: 5.11.1
Frameworks Version: 5.49.0
Operating System: Linux 4.18.4-zen1-1-zen x86_64
Distribution (Platform): Archlinux Packages

-- Information about the crash:
- What I was doing when the application crashed:

I opened Applications > Launch Feedback and did nothing.

- Unusual behavior I noticed:

The "unsaved settings" star in the app's titlebar was flashing really fast for a few seconds.
After a few seconds of flashing, the app crashed.

- Custom settings of the application:

My setup uses custom monitor scaling with xrandr which gets applied
before login in sddm's Xsetup file. I have one 3840x2160 screen at
scale 1x1 and two 1920x1080 screens at scale 2x2. 

UI scaling is set to 1.6.

The KScreen2 startup service is disabled.

System Settings was on the 3840x2160 screen during the crash.

The crash can be reproduced sometimes.

-- Backtrace:
Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f683ecc8840 (LWP 11349))]

Thread 18 (Thread 0x7f67d35ef700 (LWP 12900)):
#0  0x00007f6845ff5bb1 in poll () at /usr/lib/libc.so.6
#1  0x00007f6842a05ec0 in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007f6842a06272 in g_main_loop_run () at /usr/lib/libglib-2.0.so.0
#3  0x00007f67d8c17e78 in  () at /usr/lib/libgio-2.0.so.0
#4  0x00007f6842a2e1ea in  () at /usr/lib/libglib-2.0.so.0
#5  0x00007f6845ee4a9d in start_thread () at /usr/lib/libpthread.so.0
#6  0x00007f6846000a43 in clone () at /usr/lib/libc.so.6

Thread 17 (Thread 0x7f67ea24c700 (LWP 12899)):
#0  0x00007f6845ff1734 in read () at /usr/lib/libc.so.6
#1  0x00007f6842a4b691 in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007f6842a05981 in g_main_context_check () at /usr/lib/libglib-2.0.so.0
#3  0x00007f6842a05e66 in  () at /usr/lib/libglib-2.0.so.0
#4  0x00007f6842a05fee in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#5  0x00007f6842a06042 in  () at /usr/lib/libglib-2.0.so.0
#6  0x00007f6842a2e1ea in  () at /usr/lib/libglib-2.0.so.0
#7  0x00007f6845ee4a9d in start_thread () at /usr/lib/libpthread.so.0
#8  0x00007f6846000a43 in clone () at /usr/lib/libc.so.6

Thread 16 (Thread 0x7f67eb5f4700 (LWP 11369)):
#0  0x00007f6845ff1734 in read () at /usr/lib/libc.so.6
#1  0x00007f6842a4b691 in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007f6842a05981 in g_main_context_check () at /usr/lib/libglib-2.0.so.0
#3  0x00007f6842a05e66 in  () at /usr/lib/libglib-2.0.so.0
#4  0x00007f6842a05fee in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#5  0x00007f684651d4c4 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#6  0x00007f68464c8dac in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#7  0x00007f6846311f59 in QThread::exec() () at /usr/lib/libQt5Core.so.5
#8  0x00007f68453c20d9 in  () at /usr/lib/libQt5Qml.so.5
#9  0x00007f684631c005 in  () at /usr/lib/libQt5Core.so.5
#10 0x00007f6845ee4a9d in start_thread () at /usr/lib/libpthread.so.0
#11 0x00007f6846000a43 in clone () at /usr/lib/libc.so.6

Thread 15 (Thread 0x7f67ebfff700 (LWP 11368)):
#0  0x00007f6845eeaafc in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007f6831cc6404 in  () at /usr/lib/dri/radeonsi_dri.so
#2  0x00007f6831cc60f8 in  () at /usr/lib/dri/radeonsi_dri.so
#3  0x00007f6845ee4a9d in start_thread () at /usr/lib/libpthread.so.0
#4  0x00007f6846000a43 in clone () at /usr/lib/libc.so.6

Thread 14 (Thread 0x7f67fcb50700 (LWP 11367)):
#0  0x00007f6845eeaafc in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007f6831cc6404 in  () at /usr/lib/dri/radeonsi_dri.so
#2  0x00007f6831cc60f8 in  () at /usr/lib/dri/radeonsi_dri.so
#3  0x00007f6845ee4a9d in start_thread () at /usr/lib/libpthread.so.0
#4  0x00007f6846000a43 in clone () at /usr/lib/libc.so.6

Thread 13 (Thread 0x7f67fdf91700 (LWP 11366)):
#0  0x00007f6845eeaafc in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007f6831cc6404 in  () at /usr/lib/dri/radeonsi_dri.so
#2  0x00007f6831cc60f8 in  () at /usr/lib/dri/radeonsi_dri.so
#3  0x00007f6845ee4a9d in start_thread () at /usr/lib/libpthread.so.0
#4  0x00007f6846000a43 in clone () at /usr/lib/libc.so.6

Thread 12 (Thread 0x7f67fe792700 (LWP 11365)):
#0  0x00007f6845eeaafc in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007f6831cc6404 in  () at /usr/lib/dri/radeonsi_dri.so
#2  0x00007f6831cc60f8 in  () at /usr/lib/dri/radeonsi_dri.so
#3  0x00007f6845ee4a9d in start_thread () at /usr/lib/libpthread.so.0
#4  0x00007f6846000a43 in clone () at /usr/lib/libc.so.6

Thread 11 (Thread 0x7f680903d700 (LWP 11364)):
#0  0x00007f6845ff5bb1 in poll () at /usr/lib/libc.so.6
#1  0x00007f6842a05ec0 in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007f6842a05fee in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#3  0x00007f684651d4c4 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#4  0x00007f68464c8dac in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#5  0x00007f6846311f59 in QThread::exec() () at /usr/lib/libQt5Core.so.5
#6  0x00007f68453c20d9 in  () at /usr/lib/libQt5Qml.so.5
#7  0x00007f684631c005 in  () at /usr/lib/libQt5Core.so.5
#8  0x00007f6845ee4a9d in start_thread () at /usr/lib/libpthread.so.0
#9  0x00007f6846000a43 in clone () at /usr/lib/libc.so.6

Thread 10 (Thread 0x7f680b3dd700 (LWP 11361)):
#0  0x00007f6845ff5bb1 in poll () at /usr/lib/libc.so.6
#1  0x00007f6842a05ec0 in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007f6842a05fee in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#3  0x00007f684651d4c4 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#4  0x00007f68464c8dac in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#5  0x00007f6846311f59 in QThread::exec() () at /usr/lib/libQt5Core.so.5
#6  0x00007f68453c20d9 in  () at /usr/lib/libQt5Qml.so.5
#7  0x00007f684631c005 in  () at /usr/lib/libQt5Core.so.5
#8  0x00007f6845ee4a9d in start_thread () at /usr/lib/libpthread.so.0
#9  0x00007f6846000a43 in clone () at /usr/lib/libc.so.6

Thread 9 (Thread 0x7f682534b700 (LWP 11359)):
#0  0x00007f6845eeaafc in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007f6831cc6404 in  () at /usr/lib/dri/radeonsi_dri.so
#2  0x00007f6831cc60f8 in  () at /usr/lib/dri/radeonsi_dri.so
#3  0x00007f6845ee4a9d in start_thread () at /usr/lib/libpthread.so.0
#4  0x00007f6846000a43 in clone () at /usr/lib/libc.so.6

Thread 8 (Thread 0x7f6825b4c700 (LWP 11358)):
#0  0x00007f6845eeaafc in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007f6831cc6404 in  () at /usr/lib/dri/radeonsi_dri.so
#2  0x00007f6831cc60f8 in  () at /usr/lib/dri/radeonsi_dri.so
#3  0x00007f6845ee4a9d in start_thread () at /usr/lib/libpthread.so.0
#4  0x00007f6846000a43 in clone () at /usr/lib/libc.so.6

Thread 7 (Thread 0x7f682634d700 (LWP 11357)):
#0  0x00007f6845eeaafc in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007f6831cc6404 in  () at /usr/lib/dri/radeonsi_dri.so
#2  0x00007f6831cc60f8 in  () at /usr/lib/dri/radeonsi_dri.so
#3  0x00007f6845ee4a9d in start_thread () at /usr/lib/libpthread.so.0
#4  0x00007f6846000a43 in clone () at /usr/lib/libc.so.6

Thread 6 (Thread 0x7f6826b4e700 (LWP 11356)):
#0  0x00007f6845eeaafc in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007f6831cc6404 in  () at /usr/lib/dri/radeonsi_dri.so
#2  0x00007f6831cc60f8 in  () at /usr/lib/dri/radeonsi_dri.so
#3  0x00007f6845ee4a9d in start_thread () at /usr/lib/libpthread.so.0
#4  0x00007f6846000a43 in clone () at /usr/lib/libc.so.6

Thread 5 (Thread 0x7f682734f700 (LWP 11355)):
#0  0x00007f6845eeaafc in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007f6831cc6404 in  () at /usr/lib/dri/radeonsi_dri.so
#2  0x00007f6831cc60f8 in  () at /usr/lib/dri/radeonsi_dri.so
#3  0x00007f6845ee4a9d in start_thread () at /usr/lib/libpthread.so.0
#4  0x00007f6846000a43 in clone () at /usr/lib/libc.so.6

Thread 4 (Thread 0x7f6827b50700 (LWP 11354)):
#0  0x00007f6845eeaafc in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007f6831cc6404 in  () at /usr/lib/dri/radeonsi_dri.so
#2  0x00007f6831cc60f8 in  () at /usr/lib/dri/radeonsi_dri.so
#3  0x00007f6845ee4a9d in start_thread () at /usr/lib/libpthread.so.0
#4  0x00007f6846000a43 in clone () at /usr/lib/libc.so.6

Thread 3 (Thread 0x7f6828351700 (LWP 11353)):
#0  0x00007f6845eeaafc in pthread_cond_wait@@GLIBC_2.3.2 () at /usr/lib/libpthread.so.0
#1  0x00007f6831cc6404 in  () at /usr/lib/dri/radeonsi_dri.so
#2  0x00007f6831cc60f8 in  () at /usr/lib/dri/radeonsi_dri.so
#3  0x00007f6845ee4a9d in start_thread () at /usr/lib/libpthread.so.0
#4  0x00007f6846000a43 in clone () at /usr/lib/libc.so.6

Thread 2 (Thread 0x7f6838b48700 (LWP 11352)):
#0  0x00007f6845ff5bb1 in poll () at /usr/lib/libc.so.6
#1  0x00007f6842a05ec0 in  () at /usr/lib/libglib-2.0.so.0
#2  0x00007f6842a05fee in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#3  0x00007f684651d4c4 in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#4  0x00007f68464c8dac in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () at /usr/lib/libQt5Core.so.5
#5  0x00007f6846311f59 in QThread::exec() () at /usr/lib/libQt5Core.so.5
#6  0x00007f684676fba6 in  () at /usr/lib/libQt5DBus.so.5
#7  0x00007f684631c005 in  () at /usr/lib/libQt5Core.so.5
#8  0x00007f6845ee4a9d in start_thread () at /usr/lib/libpthread.so.0
#9  0x00007f6846000a43 in clone () at /usr/lib/libc.so.6

Thread 1 (Thread 0x7f683ecc8840 (LWP 11349)):
[KCrash Handler]
#6  0x00007f68478b5bc0 in KQuickAddons::ConfigModule::needsSave() () at /usr/lib/libKF5QuickAddons.so.5
#7  0x00007f68479e86cc in  () at /usr/lib/libKF5KCMUtils.so.5
#8  0x00007f68464f40b0 in QMetaObject::activate(QObject*, int, int, void**) () at /usr/lib/libQt5Core.so.5
#9  0x00007f67c6a027ce in  () at /usr/lib/qt/plugins/kcms/kcm_launchfeedback.so
#10 0x00007f67c6a04f7b in  () at /usr/lib/qt/plugins/kcms/kcm_launchfeedback.so
#11 0x00007f68452d9fb5 in QV4::QObjectWrapper::setProperty(QV4::ExecutionEngine*, QObject*, QQmlPropertyData*, QV4::Value const&) () at /usr/lib/libQt5Qml.so.5
#12 0x00007f68452dad3f in QV4::QObjectWrapper::setQmlProperty(QV4::ExecutionEngine*, QQmlContextData*, QObject*, QV4::String*, QV4::QObjectWrapper::RevisionMode, QV4::Value const&) () at /usr/lib/libQt5Qml.so.5
#13 0x00007f68452dae36 in QV4::QObjectWrapper::put(QV4::Managed*, QV4::String*, QV4::Value const&) () at /usr/lib/libQt5Qml.so.5
#14 0x00007f68452ee03c in QV4::Runtime::method_storeProperty(QV4::ExecutionEngine*, QV4::Value const&, int, QV4::Value const&) () at /usr/lib/libQt5Qml.so.5
#15 0x00007f68452f9c1a in  () at /usr/lib/libQt5Qml.so.5
#16 0x00007f67febb3fbd in  ()
#17 0x00007f67ea9b5320 in  ()
#18 0x00007f67ea9b5328 in  ()
#19 0x000055708e3b1cd0 in  ()
#20 0x0000000000000000 in  ()

Reported using DrKonqi
Comment 1 Kai Uwe Broulik 2018-08-27 15:26:25 UTC
*** Bug 397925 has been marked as a duplicate of this bug. ***
Comment 2 sn0w 2018-09-09 00:36:30 UTC
Bug can be reproduced after upgrading to 5.13.5.

-- Steps to reproduce:

- Open systemsettings5
- Go to Applications > Launch Feedback
- Notice the flashing * in the titlebar
- Switch to a different pane (eg Applications > Locations)
- Segfault occurs

-- Backtrace:

Application: System Settings (systemsettings5), signal: Segmentation fault
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f7db393b840 (LWP 309))]

Thread 17 (Thread 0x7f7d637fe700 (LWP 362)):
#0  0x00007f7dba890734 in read () from /usr/lib/libc.so.6
#1  0x00007f7db7647781 in ?? () from /usr/lib/libglib-2.0.so.0
#2  0x00007f7db7697a50 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#3  0x00007f7db7698e86 in ?? () from /usr/lib/libglib-2.0.so.0
#4  0x00007f7db7698fce in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#5  0x00007f7dbadce33c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#6  0x00007f7dbad7767c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#7  0x00007f7dbabb46c9 in QThread::exec() () from /usr/lib/libQt5Core.so.5
#8  0x00007f7db9c749f9 in ?? () from /usr/lib/libQt5Qml.so.5
#9  0x00007f7dbabbec54 in ?? () from /usr/lib/libQt5Core.so.5
#10 0x00007f7db8b31a9d in start_thread () from /usr/lib/libpthread.so.0
#11 0x00007f7dba89fa43 in clone () from /usr/lib/libc.so.6

Thread 16 (Thread 0x7f7d63fff700 (LWP 359)):
#0  0x00007f7db8b37afc in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f7da8c5123e in cnd_wait (cond=<optimized out>, mtx=<optimized out>) at ../mesa-18.1.8/src/../include/c11/threads_posix.h:155
#2  util_queue_thread_func (input=<optimized out>) at ../mesa-18.1.8/src/util/u_queue.c:255
#3  0x00007f7da8c519b7 in impl_thrd_routine (p=<optimized out>) at ../mesa-18.1.8/src/../include/c11/threads_posix.h:87
#4  0x00007f7db8b31a9d in start_thread () from /usr/lib/libpthread.so.0
#5  0x00007f7dba89fa43 in clone () from /usr/lib/libc.so.6

Thread 15 (Thread 0x7f7d75021700 (LWP 358)):
#0  0x00007f7db8b37afc in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f7da8c5123e in cnd_wait (cond=<optimized out>, mtx=<optimized out>) at ../mesa-18.1.8/src/../include/c11/threads_posix.h:155
#2  util_queue_thread_func (input=<optimized out>) at ../mesa-18.1.8/src/util/u_queue.c:255
#3  0x00007f7da8c519b7 in impl_thrd_routine (p=<optimized out>) at ../mesa-18.1.8/src/../include/c11/threads_posix.h:87
#4  0x00007f7db8b31a9d in start_thread () from /usr/lib/libpthread.so.0
#5  0x00007f7dba89fa43 in clone () from /usr/lib/libc.so.6

Thread 14 (Thread 0x7f7d76370700 (LWP 357)):
#0  0x00007f7db8b37afc in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f7da8c5123e in cnd_wait (cond=<optimized out>, mtx=<optimized out>) at ../mesa-18.1.8/src/../include/c11/threads_posix.h:155
#2  util_queue_thread_func (input=<optimized out>) at ../mesa-18.1.8/src/util/u_queue.c:255
#3  0x00007f7da8c519b7 in impl_thrd_routine (p=<optimized out>) at ../mesa-18.1.8/src/../include/c11/threads_posix.h:87
#4  0x00007f7db8b31a9d in start_thread () from /usr/lib/libpthread.so.0
#5  0x00007f7dba89fa43 in clone () from /usr/lib/libc.so.6

Thread 13 (Thread 0x7f7d76b71700 (LWP 355)):
#0  0x00007f7db8b37afc in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f7da8c5123e in cnd_wait (cond=<optimized out>, mtx=<optimized out>) at ../mesa-18.1.8/src/../include/c11/threads_posix.h:155
#2  util_queue_thread_func (input=<optimized out>) at ../mesa-18.1.8/src/util/u_queue.c:255
#3  0x00007f7da8c519b7 in impl_thrd_routine (p=<optimized out>) at ../mesa-18.1.8/src/../include/c11/threads_posix.h:87
#4  0x00007f7db8b31a9d in start_thread () from /usr/lib/libpthread.so.0
#5  0x00007f7dba89fa43 in clone () from /usr/lib/libc.so.6

Thread 12 (Thread 0x7f7d7d0d2700 (LWP 354)):
#0  0x00007f7dba894bb1 in poll () from /usr/lib/libc.so.6
#1  0x00007f7db7698ee0 in ?? () from /usr/lib/libglib-2.0.so.0
#2  0x00007f7db7698fce in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#3  0x00007f7dbadce33c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#4  0x00007f7dbad7767c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#5  0x00007f7dbabb46c9 in QThread::exec() () from /usr/lib/libQt5Core.so.5
#6  0x00007f7db9c749f9 in ?? () from /usr/lib/libQt5Qml.so.5
#7  0x00007f7dbabbec54 in ?? () from /usr/lib/libQt5Core.so.5
#8  0x00007f7db8b31a9d in start_thread () from /usr/lib/libpthread.so.0
#9  0x00007f7dba89fa43 in clone () from /usr/lib/libc.so.6

Thread 11 (Thread 0x7f7d7f0e9700 (LWP 352)):
#0  0x00007f7dba894bb1 in poll () from /usr/lib/libc.so.6
#1  0x00007f7db7698ee0 in ?? () from /usr/lib/libglib-2.0.so.0
#2  0x00007f7db7698fce in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#3  0x00007f7dbadce33c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#4  0x00007f7dbad7767c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#5  0x00007f7dbabb46c9 in QThread::exec() () from /usr/lib/libQt5Core.so.5
#6  0x00007f7db9c749f9 in ?? () from /usr/lib/libQt5Qml.so.5
#7  0x00007f7dbabbec54 in ?? () from /usr/lib/libQt5Core.so.5
#8  0x00007f7db8b31a9d in start_thread () from /usr/lib/libpthread.so.0
#9  0x00007f7dba89fa43 in clone () from /usr/lib/libc.so.6

Thread 10 (Thread 0x7f7d9cb4e700 (LWP 329)):
#0  0x00007f7db8b37afc in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f7da8c5123e in cnd_wait (cond=<optimized out>, mtx=<optimized out>) at ../mesa-18.1.8/src/../include/c11/threads_posix.h:155
#2  util_queue_thread_func (input=<optimized out>) at ../mesa-18.1.8/src/util/u_queue.c:255
#3  0x00007f7da8c519b7 in impl_thrd_routine (p=<optimized out>) at ../mesa-18.1.8/src/../include/c11/threads_posix.h:87
#4  0x00007f7db8b31a9d in start_thread () from /usr/lib/libpthread.so.0
#5  0x00007f7dba89fa43 in clone () from /usr/lib/libc.so.6

Thread 9 (Thread 0x7f7d9d34f700 (LWP 327)):
#0  0x00007f7db8b37afc in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f7da8c5123e in cnd_wait (cond=<optimized out>, mtx=<optimized out>) at ../mesa-18.1.8/src/../include/c11/threads_posix.h:155
#2  util_queue_thread_func (input=<optimized out>) at ../mesa-18.1.8/src/util/u_queue.c:255
#3  0x00007f7da8c519b7 in impl_thrd_routine (p=<optimized out>) at ../mesa-18.1.8/src/../include/c11/threads_posix.h:87
#4  0x00007f7db8b31a9d in start_thread () from /usr/lib/libpthread.so.0
#5  0x00007f7dba89fa43 in clone () from /usr/lib/libc.so.6

Thread 8 (Thread 0x7f7d9db50700 (LWP 326)):
#0  0x00007f7db8b37afc in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f7da8c5123e in cnd_wait (cond=<optimized out>, mtx=<optimized out>) at ../mesa-18.1.8/src/../include/c11/threads_posix.h:155
#2  util_queue_thread_func (input=<optimized out>) at ../mesa-18.1.8/src/util/u_queue.c:255
#3  0x00007f7da8c519b7 in impl_thrd_routine (p=<optimized out>) at ../mesa-18.1.8/src/../include/c11/threads_posix.h:87
#4  0x00007f7db8b31a9d in start_thread () from /usr/lib/libpthread.so.0
#5  0x00007f7dba89fa43 in clone () from /usr/lib/libc.so.6

Thread 7 (Thread 0x7f7d9e351700 (LWP 325)):
#0  0x00007f7db8b37afc in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f7da8c5123e in cnd_wait (cond=<optimized out>, mtx=<optimized out>) at ../mesa-18.1.8/src/../include/c11/threads_posix.h:155
#2  util_queue_thread_func (input=<optimized out>) at ../mesa-18.1.8/src/util/u_queue.c:255
#3  0x00007f7da8c519b7 in impl_thrd_routine (p=<optimized out>) at ../mesa-18.1.8/src/../include/c11/threads_posix.h:87
#4  0x00007f7db8b31a9d in start_thread () from /usr/lib/libpthread.so.0
#5  0x00007f7dba89fa43 in clone () from /usr/lib/libc.so.6

Thread 6 (Thread 0x7f7d9eb52700 (LWP 324)):
#0  0x00007f7db8b37afc in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f7da8c5123e in cnd_wait (cond=<optimized out>, mtx=<optimized out>) at ../mesa-18.1.8/src/../include/c11/threads_posix.h:155
#2  util_queue_thread_func (input=<optimized out>) at ../mesa-18.1.8/src/util/u_queue.c:255
#3  0x00007f7da8c519b7 in impl_thrd_routine (p=<optimized out>) at ../mesa-18.1.8/src/../include/c11/threads_posix.h:87
#4  0x00007f7db8b31a9d in start_thread () from /usr/lib/libpthread.so.0
#5  0x00007f7dba89fa43 in clone () from /usr/lib/libc.so.6

Thread 5 (Thread 0x7f7d9f353700 (LWP 323)):
#0  0x00007f7db8b37afc in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f7da8c5123e in cnd_wait (cond=<optimized out>, mtx=<optimized out>) at ../mesa-18.1.8/src/../include/c11/threads_posix.h:155
#2  util_queue_thread_func (input=<optimized out>) at ../mesa-18.1.8/src/util/u_queue.c:255
#3  0x00007f7da8c519b7 in impl_thrd_routine (p=<optimized out>) at ../mesa-18.1.8/src/../include/c11/threads_posix.h:87
#4  0x00007f7db8b31a9d in start_thread () from /usr/lib/libpthread.so.0
#5  0x00007f7dba89fa43 in clone () from /usr/lib/libc.so.6

Thread 4 (Thread 0x7f7d9fc95700 (LWP 322)):
#0  0x00007f7db8b37afc in pthread_cond_wait@@GLIBC_2.3.2 () from /usr/lib/libpthread.so.0
#1  0x00007f7da8c5123e in cnd_wait (cond=<optimized out>, mtx=<optimized out>) at ../mesa-18.1.8/src/../include/c11/threads_posix.h:155
#2  util_queue_thread_func (input=<optimized out>) at ../mesa-18.1.8/src/util/u_queue.c:255
#3  0x00007f7da8c519b7 in impl_thrd_routine (p=<optimized out>) at ../mesa-18.1.8/src/../include/c11/threads_posix.h:87
#4  0x00007f7db8b31a9d in start_thread () from /usr/lib/libpthread.so.0
#5  0x00007f7dba89fa43 in clone () from /usr/lib/libc.so.6

Thread 3 (Thread 0x7f7daaf1a700 (LWP 320)):
#0  0x00007f7dba894bb1 in poll () from /usr/lib/libc.so.6
#1  0x00007f7db7698ee0 in ?? () from /usr/lib/libglib-2.0.so.0
#2  0x00007f7db7698fce in g_main_context_iteration () from /usr/lib/libglib-2.0.so.0
#3  0x00007f7dbadce33c in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#4  0x00007f7dbad7767c in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/libQt5Core.so.5
#5  0x00007f7dbabb46c9 in QThread::exec() () from /usr/lib/libQt5Core.so.5
#6  0x00007f7dbb023ba6 in ?? () from /usr/lib/libQt5DBus.so.5
#7  0x00007f7dbabbec54 in ?? () from /usr/lib/libQt5Core.so.5
#8  0x00007f7db8b31a9d in start_thread () from /usr/lib/libpthread.so.0
#9  0x00007f7dba89fa43 in clone () from /usr/lib/libc.so.6

Thread 2 (Thread 0x7f7db2316700 (LWP 313)):
#0  0x00007f7dba894bb1 in poll () from /usr/lib/libc.so.6
#1  0x00007f7db8af3752 in _xcb_conn_wait (c=0x55ef94f4d550, cond=<optimized out>, vector=0x0, count=0x0) at xcb_conn.c:479
#2  0x00007f7db8af5b06 in xcb_wait_for_event (c=0x55ef94f4d550) at xcb_in.c:697
#3  0x00007f7db347d2da in ?? () from /usr/lib/libQt5XcbQpa.so.5
#4  0x00007f7dbabbec54 in ?? () from /usr/lib/libQt5Core.so.5
#5  0x00007f7db8b31a9d in start_thread () from /usr/lib/libpthread.so.0
#6  0x00007f7dba89fa43 in clone () from /usr/lib/libc.so.6

Thread 1 (Thread 0x7f7db393b840 (LWP 309)):
[KCrash Handler]
#6  KQuickAddons::ConfigModule::needsSave (this=0x2100000000) at /usr/src/debug/kdeclarative-5.49.0/src/quickaddons/configmodule.cpp:336
#7  0x00007f7dbc2b378c in KCModuleQml::<lambda()>::operator() (__closure=<optimized out>) at /usr/src/debug/kcmutils-5.49.0/src/kcmoduleqml.cpp:72
#8  QtPrivate::FunctorCall<QtPrivate::IndexesList<>, QtPrivate::List<>, void, KCModuleQml::KCModuleQml(KQuickAddons::ConfigModule*, QWidget*, const QVariantList&)::<lambda()> >::call (arg=<optimized out>, f=...) at /usr/include/qt/QtCore/qobjectdefs_impl.h:128
#9  QtPrivate::Functor<KCModuleQml::KCModuleQml(KQuickAddons::ConfigModule*, QWidget*, const QVariantList&)::<lambda()>, 0>::call<QtPrivate::List<>, void> (arg=<optimized out>, f=...) at /usr/include/qt/QtCore/qobjectdefs_impl.h:238
#10 QtPrivate::QFunctorSlotObject<KCModuleQml::KCModuleQml(KQuickAddons::ConfigModule*, QWidget*, const QVariantList&)::<lambda()>, 0, QtPrivate::List<>, void>::impl(int, QtPrivate::QSlotObjectBase *, QObject *, void **, bool *) (which=<optimized out>, this_=<optimized out>, r=<optimized out>, a=<optimized out>, ret=<optimized out>) at /usr/include/qt/QtCore/qobjectdefs_impl.h:421
#11 0x00007f7dbada3f6a in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/libQt5Core.so.5
#12 0x00007f7d7c1838f3 in LaunchFeedback::updateNeedsSave (this=0x55ef9612b660) at /usr/src/debug/plasma-desktop-5.13.5/kcms/launch/launchfeedback.cpp:199
#13 0x00007f7d7c1862b3 in LaunchFeedback::qt_metacall (this=0x55ef9612b660, _c=QMetaObject::WriteProperty, _id=0, _a=0x7ffebb075ed0) at /usr/src/debug/build/kcms/launch/kcm_launchfeedback_autogen/EWIEGA46WW/moc_launchfeedback.cpp:202
#14 0x00007f7db9b87ac3 in QV4::QObjectWrapper::setProperty(QV4::ExecutionEngine*, QObject*, QQmlPropertyData*, QV4::Value const&) () from /usr/lib/libQt5Qml.so.5
#15 0x00007f7db9b888cf in QV4::QObjectWrapper::setQmlProperty(QV4::ExecutionEngine*, QQmlContextData*, QObject*, QV4::String*, QV4::QObjectWrapper::RevisionMode, QV4::Value const&) () from /usr/lib/libQt5Qml.so.5
#16 0x00007f7db9b889d6 in QV4::QObjectWrapper::put(QV4::Managed*, QV4::String*, QV4::Value const&) () from /usr/lib/libQt5Qml.so.5
#17 0x00007f7db9b9c02c in QV4::Runtime::method_storeProperty(QV4::ExecutionEngine*, QV4::Value const&, int, QV4::Value const&) () from /usr/lib/libQt5Qml.so.5
#18 0x00007f7db9ba7dea in ?? () from /usr/lib/libQt5Qml.so.5
#19 0x00007f7d7c036fad in ?? ()
#20 0x000055ef96233be0 in ?? ()
#21 0x00007f7d62bbf328 in ?? ()
#22 0x000055ef9629c270 in ?? ()
#23 0x0000000000000000 in ?? ()
Comment 3 Martin 2018-09-14 22:10:28 UTC
Created attachment 114968 [details]
New crash information added by DrKonqi

systemsettings5 (5.13.4) using Qt 5.11.1

- What I was doing when the application crashed:
Open "Launch feedback"
- Unusual behavior I noticed:

Titlebar was flashing with "*".
When I clicked in the Back button, it crash

-- Backtrace (Reduced):
#6  KQuickAddons::ConfigModule::needsSave (this=0x676e69636e756f42) at /usr/src/debug/kdeclarative-5.49.0-1.1.x86_64/src/quickaddons/configmodule.cpp:336
#7  0x00007f7fb23394bb in KCModuleQml::<lambda()>::operator() (__closure=<optimized out>) at /usr/src/debug/kcmutils-5.49.0-2.1.x86_64/src/kcmoduleqml.cpp:72
#10 QtPrivate::QFunctorSlotObject<KCModuleQml::KCModuleQml(KQuickAddons::ConfigModule*, QWidget*, const QVariantList&)::<lambda()>, 0, QtPrivate::List<>, void>::impl(int, QtPrivate::QSlotObjectBase *, QObject *, void **, bool *) (which=<optimized out>, this_=<optimized out>, r=<optimized out>, a=<optimized out>, ret=<optimized out>) at /usr/include/qt5/QtCore/qobjectdefs_impl.h:421
#11 0x00007f7fb09e1760 in QtPrivate::QSlotObjectBase::call (a=0x7fff384e93b0, r=0x55dfc507cc50, this=0x55dfc50a9f40) at ../../include/QtCore/../../src/corelib/kernel/qobjectdefs_impl.h:376
[...]
#13 0x00007f7f8e7d2f23 in LaunchFeedback::updateNeedsSave (this=0x55dfc507cc50) at /usr/src/debug/plasma5-desktop-5.13.4-1.1.x86_64/kcms/launch/launchfeedback.cpp:199
Comment 4 Nate Graham 2018-11-01 17:26:22 UTC
*** Bug 400390 has been marked as a duplicate of this bug. ***
Comment 5 Nate Graham 2018-11-01 18:51:15 UTC
*** Bug 400446 has been marked as a duplicate of this bug. ***
Comment 6 Nate Graham 2018-11-01 18:55:24 UTC
Should be fixed by https://phabricator.kde.org/D16594
Comment 7 David Edmundson 2018-11-05 15:59:02 UTC
Git commit 2da8aed41663d2e765dddb3bf66fad038879d6d4 by David Edmundson.
Committed on 05/11/2018 at 15:57.
Pushed by davidedmundson into branch 'master'.

Add context to kcmodule connection to lambdas

Summary:
configModule outlives KCModuleQML.

Test Plan: Compiled

Reviewers: #plasma, broulik, bruns

Reviewed By: #plasma, broulik, bruns

Subscribers: bruns, kde-frameworks-devel

Tags: #frameworks

Differential Revision: https://phabricator.kde.org/D16594

M  +6    -6    src/kcmoduleqml.cpp

https://commits.kde.org/kcmutils/2da8aed41663d2e765dddb3bf66fad038879d6d4
Comment 8 David Edmundson 2018-11-06 09:45:13 UTC
*** Bug 392590 has been marked as a duplicate of this bug. ***
Comment 9 Nate Graham 2018-11-06 21:31:08 UTC
Can this go into the stable branch too?
Comment 10 Christoph Feck 2018-11-06 23:18:12 UTC
Nate, kcmutils is part of KF5. If urgent, David can do a respin of it for the coming 5.52.0 release.
Comment 11 Nate Graham 2018-11-06 23:25:18 UTC
Oh duh. Never mind!
Comment 12 Christoph Feck 2018-11-16 18:33:19 UTC
*** Bug 401117 has been marked as a duplicate of this bug. ***
Comment 13 Christoph Feck 2018-11-20 23:11:15 UTC
*** Bug 400577 has been marked as a duplicate of this bug. ***
Comment 14 Christoph Feck 2018-11-20 23:13:26 UTC
*** Bug 398640 has been marked as a duplicate of this bug. ***
Comment 15 Christoph Feck 2018-12-06 02:59:00 UTC
*** Bug 400972 has been marked as a duplicate of this bug. ***
Comment 16 Kai Uwe Broulik 2018-12-12 08:57:41 UTC
*** Bug 402027 has been marked as a duplicate of this bug. ***
Comment 17 Christoph Feck 2019-01-09 03:33:13 UTC
*** Bug 402243 has been marked as a duplicate of this bug. ***
Comment 18 Christoph Feck 2019-01-09 03:36:19 UTC
*** Bug 393120 has been marked as a duplicate of this bug. ***
Comment 19 Christoph Feck 2019-01-17 07:20:03 UTC
*** Bug 403294 has been marked as a duplicate of this bug. ***
Comment 20 Kai Uwe Broulik 2019-02-05 11:40:42 UTC
*** Bug 403950 has been marked as a duplicate of this bug. ***
Comment 21 Christoph Feck 2019-03-19 11:56:31 UTC
*** Bug 405637 has been marked as a duplicate of this bug. ***
Comment 22 Christoph Feck 2019-04-04 23:37:05 UTC
*** Bug 406236 has been marked as a duplicate of this bug. ***
Comment 23 David Edmundson 2019-04-05 10:37:00 UTC
*** Bug 406249 has been marked as a duplicate of this bug. ***
Comment 24 Christoph Feck 2019-04-08 21:21:34 UTC
*** Bug 406341 has been marked as a duplicate of this bug. ***
Comment 25 Christoph Feck 2019-04-16 20:21:24 UTC
*** Bug 405738 has been marked as a duplicate of this bug. ***
Comment 26 Christoph Feck 2019-06-14 13:00:09 UTC
*** Bug 407912 has been marked as a duplicate of this bug. ***
Comment 27 Christoph Feck 2019-06-30 23:29:38 UTC
*** Bug 409321 has been marked as a duplicate of this bug. ***