Bug 403838 - Allow re-positioning the window by clicking-and-dragging on empty areas of headers and the background
Summary: Allow re-positioning the window by clicking-and-dragging on empty areas of he...
Status: RESOLVED FIXED
Alias: None
Product: frameworks-kirigami
Classification: Frameworks and Libraries
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal (vote)
Target Milestone: Not decided
Assignee: Marco Martin
URL:
Keywords:
: 408628 410603 413450 418523 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-02-01 16:41 UTC by Nate Graham
Modified: 2021-01-16 12:16 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In: Frameworks 5.79 + Plasma 5.21


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nate Graham 2019-02-01 16:41:42 UTC
When on the desktop, Kirigami's ScrollablePage should allow re-positioning the window when the background is clicked-and-dragged, if the user has that setting enabled (which is the default). If the setting is disabled, then a click-and-drag should do nothing.
Comment 1 Marco Martin 2019-02-11 16:23:44 UTC
this can't work in qml in general (plasma configuration windows use an hack which can't work on wayland)

I don't think any of this drag on empty area stuff works or could ever work in wayland in general?
Comment 2 Marco Martin 2019-02-11 16:24:31 UTC
@david: is there any wayland protocol which would allow the drag on empty areas stuff?
Comment 3 Björn Feber 2019-06-13 05:13:22 UTC
*** Bug 408628 has been marked as a duplicate of this bug. ***
Comment 4 Nate Graham 2019-10-27 15:35:23 UTC
*** Bug 410603 has been marked as a duplicate of this bug. ***
Comment 5 Nate Graham 2019-10-27 23:20:40 UTC
*** Bug 413450 has been marked as a duplicate of this bug. ***
Comment 6 Patrick Silva 2020-03-13 17:08:07 UTC
*** Bug 418523 has been marked as a duplicate of this bug. ***
Comment 7 Bug Janitor Service 2020-11-30 17:38:53 UTC
A possibly relevant merge request was started @ https://invent.kde.org/frameworks/kirigami/-/merge_requests/179
Comment 9 petrk 2021-01-16 12:16:11 UTC
Nice, thanks. More consistency is always welcome.