Bug 403340 - Lag in working with vectors
Summary: Lag in working with vectors
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: Usability (show other bugs)
Version: 4.1.7
Platform: Microsoft Windows Microsoft Windows
: NOR normal
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2019-01-18 05:38 UTC by Marcos
Modified: 2019-03-23 21:35 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marcos 2019-01-18 05:38:40 UTC
SUMMARY

Lag in working with vectors

STEPS TO REPRODUCE
1. Moving a vector
2. 
3. 

OBSERVED RESULT
Lag, breaks frames

EXPECTED RESULT
Uniform displacement, smoothness in movement

SOFTWARE/OS VERSIONS
Windows: 7 64 bits
MacOS: 
Linux/KDE Plasma: 
(available in About System)
KDE Plasma Version: 
KDE Frameworks Version: 
Qt Version: 

ADDITIONAL INFORMATION

Krita
  Version: 4.1.7

Qt
  Version (compiled): 5.9.3
  Version (loaded): 5.9.3

OS Information
  Build ABI: x86_64-little_endian-llp64
  Build CPU: x86_64
  CPU: x86_64
  Kernel Type: winnt
  Kernel Version: 6.1.7601
  Pretty Productname: Windows 7 SP 1 (6.1)
  Product Type: windows
  Product Version: 7sp1

OpenGL Info
  **OpenGL not initialized**


I see slowness in moving a vector, shrinking it, or rotating it.
This only happens when I use a vector layer, drawing is normal
In system information it appears that Opengl is not initialized, my graphics card is an Nvidia GTX 750 (Opengl 4.4)
When changing from Opengl to Directx11 happens the same

Thanks you for your attention, greetings
Comment 1 Scott Petrovic 2019-01-18 14:25:44 UTC
I can conform on my windows build (on Windows 10 Krita 4.2 pre-alpha).

"lag" is maybe not the best term to describe this since it doesn't bog down or slow down the computer. It seems to be more of a refresh rate issue on the canvas.
Comment 2 Halla Rempt 2019-01-18 16:58:11 UTC
That's as may be -- but "lag" is not a "bug". If it doesn't perform as well as one would like, it's still not a "bug". Unless this is a definite and recent regression, we should close this report -- generic performance complains are not useful to keep in bugzilla.
Comment 3 Marcos 2019-01-18 17:43:00 UTC
(In reply to Boudewijn Rempt from comment #2)
> That's as may be -- but "lag" is not a "bug". If it doesn't perform as well
> as one would like, it's still not a "bug". Unless this is a definite and
> recent regression, we should close this report -- generic performance
> complains are not useful to keep in bugzilla.

Watching tutorials on youtube I see the movement is smooth
Another thing, opengl is not initialized, maybe it is related?
Sorry for my english, thanks
Comment 4 Halla Rempt 2019-01-18 18:11:05 UTC
if you really cannot enable opengl -- the bug info report might be misleading -- then that would certainly cause performance issues. And with Windows 7, it might be that there just aren't good enough display drivers anymore. It's an old OS, and we don't test with it anymore.
Comment 5 Halla Rempt 2019-03-21 15:20:00 UTC

*** This bug has been marked as a duplicate of bug 405698 ***
Comment 6 Dmitry Kazakov 2019-03-23 21:35:56 UTC
Git commit b4b8166ae74b7690c269b02f02d93ef5c9aeae02 by Dmitry Kazakov.
Committed on 23/03/2019 at 21:35.
Pushed by dkazakov into branch 'master'.

Adjust signal compressor in shape layer when image size changes
Related: bug 405698

M  +17   -17   libs/ui/flake/kis_shape_layer_canvas.cpp
M  +4    -1    libs/ui/flake/kis_shape_layer_canvas.h

https://commits.kde.org/krita/b4b8166ae74b7690c269b02f02d93ef5c9aeae02