Bug 402990 - Colour selection in popup palette with click "right button" on stylus
Summary: Colour selection in popup palette with click "right button" on stylus
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: Color Selectors (show other bugs)
Version: 4.1.7
Platform: Mint (Ubuntu based) Linux
: NOR normal
Target Milestone: ---
Assignee: Scott Petrovic
URL:
Keywords:
: 393317 (view as bug list)
Depends on:
Blocks:
 
Reported: 2019-01-08 08:04 UTC by n0dwis
Modified: 2019-04-09 00:57 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description n0dwis 2019-01-08 08:04:59 UTC
SUMMARY
I can choose colour from triangle in a popup palette with clicking a pen button than assigned to a right mouse button. Than the palette close. The Mouse hasn't same behaviour. The right mouse button click at any part of palette just close one.

STEPS TO REPRODUCE
1. Choose a colour
2. Open a brush popup palette with click a "right" button on stylus
3. Close the palette with click same button when a cursor is placed insight colour circle

OBSERVED RESULT
The colour that was selected on step 1 changed

EXPECTED RESULT
A colour should be same

Linux/KDE Plasma: Mint Cinnamon 19.1
Qt Version: qtcore - 5.9.5+dfsg-0ubuntu1

ADDITIONAL INFORMATION
This behaviour are totally comfortless because of I can accidental change a colour.
Comment 1 Halla Rempt 2019-01-08 09:42:42 UTC
What kind of tablet are you using?
Comment 2 n0dwis 2019-01-08 18:35:33 UTC
(In reply to Boudewijn Rempt from comment #1)
> What kind of tablet are you using?

One by Wacom CTL-672
Comment 3 Jason G. 2019-01-15 17:59:46 UTC
I have also confirmed this issue on the following machine:

Arch Linux
Awesome WM
krita-4.1.7-1
qt5-base-5.12.0-1
Wacom Cintiq 24HDT

Clicking the pen's "right mouse button" on the canvas will pop up the color picker. If you then right-click (or hold it and drag) on a color the selection will change and the picker will be dismissed. Interestingly, although the selected color changes, the brush color itself doesn't seem to change.

Trying the same with a mouse results in the picker opening and closing without a change to the selected color.
Comment 4 Tyson Tan 2019-04-08 15:41:04 UTC
I can confirm this on a Cintiq Pro 13, Manjaro KDE 18.0.4, Krita 4.2.0. Right click on Popup palette's color triangle doesn't close the palette, while a mouse's right click closes it.
Comment 5 wolthera 2019-04-08 16:07:32 UTC
alright, setting it to confirmed then.
Comment 6 Scott Petrovic 2019-04-08 16:26:09 UTC
This is also happening with my pen (Huion) on Windows git master

I think the issue is specifically with the color selector in the middle and how it handles tablet drag events. I think if we can just update the input handling of that color selector to ignore all right click events that will take care of it.
Comment 7 Quiralta 2019-04-08 16:31:17 UTC
*** Bug 393317 has been marked as a duplicate of this bug. ***
Comment 8 Scott Petrovic 2019-04-09 00:28:07 UTC
Git commit 62b4e3f3b9ce13d51b77be76b4b768bac46f3c20 by Scott Petrovic.
Committed on 09/04/2019 at 00:27.
Pushed by scottpetrovic into branch 'master'.

M  +36   -22   libs/ui/kis_popup_palette.cpp
M  +1    -0    libs/widgets/KoTriangleColorSelector.h

https://commits.kde.org/krita/62b4e3f3b9ce13d51b77be76b4b768bac46f3c20
Comment 9 Scott Petrovic 2019-04-09 00:30:30 UTC
Right-clicking on the color selector area now closes the popup palette immediately, and also makes sure a color is not selected.
Comment 10 Tyson Tan 2019-04-09 00:57:59 UTC
(In reply to Scott Petrovic from comment #9)
> Right-clicking on the color selector area now closes the popup palette
> immediately, and also makes sure a color is not selected.

Thank you Scott! :)