Bug 400613 - kcm_printer_manager - Windows printer via SAMBA - Browse button greyed out
Summary: kcm_printer_manager - Windows printer via SAMBA - Browse button greyed out
Status: RESOLVED DUPLICATE of bug 368305
Alias: None
Product: print-manager
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Daniel Nicoletti
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-11-03 08:55 UTC by raffaelemancuso91
Modified: 2020-02-18 17:06 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description raffaelemancuso91 2018-11-03 08:55:53 UTC
SUMMARY

In `/usr/bin/kcmshell5 kcm_printer_manager`, when I click on "Add printer" and then on "Window printer via SAMBA", the "Browse" button is greyed out.

Instead, by running system-config-printer (the GNOME equivalent), after clicking on Add->Printer, then on "Network printer" and then on "Window Printer via SAMBA", the "Browse" button works and it is clickable (after installing the python-smbc package)

The python-smbc and python3-smbc packages are installed.

Compiling printer_manager from source (https://github.com/KDE/print-manager) does not fix the problem

STEPS TO REPRODUCE
1(a). Run "/usr/bin/kcmshell5 kcm_printer_manager" and click on "Add printer"
or 
1(b). compile it from source and run "kde-add-printer --add-printer"
2. Click on Windows printer via SAMBA

OBSERVED RESULT

"Browse" button is greyed out


EXPECTED RESULT

"Browse" button should work and display the SAMBA tree


SOFTWARE VERSIONS
(available in About System)
KDE Plasma Version: 5.13.5
KDE Frameworks Version: 5.50.0
Qt Version: 5.11.1

ADDITIONAL INFORMATION
Comment 1 Daniel Nicoletti 2018-11-03 11:05:27 UTC
It's greyed out because it's a feature not implemented, patches are welcome :)
Comment 2 Nate Graham 2020-02-18 17:06:02 UTC

*** This bug has been marked as a duplicate of bug 368305 ***