Bug 368305 - Implement Samba printer browsing
Summary: Implement Samba printer browsing
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_printer_manager (show other bugs)
Version: unspecified
Platform: Mint (Ubuntu based) Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: Daniel Nicoletti
URL:
Keywords:
: 400613 421026 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-09-05 23:02 UTC by Digby
Modified: 2021-12-24 05:08 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In: 22.04


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Digby 2016-09-05 23:02:50 UTC
while trying to connect to a network print thro a windows 7 server the browse button is grayed out.

Reproducible: Always

Steps to Reproduce:
1 installed packages from the soft ware manager
2.tried suggestions from the linux blogs and commumity
3.

Actual Results:  
nothing happened

Expected Results:  
nothing
Comment 1 Daniel Nicoletti 2020-01-28 18:01:57 UTC
It's a missing feature, patches welcome :)
Comment 2 Harald Sitter 2020-01-28 18:09:35 UTC
Perhaps we should hide the button? I can totally see how a visible but always disabled button is confusing ^^
Comment 3 Daniel Nicoletti 2020-01-28 18:19:59 UTC
We can, I was actually hoping for someone missing the feature to implement it :)
Comment 4 Nate Graham 2020-02-18 17:06:02 UTC
*** Bug 400613 has been marked as a duplicate of this bug. ***
Comment 5 r3d9u11 2020-02-18 18:41:27 UTC
I'm afraid that not only "Browse" button didn't implemented. But "Printers configuration" at all.

I can't add any kind of printer by KDE GUI (but I did it by web without any troubles).

Here is a little discussion: https://www.reddit.com/r/kdeneon/comments/f55iey/cant_add_any_printer/fhwsdvx?utm_source=share&utm_medium=web2x
Comment 6 Harald Sitter 2021-02-19 13:54:27 UTC
*** Bug 421026 has been marked as a duplicate of this bug. ***
Comment 7 Harald Sitter 2021-02-19 14:00:56 UTC
For the record: I've been thinking that browsing could be terribly simply implemented by using the existing KIO smb worker implementation. Alas, we'd need to set KIO metadata on the underlying StatJob to switch the worker into some sort of printer browsing mode (not listing files but only folders and printers). AFAIK there is no way to pass KIO metadata right now, not even when using KFileWidget directly so one would first need to extend that API :(
Comment 8 Daniel Nicoletti 2021-02-19 17:15:39 UTC
My initial idea was to use KIO, BUT, the code for printers there is explicity disabled :( but indeed should be less work than talking to smb libs directly.
Comment 9 Harald Sitter 2021-02-22 10:37:58 UTC
Yep, the explicit disabling is why I think we want the ability to pass metadata via KIO::Job::addMetaData. On the GUI side we'd open a fopendialog with smb-browse-printers=true as metadata to switch the smb.so into a mode where it'd list printers rather than files.

OTOH having written that I realize we could also do it the other way around and have the printers listed with some vendor mimetype that the printer manager registers for. Which is kinda how windows does it. Then smb.so would always list printers. With dolphin it'd open through the mimetype association while from inside the printer manager it'd simply put a mimetype filter on the dialog. Vendor mimetypes are fairly meh though.
Comment 10 Bug Janitor Service 2021-12-03 11:13:06 UTC
A possibly relevant merge request was started @ https://invent.kde.org/utilities/print-manager/-/merge_requests/15
Comment 11 Harald Sitter 2021-12-20 21:27:29 UTC
Git commit b8e53b23b177983886c673cb617e794069d6c917 by Harald Sitter.
Committed on 20/12/2021 at 21:27.
Pushed by sitter into branch 'master'.

enable the smb browse button

M  +25   -1    add-printer/ChooseSamba.cpp

https://invent.kde.org/utilities/print-manager/commit/b8e53b23b177983886c673cb617e794069d6c917