Bug 398958 - Editing a layer name in the Layer Properties window has a fault
Summary: Editing a layer name in the Layer Properties window has a fault
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: Usability (show other bugs)
Version: nightly build (please specify the git hash!)
Platform: Debian stable Linux
: NOR minor
Target Milestone: ---
Assignee: Dmitry Kazakov
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-09-22 13:22 UTC by Ahab Greybeard
Modified: 2018-09-27 07:47 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ahab Greybeard 2018-09-22 13:22:41 UTC
If you right click a layer in the Layers docker to get the Layer Properties window then try to edit the layer name in there, you can place the cursor, move the cursor, select text for replacement etc. anywhere in the name but after typing the first character, the cursor moves to the end of the name. This is annoying and inconvenient but not a disaster.

A workaround is to use double-click on the layer name in the Layer docker since the name editing box presented there does work properly.


This fault is present in the 4.1.1 and 4.2.0 pre-alpha (127857b) appimages and in the 4.1.1 Windows installation.

Further note: If you edit the name of a bundle in the Manage Resource Bundles window, there is no problem with this.
Comment 1 Halla Rempt 2018-09-22 13:23:49 UTC
I can confirm that -- but I have no idea what might cause this to happen.
Comment 2 Halla Rempt 2018-09-22 13:27:04 UTC
Git commit 14d829e820d8ba6fd704d9c8f45e96e249c7bfa4 by Boudewijn Rempt.
Committed on 22/09/2018 at 13:25.
Pushed by rempt into branch 'master'.

Two notes:

* This also sets the width of the label to that of the chooser,
since otherwise if there are no constraints, the label will grow
anyway.
* The pattern names that have the entire bundle path in their
name are wrong, but that's a separate bug.

M  +8    -6    libs/ui/widgets/kis_pattern_chooser.cc
M  +2    -2    libs/ui/widgets/kis_pattern_chooser.h

https://commits.kde.org/krita/14d829e820d8ba6fd704d9c8f45e96e249c7bfa4
Comment 3 Halla Rempt 2018-09-22 13:27:36 UTC
Argh, that commit was meant for https://bugs.kde.org/show_bug.cgi?id=398837
Comment 4 Halla Rempt 2018-09-24 07:25:21 UTC
Git commit b1a3736d07e99e8a34d115abdf0b06159e1c6641 by Boudewijn Rempt.
Committed on 24/09/2018 at 07:05.
Pushed by rempt into branch 'krita/4.1'.

Two notes:

* This also sets the width of the label to that of the chooser,
since otherwise if there are no constraints, the label will grow
anyway.
* The pattern names that have the entire bundle path in their
name are wrong, but that's a separate bug.

M  +8    -6    libs/ui/widgets/kis_pattern_chooser.cc
M  +2    -2    libs/ui/widgets/kis_pattern_chooser.h

https://commits.kde.org/krita/b1a3736d07e99e8a34d115abdf0b06159e1c6641
Comment 5 Ahab Greybeard 2018-09-25 18:41:41 UTC
Has this bug been mistakenly marked as 'RESOLVED FIXED' because of confusion with the commits postings for  https://bugs.kde.org/show_bug.cgi?id=398837
?
Comment 6 Halla Rempt 2018-09-25 18:48:06 UTC
It got closed once more because pushing the fix to 4.1 closed the bug once again.
Comment 7 Dmitry Kazakov 2018-09-26 09:27:44 UTC
Git commit 00716fedf655b4859f353bb5b506d391cdfc2c21 by Dmitry Kazakov.
Committed on 26/09/2018 at 09:27.
Pushed by dkazakov into branch 'master'.

Fix cursor jumps in the Layer Properties dialog

M  +8    -2    libs/ui/dialogs/kis_dlg_layer_properties.cc

https://commits.kde.org/krita/00716fedf655b4859f353bb5b506d391cdfc2c21
Comment 8 Halla Rempt 2018-09-26 09:35:34 UTC
Git commit e03a872a0e630d71287e40bd125ec9a9c09476f2 by Boudewijn Rempt, on behalf of Dmitry Kazakov.
Committed on 26/09/2018 at 09:35.
Pushed by rempt into branch 'krita/4.1'.

Fix cursor jumps in the Layer Properties dialog

M  +8    -2    libs/ui/dialogs/kis_dlg_layer_properties.cc

https://commits.kde.org/krita/e03a872a0e630d71287e40bd125ec9a9c09476f2
Comment 9 Ahab Greybeard 2018-09-27 07:47:48 UTC
I confirm that this is now fixed in the 4.2.0 pre-alpha (04a7ade) appimage. (I haven't tested the latest Windows build).