Bug 396689 - Tab text color (for monitoring highlight?) does not reset
Summary: Tab text color (for monitoring highlight?) does not reset
Status: RESOLVED DUPLICATE of bug 402541
Alias: None
Product: konsole
Classification: Unclassified
Component: tabbar (show other bugs)
Version: 18.12.0
Platform: Other Linux
: NOR minor (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
: 401465 402394 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-07-20 12:45 UTC by Christoph Feck
Modified: 2018-12-27 10:56 UTC (History)
9 users (show)

See Also:
Latest Commit:
Version Fixed In: 19.04.0


Attachments
Screenshot for Konsole tab text color issue (10.42 KB, image/png)
2018-07-20 12:45 UTC, Christoph Feck
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christoph Feck 2018-07-20 12:45:50 UTC
Created attachment 114027 [details]
Screenshot for Konsole tab text color issue

New tabs start out with usual black tab text color. After using Konsole for some time, I see several tabs using a dark violet text color, probably used for monitoring (which I have not enabled). This color never resets back to black.

In attached screenshot, the first two tabs show this violet color. The last two tabs are freshly created, and still have the correct black text.

BTW, the monitoring actions are no longer present in the tab context menu.
Comment 1 Christoph Feck 2018-09-20 00:08:18 UTC
I now understand that this is not related to custom monitoring, but to automatic monitoring. When a tab receives output, but is not currently active, the tab automatically changes its color. Previously, this color was reset when visiting the tab.
Comment 2 Christoph Feck 2018-12-14 12:26:08 UTC
*** Bug 401465 has been marked as a duplicate of this bug. ***
Comment 3 Letto2 2018-12-20 23:49:50 UTC
*** Bug 402394 has been marked as a duplicate of this bug. ***
Comment 4 Arfrever Frehtes Taifersar Arahesis 2018-12-21 10:00:01 UTC
This bug appears to have been fixed during last 2 weeks.

Reproducible at time of commit 14b3c8be2c15ed9711b1308b4a991de4aad5802d from 2018-12-06.
Not reproducible at time of commit 64a93ce552c64f1f431cb164cb9ad553bc95b2b0 from 2018-12-19.
Comment 5 David Faure 2018-12-21 10:05:49 UTC
Still broken in Applications/18.12 branch though. This is quite annoying ;)
Comment 6 Arfrever Frehtes Taifersar Arahesis 2018-12-21 10:19:36 UTC
For still affected users, a workaround is to move a tab using 'Ctrl + Shift + Left Arrow' or 'Ctrl + Shift + Right Arrow' :) .
(Moving using mouse does not help...)
Comment 7 Arfrever Frehtes Taifersar Arahesis 2018-12-21 11:25:07 UTC
This bug was fixed as side effect of commit 7a43e3b2cde05a70a38c0bcac39051b675425bf9 (with follow-up in commit f2fab9a26a32caf08d24a7035893a3ba4d28ed61).

The first commit partially fails to apply to Applications/18.12 branch.
It can be applied after backporting commit 0709fdcbb5355d6dea2dd2b0e2ef9a635b698bc5.

So these 3 commits could be backported:
  0709fdcbb5355d6dea2dd2b0e2ef9a635b698bc5
  7a43e3b2cde05a70a38c0bcac39051b675425bf9
  f2fab9a26a32caf08d24a7035893a3ba4d28ed61
Comment 8 Christoph Feck 2018-12-27 10:56:55 UTC

*** This bug has been marked as a duplicate of bug 402541 ***