Bug 396064 - Restore defaults button resets to the previous saved setting and not the actual default settings
Summary: Restore defaults button resets to the previous saved setting and not the actu...
Status: RESOLVED FIXED
Alias: None
Product: krita
Classification: Unclassified
Component: Shortcuts and Canvas Input Settings (show other bugs)
Version: 4.1.0 beta
Platform: Other Linux
: NOR normal
Target Milestone: ---
Assignee: Krita Bugs
URL:
Keywords:
: 450483 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-07-01 19:43 UTC by Antti Savolainen
Modified: 2022-04-28 15:25 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Antti Savolainen 2018-07-01 19:43:06 UTC
Video visualization: https://youtu.be/Z5ODitlqHU0

Steps to reproduce:
Open settings
Select 'Canvas Input Settings'
Open 'Show Popup Palette' (I haven't tested any other setting)
Add a shortcut and save
Go back to that setting and Restore Defaults
Delete the new binding and try Restore Defaults again

Expected behavior: Only Right button should be left in the binding

Actual behavior: The last saved setting gets restored

Build & Platform:
    krita 4.2.0-pre-alpha
    Xubuntu 17.10
Comment 1 Tiar 2020-11-19 16:02:42 UTC
Note for a developer: see that there is also an option to reset configuration from Settings -> Reset Krita Configurations . I think it would be good to just rename this one as "Restore Previous"? (Reset Krita Configurations does something that might not be visible from the dialog, because it also resets the workspace etc.).
Comment 2 sh_zam 2022-04-04 08:32:38 UTC
Git commit c14d3bbdc2301c24ccf74186f654172ff40dc26a by Sharaf Zaman.
Committed on 04/04/2022 at 08:32.
Pushed by szaman into branch 'master'.

Bugfix: Restore Defaults doesn't work properly in Canvas Input Settings

Reason of the bug being, profileDir.entryList() returned an empty list.

M  +1    -1    libs/ui/input/config/kis_input_configuration_page.cpp

https://invent.kde.org/graphics/krita/commit/c14d3bbdc2301c24ccf74186f654172ff40dc26a
Comment 3 sh_zam 2022-04-11 09:11:37 UTC
Git commit f5bf73f98491fb01949b09285a54b92c05b93059 by Sharaf Zaman.
Committed on 11/04/2022 at 09:11.
Pushed by szaman into branch 'krita/5.0'.

Bugfix: Restore Defaults doesn't work properly in Canvas Input Settings

Reason of the bug being, profileDir.entryList() returned an empty list.
(cherry picked from commit c14d3bbdc2301c24ccf74186f654172ff40dc26a)

M  +1    -1    libs/ui/input/config/kis_input_configuration_page.cpp

https://invent.kde.org/graphics/krita/commit/f5bf73f98491fb01949b09285a54b92c05b93059
Comment 4 Eranthis stellata Maxim 2022-04-28 15:25:55 UTC
*** Bug 450483 has been marked as a duplicate of this bug. ***