Bug 395594 - Icon size for launcher in vertical panels
Summary: Icon size for launcher in vertical panels
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Application Launcher (Kickoff) (show other bugs)
Version: 5.13.0
Platform: Archlinux Packages Linux
: NOR normal
Target Milestone: 1.0
Assignee: David Edmundson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-06-19 05:00 UTC by Christian Muehlhaeuser
Modified: 2018-07-24 08:10 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Muehlhaeuser 2018-06-19 05:00:36 UTC
I've moved my default plasmashell panel to the right side of my monitor, so it becomes a vertical instead of a horizontal bar.

Before 5.13 the application launcher icon was horizontally centered in that panel, but only used a "regular" icon size. I haven't measured it, but it's roughly as high as a single entry in the task manager below it.

Since 5.13 the icon fills the entire width of the panel, keeping its aspect ratio while resizing. Having a fairly wide vertical panel, this means the application launcher icon is now occupying more than a third of the panel's entire height.

It would be nice to make the size of the icon either configurable or define "sane" boundaries for the dimensions. (Sane might be hard to argue about here, though)

Fwiw, I definitely preferred the previous behaviour which, while wasting a tiny bit of horizontal space, at least meant I could make the most of the panel.
Comment 1 Jose 2018-07-22 06:02:23 UTC
This is a regression. 

It was solved at 2017-06-02. This is the issue: https://bugs.kde.org/show_bug.cgi?id=378443
Comment 2 Eike Hein 2018-07-23 03:28:32 UTC
Can reproduce.
Comment 3 Eike Hein 2018-07-24 08:10:30 UTC
Git commit 664865f12bc756f4ac75e2915dfebb88aa3abf54 by Eike Hein.
Committed on 24/07/2018 at 08:09.
Pushed by hein into branch 'master'.

Fix Kickoff compact repr size hints in panel

Summary:
The old code was copy-pasted from Kicker but the wrong code block;
it was the code path for custom button image mode, not the regular
code path.

Reviewers: broulik

Subscribers: plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D14285

M  +43   -23   applets/kickoff/package/contents/ui/Kickoff.qml

https://commits.kde.org/plasma-desktop/664865f12bc756f4ac75e2915dfebb88aa3abf54