Bug 378443 - Plasma 5 start-button gets too big when the panel is vertical. (there was no problem in Plasma 4)
Summary: Plasma 5 start-button gets too big when the panel is vertical. (there was no ...
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Application Menu (Kicker) (show other bugs)
Version: master
Platform: Mint (Ubuntu based) Linux
: NOR normal
Target Milestone: 1.0
Assignee: Eike Hein
URL:
Keywords:
: 378958 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-04-04 17:01 UTC by Jan Fox
Modified: 2018-07-23 03:24 UTC (History)
4 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Panel vertically on the right. Start button at the upper right corner is too big. (642.97 KB, image/png)
2017-04-04 17:01 UTC, Jan Fox
Details
Just to illustrate the additional compliment and thanks (619.50 KB, image/png)
2017-04-04 17:02 UTC, Jan Fox
Details
Start button without this problem (in Mint 17.3 KDE 64Bit) (712.71 KB, image/png)
2017-04-04 17:03 UTC, Jan Fox
Details
Start button also without this problem (Debian 8.6 Jessie KDE 4.14.2) (39.03 KB, image/png)
2017-04-04 17:05 UTC, Jan Fox
Details
KDE-Version according to the KDE-Info-Center. (This version has the problem) (64.77 KB, image/png)
2017-04-04 18:19 UTC, Jan Fox
Details
Smaller icon (a scaled down sreenshot of the large icon) (3.06 KB, image/png)
2017-04-04 19:35 UTC, Jan Fox
Details
The smaller icon in use. Image 1. (642.08 KB, image/png)
2017-04-04 19:36 UTC, Jan Fox
Details
The smaller icon in use. Image 2. (544.78 KB, image/png)
2017-04-04 19:36 UTC, Jan Fox
Details
Using this small and wide image as icon unfortunately gave the same result as the small quadratic image (3.27 KB, image/png)
2017-04-04 21:37 UTC, Jan Fox
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Fox 2017-04-04 17:01:00 UTC
Created attachment 104877 [details]
Panel vertically on the right. Start button at the upper right corner is too big.

I found this problem in Linux Mint 18.1 64Bit KDE (see images).
The KDE version is 4.14.22 [tested in the terminal per "kde-open --version"].

Mint uses Plasma 5 since version 18.

In Mint 17.3 64Bit KDE there was no problem (see images)


PS: I very much enjoy, that you decided to enrich the classical start menu adding the search bar (as seen in the image)!
Comment 1 Jan Fox 2017-04-04 17:02:35 UTC
Created attachment 104878 [details]
Just to illustrate the additional compliment and thanks
Comment 2 Jan Fox 2017-04-04 17:03:49 UTC
Created attachment 104879 [details]
Start button without this problem (in Mint 17.3 KDE 64Bit)
Comment 3 Jan Fox 2017-04-04 17:05:19 UTC
Created attachment 104880 [details]
Start button also without this problem (Debian 8.6 Jessie KDE 4.14.2)
Comment 4 Eike Hein 2017-04-04 17:29:28 UTC
For now what you could do is use the Custom Image option in the settings dialog of the applet to pick a smaller image/icon.
Comment 5 Jan Fox 2017-04-04 18:19:37 UTC
Created attachment 104881 [details]
KDE-Version according to the KDE-Info-Center. (This version has the problem)
Comment 6 Jan Fox 2017-04-04 19:33:03 UTC
(In reply to Eike Hein from comment #4)
> For now what you could do is use the Custom Image option in the settings
> dialog of the applet to pick a smaller image/icon.

Thank you very much for the quick reply.

Unfortunately, this did not work. 

The image became smaller but the area obtained by the start-button remains the same.

I add the screenshots to illustrate.
Comment 7 Jan Fox 2017-04-04 19:35:05 UTC
Created attachment 104882 [details]
Smaller icon (a scaled down sreenshot of the large icon)
Comment 8 Jan Fox 2017-04-04 19:36:25 UTC
Created attachment 104883 [details]
The smaller icon in use. Image 1.
Comment 9 Jan Fox 2017-04-04 19:36:56 UTC
Created attachment 104884 [details]
The smaller icon in use. Image 2.
Comment 10 Eike Hein 2017-04-04 19:39:13 UTC
Does it stay big when you restart Plasma?

What if you try an image that has the right aspect ratio - make one as tall and wide as you want (i.e. bake in some horizontal padding).

Sorry for the trouble.
Comment 11 Jan Fox 2017-04-04 21:37:13 UTC
Created attachment 104887 [details]
Using this small and wide image as icon unfortunately gave the same result as the small quadratic image
Comment 12 Jan Fox 2017-04-04 21:45:24 UTC
(In reply to Eike Hein from comment #10)
> Does it stay big when you restart Plasma?
> 
> What if you try an image that has the right aspect ratio - make one as tall
> and wide as you want (i.e. bake in some horizontal padding).
> 
> Sorry for the trouble.



Again, thank you for your ideas.

I did a reboot after implementing the small+wide image (as attached above) but nothing changed, I'm afraid. 

Just to make sure, I also implemented the small+quadratic image (attached previously) followed by a reboot. But no change there either.
Comment 13 Jan Fox 2017-04-14 19:48:02 UTC
Just to make sure that there is no misunderstanding:
Neither the small+quadratic image nor the small+wide image solved the problem. 
The area occupied by the kde-start-button remains too large (see images "The smaller icon in use").

I put my hope in future KDE-versions.
Comment 14 Abscissa 2017-04-25 18:45:43 UTC
This issue has been keeping me on KDE4 for years, despite having brought it up on the forums as far back as 2014 with no response whatsoever (except for a link to this ticket just this month):

https://forum.kde.org/viewtopic.php?f=83&t=122938&p=319975#p319975
https://forum.kde.org/viewtopic.php?f=289&t=131908

TO REPRODUCE THIS ISSUE (trivial):

This is trivial to reproduce on any KDE5/Plasma5 installation:

1. Create a new "Default Panel".

2. Move it to the left or right side of the screen.

3. Adjust the width so the text on the task manager button is actually readable and doesn't look like Win7 or OSX.

The issue is now reproduced.

Note too, that "Kicker" is not the only widget that exhibits this problem. MOST other widgets available also exhibit the same problem, including all the alternate application menus and the "three ball" activities menu.

Unlike KDE4, this has nothing to do the images used, and has everything to do with the way Plasma5 calculates sizes for widgets on a panel.
Comment 15 Eike Hein 2017-04-26 07:47:08 UTC
Note the forums are not the bug tracker, the developers don't usually check there (it's too unstructured and takes too much time).

I'll take a stab at improving this for the Plasma 5.10 release, probably hacking on it today. Please don't get too frustrated, we can see it's a problem and agree.
Comment 16 Eike Hein 2017-04-26 10:59:16 UTC
Patch for Kicker/Dashboard under review: https://phabricator.kde.org/D5592

Kickoff needs a separate patch.
Comment 17 Eike Hein 2017-04-26 11:58:19 UTC
Git commit 4f48901b05fd9e543c958561543f19f617c0b177 by Eike Hein.
Committed on 26/04/2017 at 11:41.
Pushed by hein into branch 'master'.

Introduce units.iconSizeHints.* to provide user-configurable icon size hints

Summary:
In effect this is meant to resurrect the "Panel" icon size setting from
the Icons -> Advanced KCM in System Settings, for use as a ceiling on
panel icons to avoid them taking up too much space, especially in wide
vertical panels.

Previously, the actually-unused "Desktop" size hint was added to the
iconSizes map. I believe this was in error, as the size hints are
semantically different from the size classes. This patch marks the
"desktop" iconSizes map entry as deprecated and makes it available
under iconSizeHints instead.

The soon-to-be-updated D5592 will demonstrate this API in use.

Reviewers: #plasma, mart

Subscribers: plasma-devel, #frameworks

Tags: #plasma, #frameworks

Differential Revision: https://phabricator.kde.org/D5593

M  +10   -0    src/declarativeimports/core/units.cpp
M  +25   -4    src/declarativeimports/core/units.h

https://commits.kde.org/plasma-framework/4f48901b05fd9e543c958561543f19f617c0b177
Comment 18 Eike Hein 2017-04-26 12:03:21 UTC
Git commit eae7910ed13724649f5ac0fc98680e11865e721a by Eike Hein.
Committed on 26/04/2017 at 11:57.
Pushed by hein into branch 'master'.

Configurable icon size

Summary:
This patch uses the new units.iconSizeHints.panel API to limit the
icon size to what the user sets for panel icons in System Settings,
avoiding them taking up too much space, particularly in wide vertical
panels.

See D5592, D5594 and D4550 for similar changes.

Depends on D5593.

Subscribers: plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D5595

M  +8    -0    desktoppackage/contents/applet/DefaultCompactRepresentation.qml

https://commits.kde.org/plasma-desktop/eae7910ed13724649f5ac0fc98680e11865e721a
Comment 19 Eike Hein 2017-04-26 12:03:22 UTC
Git commit ad08c43ccaa28005750f4a04e2283cb78ecdbed6 by Eike Hein.
Committed on 26/04/2017 at 11:54.
Pushed by hein into branch 'master'.

Configurable icon size

Summary:
This patch uses the new units.iconSizeHints.panel API to limit the
icon size to what the user sets for panel icons in System Settings,
avoiding them taking up too much space, particularly in wide vertical
panels.

See D4550 for a similar change.

A similar change will need to be done for Kickoff, which uses the
default CompactRepr instead.

Depends on D5593.

Reviewers: #plasma, mart

Subscribers: plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D5592

M  +8    -4    applets/kicker/package/contents/ui/CompactRepresentation.qml

https://commits.kde.org/plasma-desktop/ad08c43ccaa28005750f4a04e2283cb78ecdbed6
Comment 20 Eike Hein 2017-04-26 12:04:40 UTC
Git commit 0f8302c2c38ca8f60e76b118daa651a3b1ee89c9 by Eike Hein.
Committed on 26/04/2017 at 12:04.
Pushed by hein into branch 'master'.

Configurable icon size

Summary:
This patch uses the new units.iconSizeHints.panel API to limit the
icon size to what the user sets for panel icons in System Settings,
avoiding them taking up too much space, particularly in wide vertical
panels.

See D5592 and D4550 for similar changes.

Depends on D5593.

Reviewers: #plasma, mart, broulik

Subscribers: plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D5594

M  +7    -0    applets/icon/package/contents/ui/main.qml

https://commits.kde.org/plasma-workspace/0f8302c2c38ca8f60e76b118daa651a3b1ee89c9
Comment 21 Eike Hein 2017-04-26 12:05:48 UTC
With the above changes for Plasma 5.10, the size of the Kickoff/Kicker/Dashboard icons and generally icon-like panel applets will no longer grow beyond the size configured for "Panel" in Icons -> Advanced in System Settings.
Comment 22 Abscissa 2017-04-26 16:13:41 UTC
Fantastic! Thanks!
Comment 23 Christoph Feck 2017-04-27 00:56:48 UTC
*** Bug 378958 has been marked as a duplicate of this bug. ***
Comment 24 Abscissa 2017-05-19 00:10:16 UTC
Just checked this out in the latest Neon unstable live disc. While it's definitely improved ("Show Desktop" works perfectly and immediately reacts to changes in the "Panel" Icon Size setting (when applied)), there are still some issues with still with other widgets:

- "Application Menu" and "Application Dashboard" doesn't react immediately to Icon Size changes. I have to force it to refresh first. I did that by switching the widget to something else (like "Application Launcher") and back again.

- "Application Menu" and "Application Dashboard" *sometimes* react to changes in "Desktop" Icon Size. But then sometimes it seems to go with the "Panel" Icon Size. Try playig around with changing the icon size setting and then using the "Alternatives... -> Switch" feature.

- The following widgets (that I've discovered so far) are completely unaffected by this fix and still exhibit the old, incorrect behavior:

* "Application Launcher"
* "Activities" (a problem for me, since I use this)
* "Activity Bar"
* "Quicklaunch" (This might be a separate issue though, due to the way it seems to work)
* "Analog Clock"
* "Binary Clock"
* "Calendar"
* "Bluetooth"

There may be others as well, I didn't check all of them.
Comment 25 Eike Hein 2017-05-23 22:24:20 UTC
Many of the above shouldn't actually follow this setting, but Application Launcher is a legit bug, as are some of the others.
Comment 26 Eike Hein 2017-05-23 23:42:49 UTC
Git commit b45cb75675c92924db4b38ebc55d9ab93d53fb1f by Eike Hein.
Committed on 23/05/2017 at 23:42.
Pushed by hein into branch 'Plasma/5.10'.

Implement the new panel icon size ceiling also for Kickoff.

Summary:
It was done for various other applets but not this.

Reviewers: #plasma, mart

Subscribers: plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D5949

M  +7    -0    applets/kickoff/package/contents/ui/Kickoff.qml

https://commits.kde.org/plasma-desktop/b45cb75675c92924db4b38ebc55d9ab93d53fb1f
Comment 27 Eike Hein 2017-05-23 23:42:50 UTC
Git commit a8d9038a592e6d3ed87852bc2fb3a0f93449897d by Eike Hein.
Committed on 23/05/2017 at 23:42.
Pushed by hein into branch 'Plasma/5.10'.

Implement the new panel icon size ceiling also for Activities.

Summary:
It was done for various other applets but not this.

Reviewers: #plasma, mart

Subscribers: plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D5950

M  +7    -2    applets/showActivityManager/package/contents/ui/main.qml

https://commits.kde.org/plasma-desktop/a8d9038a592e6d3ed87852bc2fb3a0f93449897d
Comment 28 Eike Hein 2017-05-24 15:41:43 UTC
Git commit 4f3998ae791446fee9d2332b94e770753774850c by Eike Hein.
Committed on 23/05/2017 at 23:01.
Pushed by hein into branch 'Plasma/5.10'.

Implement the new panel icon size ceiling also for Bluetooth.

Summary:
It was done for various other applets but not this.

Reviewers: #plasma, mart, broulik

Subscribers: plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D5951

M  +10   -0    src/applet/package/contents/ui/CompactRepresentation.qml

https://commits.kde.org/bluedevil/4f3998ae791446fee9d2332b94e770753774850c
Comment 29 Weng Xuetian 2017-05-24 18:14:22 UTC
Git commit a0dee59dcf28a530741a0ff6c71aef782feba9e4 by Weng Xuetian.
Committed on 24/05/2017 at 18:14.
Pushed by xuetianweng into branch 'master'.

Implement the new panel icon size ceiling also for Input Method Panel.

Summary:
It was done for various other applets but not this.

Reviewers: #plasma, mart, broulik, hein

Reviewed By: #plasma, hein

Subscribers: plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D5962

M  +37   -34   applets/kimpanel/package/contents/ui/main.qml

https://commits.kde.org/plasma-desktop/a0dee59dcf28a530741a0ff6c71aef782feba9e4
Comment 30 Weng Xuetian 2017-05-24 18:20:32 UTC
Git commit e3869e559da25d2fecdfb5418a5af6079a1dc2b3 by Weng Xuetian.
Committed on 24/05/2017 at 18:19.
Pushed by xuetianweng into branch 'Plasma/5.10'.

Implement the new panel icon size ceiling also for Input Method Panel.

Summary:
It was done for various other applets but not this.

Reviewers: #plasma, mart, broulik, hein

Reviewed By: #plasma, hein

Subscribers: plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D5962

M  +37   -34   applets/kimpanel/package/contents/ui/main.qml

https://commits.kde.org/plasma-desktop/e3869e559da25d2fecdfb5418a5af6079a1dc2b3
Comment 31 Eike Hein 2017-06-02 09:04:58 UTC
Git commit 200d5a73cbdb76a1b0df29c5cf502fd88b922542 by Eike Hein.
Committed on 02/06/2017 at 09:04.
Pushed by hein into branch 'Plasma/5.10'.

React to changes in the size hint.

M  +6    -0    applets/kicker/package/contents/ui/CompactRepresentation.qml

https://commits.kde.org/plasma-desktop/200d5a73cbdb76a1b0df29c5cf502fd88b922542
Comment 32 Jose 2018-07-22 06:04:46 UTC
In 5.13 the problem has come back.

See this new issue: https://bugs.kde.org/show_bug.cgi?id=395594
Comment 33 Eike Hein 2018-07-23 03:24:33 UTC
Thanks. Let's use the new ticket then.