Bug 395012 - Skins can't be installed from KNS
Summary: Skins can't be installed from KNS
Status: RESOLVED FIXED
Alias: None
Product: yakuake
Classification: Applications
Component: general (show other bugs)
Version: Git (Frameworks 5)
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Eike Hein
URL:
Keywords:
: 390155 399887 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-06-03 22:13 UTC by Lionel Chauvin
Modified: 2019-03-11 11:00 UTC (History)
8 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
patch (2.81 KB, text/plain)
2018-06-03 22:13 UTC, Lionel Chauvin
Details
attachment-5878-0.html (1.32 KB, text/html)
2019-03-05 10:49 UTC, Andrei
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lionel Chauvin 2018-06-03 22:13:47 UTC
Created attachment 113055 [details]
patch

When a Skin is downloaded from KNS, Yakuake fails to validate the presence of title.skin and tabs.skin files.
The skin is then uninstalled even if these files exist.

This is due to this optimization of KNS: https://phabricator.kde.org/D6104
Files are not listed anymore by entry.installedFiles().
They are replaced by paths that end with /*
Comment 1 Lionel Chauvin 2018-06-04 15:10:22 UTC
Hi, Ein Kein
Can I add you as a reviewer on https://phabricator.kde.org/D13335 ?
Comment 2 Lionel Chauvin 2018-06-04 15:11:40 UTC
Hi, Eike Hein
Can I add you as a reviewer on https://phabricator.kde.org/D13335 ?
Comment 3 Andrei 2018-12-01 17:14:57 UTC
Just wanted to confirm the bug, have to install skins manually.
Comment 4 Patrick Silva 2019-01-06 17:03:35 UTC
*** Bug 399887 has been marked as a duplicate of this bug. ***
Comment 5 Neousr 2019-02-08 18:01:51 UTC
Can confirm this on Plasma 5.14.5 some time ago i circumvented this by manually installing a skin.
Comment 6 Patrick Silva 2019-02-28 13:48:00 UTC

*** This bug has been marked as a duplicate of bug 390155 ***
Comment 7 Colin Jaffe 2019-03-05 03:21:45 UTC
How does one manually install a yakuake skin?
Comment 8 Andrei 2019-03-05 10:49:07 UTC
Created attachment 118570 [details]
attachment-5878-0.html

Download skin and extract it to ~/.local/share/yakuake/kns_skins/

вт, 5 мар. 2019 г., 6:21 Colin Jaffe <bugzilla_noreply@kde.org>:

> https://bugs.kde.org/show_bug.cgi?id=395012
>
> Colin Jaffe <abbreviatedman@posteo.net> changed:
>
>            What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>                  CC|                            |abbreviatedman@posteo.net
>
> --- Comment #7 from Colin Jaffe <abbreviatedman@posteo.net> ---
> How does one manually install a yakuake skin?
>
> --
> You are receiving this mail because:
> You are on the CC list for the bug.
Comment 9 Eike Hein 2019-03-10 07:31:07 UTC
Git commit d9537fcba90ba912c8ea50c4733d6189cdb15b01 by Eike Hein, on behalf of Lionel Chauvin.
Committed on 10/03/2019 at 07:30.
Pushed by hein into branch 'master'.

Fix Skin validation when installed from KNS

Summary:
When a Skin is downloaded from KNS, Yakuake fails to validate the presence of title.skin and tabs.skin files.
The skin is then uninstalled even if these files exist.

This is due to this optimization of KNS: https://phabricator.kde.org/D6104
Files are not listed anymore by entry.installedFiles().
They are replaced by paths that end with /*

In order to fix this bug I changed the validateSkin method so that it checks the presence of files in the filesystem instead of in a list of entries returned by KNS.

Test Plan:
Download a Skin from KNS:  It should not complain about missing files.
Install a correct skin from local: it should not  complain about missing files;
Install a wrong skin from local: it should  complain about missing files;
Install a correct skin already installed from local: it should ask for overwrite existing skin.

Reviewers: hein, apol, #yakuake

Reviewed By: hein

Subscribers: Zren, hein, apol, chauvin

Tags: #yakuake

Differential Revision: https://phabricator.kde.org/D13335

M  +45   -59   app/config/appearancesettings.cpp
M  +4    -3    app/config/appearancesettings.h

https://commits.kde.org/yakuake/d9537fcba90ba912c8ea50c4733d6189cdb15b01
Comment 10 Patrick Silva 2019-03-10 09:25:47 UTC
*** Bug 390155 has been marked as a duplicate of this bug. ***
Comment 11 Christoph Feck 2019-03-11 11:00:00 UTC
Yakuake is not part of KDE Applications, but released separately.