Bug 392488 (libinput-mouse-kcm-middle-click-paste) - Setting to disable middle click paste
Summary: Setting to disable middle click paste
Status: RESOLVED DUPLICATE of bug 441668
Alias: libinput-mouse-kcm-middle-click-paste
Product: systemsettings
Classification: Applications
Component: kcm_mouse (show other bugs)
Version: 5.22.0
Platform: Other Linux
: NOR normal with 40 votes (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords: usability
Depends on:
Blocks:
 
Reported: 2018-03-29 14:12 UTC by jeremy9856
Modified: 2022-04-07 12:15 UTC (History)
6 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jeremy9856 2018-03-29 14:12:33 UTC
Hello,

We should be able to disable middle click paste for touchpad and mouse to avoid unwanted copy / paste for those who have sensible touchpad and mouse.

It's possible on Gnome :

org.gnome.desktop.interface gtk-enable-primary-paste -> False

Thanks !
Comment 1 Christoph Feck 2018-03-30 03:27:21 UTC
Needs a new setting in http://doc.qt.io/qt-5/qstylehints.html

Standard Qt widgets (QLineEdit, QTextEdit) and individual applications (Kate/KWrite, Konsole, Calligra, etc.) need to be changed to respect this setting.
Comment 2 KC 2019-11-17 12:34:00 UTC
This would be very useful, indeed!
Comment 3 postix 2021-06-13 10:04:57 UTC
This is really needed and super annoying when you use a touchpad on a laptop, where a light tap around the center is misinterpreted as a middle click and thus unintentionally content is pasted!

I only have found one hacky workaround so far [1] involving an sxkhd script.

[1] https://www.reddit.com/r/kde/comments/nyqf13/how_to_disable_middle_click_paste/h1lofqu/?context=3
Comment 4 jimbo 2021-09-06 13:39:26 UTC
The workaround can break normal control+c functionality in Chromium. There should be an option to disable this functionality.
Comment 5 jimbo 2021-09-06 13:45:25 UTC
* sorry, Firefox not Chromium
Comment 6 postix 2021-10-18 08:43:50 UTC

*** This bug has been marked as a duplicate of bug 441668 ***