Bug 389710 (libinput-touchpad-kcm-middle-click-paste) - Setting to disable middle click paste
Summary: Setting to disable middle click paste
Status: RESOLVED DUPLICATE of bug 441668
Alias: libinput-touchpad-kcm-middle-click-paste
Product: systemsettings
Classification: Applications
Component: kcm_touchpad (show other bugs)
Version: 5.17.5
Platform: Other Linux
: NOR wishlist with 21 votes (vote)
Target Milestone: ---
Assignee: Plasma Bugs List
URL:
Keywords: usability
Depends on:
Blocks:
 
Reported: 2018-01-31 17:39 UTC by jeremy9856
Modified: 2022-04-07 12:18 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jeremy9856 2018-01-31 17:39:28 UTC
Hello,

We should be able to disable middle click paste for touchpad and mouse to avoid unwanted copy / paste for those who have sensible touchpad and mouse.

It's possible on Gnome :

org.gnome.desktop.interface gtk-enable-primary-paste -> False

Thanks !
Comment 1 Nate Graham 2018-02-17 15:50:12 UTC
Jeremy, if there were a setting for this, would you still use the touchpad virtual middle mouse button for anything?

In other words, would a setting to disable the virtual middle mouse button itself satisfy you here, or do you use the virtual middle mouse button for other things, and just don't want it to paste?
Comment 2 jeremy9856 2018-02-17 17:35:09 UTC
When I use Gnome I still use middle click to, for instance, close browser tabs. It's just the middle click paste that bother me.

By the way my request also apply to mouse (old mouse that now have a too sensitive middle click) but I didn't find where to report it.

Thank you.
Comment 3 jeremy9856 2018-03-02 07:03:12 UTC
Even elementary OS / Pantheon have it now

https://medium.com/elementaryos/juno-progress-for-january-february-9b276042716e
Comment 4 David 2018-07-09 08:07:11 UTC
Would be nice to have this option in systemsettings in the "mouse" section in input devices. I realize this comes from xorg rather than from KDE, and can currently be disabled through third-party tools, but would still make sense to have in the KDE settings.
Comment 5 Justin Zobel 2021-03-13 02:01:40 UTC
I think this would still be wanted by many users.
Comment 6 Nate Graham 2021-10-29 13:57:44 UTC

*** This bug has been marked as a duplicate of bug 441668 ***