Bug 391886 - Following a recent update of udisk2 from 2.6.5 to 2.7.6 Dolphin, for example, is unable to mount media.
Summary: Following a recent update of udisk2 from 2.6.5 to 2.7.6 Dolphin, for example,...
Status: RESOLVED DUPLICATE of bug 391386
Alias: None
Product: frameworks-solid
Classification: Unclassified
Component: general (show other bugs)
Version: 5.43.0
Platform: openSUSE RPMs Linux
: NOR normal
Target Milestone: ---
Assignee: Lukáš Tinkl
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-15 12:45 UTC by Paul
Modified: 2018-03-15 19:47 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot of (Dolphin) mount error. (133.34 KB, image/jpeg)
2018-03-15 12:45 UTC, Paul
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paul 2018-03-15 12:45:11 UTC
Created attachment 111414 [details]
Screenshot of (Dolphin) mount error.

Following a recent update of udisk2 from 2.6.5 to 2.7.6 Dolphin, for example, is unable to mount media.

This happens when attempting to mount any device, external USB, internal (unmounted) drive, no matter what.

The error reported by Dolphin is:

"An error occurred while accessing 'Wastebin'; the system responded: The device is already mounted: Device /dev/sd(Xn) is already mounted at '/run/media/(user)/(device label)'."

(See attached Screenshot)

Downgrading udisks2 back to 2.6.5 "cures" the problem, media mounts correctly without error.


See also this https://forums.opensuse.org/showthread.php/530169-Since-TW-snapshot-20180312-Dolphin-throws-a-wobbly-when-attempting-to-mount-media thread on the openSUSE user forums.


Using:
Plasma 5.12.3
Frameworks 5.43.0
Qt 5.10.0
Comment 1 Paul 2018-03-15 14:36:30 UTC
Follow up:

Just found these, the first looks very similar to the problem I observed.

https://bugs.kde.org/show_bug.cgi?id=391290

The second may also be related.

https://bugs.kde.org/show_bug.cgi?id=391386


I temporarily reverted back to udisks2 2.7.6 and indeed the media is actually mounted, despite the warning.

Open Dolphin
Insert USB stick
Click to mount - error displayed
Click elsewhere on a "Places" entry (Home, Downloads, whatever)
Re-Click on the USB device - now shown as mounted and Dolphin displays the contents.
Comment 2 Patrick Silva 2018-03-15 19:47:30 UTC

*** This bug has been marked as a duplicate of bug 391386 ***