Bug 391290 - Dolphin double mounts the partition and writes a warning
Summary: Dolphin double mounts the partition and writes a warning
Status: RESOLVED DUPLICATE of bug 391386
Alias: None
Product: dolphin
Classification: Unclassified
Component: panels: information (show other bugs)
Version: 17.12.2
Platform: Kubuntu Packages Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Dolphin Bug Assignee
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-03-02 12:27 UTC by lega99
Modified: 2018-03-15 22:07 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Dolphin looks at the controversial situation (144.12 KB, image/png)
2018-03-02 12:27 UTC, lega99
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lega99 2018-03-02 12:27:01 UTC
Created attachment 111135 [details]
Dolphin looks at the controversial situation

Dolphin double mounts the partition and writes a warning. This is happening in Kubuntu and Manjaro KDE, plasma 5.12.2. All other linux file managers do not have this problem. I tried downgrade Dolphin, but the same error appeared.
Plus the absurd situation, nonsense in Kali, Dolphin can not run in root mode and it is placed as default file manager in Kali linux KDE
Comment 1 Paul 2018-03-15 14:40:16 UTC
What version of "udisks2" do you have?

I'm seeing what I believe is the same problem on openSUSE Tumbleweed following a udisks2 upgrade 2.6.5 -> 2.7.6

See:
https://forums.opensuse.org/showthread.php/530169-Since-TW-snapshot-20180312-Dolphin-throws-a-wobbly-when-attempting-to-mount-media 
and:
https://bugs.kde.org/show_bug.cgi?id=391886
Comment 2 Patrick Silva 2018-03-15 19:48:19 UTC

*** This bug has been marked as a duplicate of bug 391386 ***
Comment 3 lega99 2018-03-15 22:07:18 UTC
In Neon linux LTS and Neon user edition I have udisks2 2.1.7-1ubuntu1. The problem is a bit more complex and I decided to switch off partition mounting in the system setup. In the fstab file I only mount the ntfs partition via the uuid number. With these settings Dolphin works ok mounting the linux partition even though I turned it off in system setup. It is interesting that the Nemo file manager has no problems, I tried in Neon Linux. In Calculate the linux variants of Gentoo I have no udisks2, there is a same bug and it has the same problem. Manjaro has the same problem and everything started with the new plasma 5.12.x. The only version that works ok is in the system setup to turned off mount partitions and mount in fstab ntfs partition.