Bug 390021 - Add day option to Night Color
Summary: Add day option to Night Color
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Applications
Component: kcm_nightcolor (show other bugs)
Version: 5.17.0
Platform: Neon Linux
: NOR wishlist with 20 votes (vote)
Target Milestone: ---
Assignee: KWin default assignee
URL:
Keywords:
: 430292 444143 447987 451574 (view as bug list)
Depends on:
Blocks:
 
Reported: 2018-02-07 17:25 UTC by KDE Neon user
Modified: 2022-08-31 19:36 UTC (History)
15 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.26


Attachments
LightBulb screenshot on Windows (17.53 KB, image/png)
2018-02-07 17:25 UTC, KDE Neon user
Details

Note You need to log in before you can comment on or make changes to this bug.
Description KDE Neon user 2018-02-07 17:25:26 UTC
Created attachment 110411 [details]
LightBulb screenshot on Windows

Like the built-in implementations by Windows 10 and Gnome, the new Night Color feature of KDE missed an essential feature of redshift and similar third-party programs: allowing users to set the (top) day color value. This allows people to completely limit the range to be used throughout the entire day.
Comment 1 Roman Gilg 2018-02-07 22:53:26 UTC
The idea was to put the daytime/overall color temperature value in the end in a separate KCM, that replaces KGamma on Wayland and handles all color correction. This should then also do this per screen.

The nighttime color temperature value would then be a relative delta to the daytime/overall color temperature value on each screen.

Fine with that?
Comment 2 KDE Neon user 2018-02-08 16:49:31 UTC
That makes sense, since you control the system settings directly.

Could the Night Color KCM somehow link to the main color KCM you've mentioned, so users who are used to setting it through third-party Night Color-like programs can easily find it?
Comment 3 Anthony Fieroni 2019-03-13 07:43:33 UTC
(In reply to Roman Gilg from comment #1)
> The idea was to put the daytime/overall color temperature value in the end
> in a separate KCM, that replaces KGamma on Wayland and handles all color
> correction. This should then also do this per screen.
> 
> The nighttime color temperature value would then be a relative delta to the
> daytime/overall color temperature value on each screen.
> 
> Fine with that?

I look at the code of night color so it will be better to be distinct kcm, also note that's good feature, by myself i'm using it for years (at days as well) so that's missing in Wayland.
Comment 4 Anthony Fieroni 2019-10-27 15:29:02 UTC
I'm fine with 'Constant mode' it makes sense to me since i use ~4000k temp.
Comment 5 Pierpaolo Valerio 2020-11-08 09:12:09 UTC
Any news on this issue? Personally this single-handedly makes wayland unusable for me, as I wouldn't be able to run redshift to adjust my screen temperature.
Comment 6 Nate Graham 2020-12-17 21:09:12 UTC
*** Bug 430292 has been marked as a duplicate of this bug. ***
Comment 7 geisserml 2021-05-03 19:06:31 UTC
I'd also like/need an option to set the day-time monitor colour temperature. This is one of the features I have been missing the most and already wanted to ask for since a longer time.
Currently I open the night colours kcm many times a day and set the temperature manually, but that's tedious.
My dream would be the possibility to make a custom graph for the colour temperature over the day, but that's probably a bit too fulsome...
A simple day-time setting would really be enough and a great improvement that I'd love to see on the next Nate Graham "This week in kde" blog post 😊🙈
Comment 8 Nate Graham 2021-10-21 13:09:51 UTC
*** Bug 444143 has been marked as a duplicate of this bug. ***
Comment 9 Nate Graham 2021-11-23 22:48:43 UTC
*** Bug 445758 has been marked as a duplicate of this bug. ***
Comment 10 Nate Graham 2022-01-12 20:45:22 UTC
*** Bug 447987 has been marked as a duplicate of this bug. ***
Comment 11 Nate Graham 2022-03-26 02:23:28 UTC
*** Bug 451574 has been marked as a duplicate of this bug. ***
Comment 12 Bug Janitor Service 2022-08-28 19:48:25 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/kwin/-/merge_requests/2871
Comment 13 Bug Janitor Service 2022-08-28 19:49:40 UTC
A possibly relevant merge request was started @ https://invent.kde.org/plasma/plasma-workspace/-/merge_requests/2055
Comment 14 Nate Graham 2022-08-31 19:35:26 UTC
Git commit 8e8b6145008234323a51b5bd607c3a194a73cc29 by Nate Graham, on behalf of Natalie Clarius.
Committed on 31/08/2022 at 18:58.
Pushed by ngraham into branch 'master'.

plugins/nightcolor: add configurable day temperature

M  +1    -1    src/plugins/nightcolor/constants.h
M  +3    -2    src/plugins/nightcolor/nightcolormanager.cpp
M  +3    -3    src/plugins/nightcolor/nightcolormanager.h
M  +3    -0    src/plugins/nightcolor/nightcolorsettings.kcfg

https://invent.kde.org/plasma/kwin/commit/8e8b6145008234323a51b5bd607c3a194a73cc29