Bug 389079 - With gedit installed from Flathub and GNOME nightly repo, trying to launch GNOME nightly version launches Flathub version
Summary: With gedit installed from Flathub and GNOME nightly repo, trying to launch GN...
Status: RESOLVED FIXED
Alias: None
Product: Discover
Classification: Unclassified
Component: Flatpak Backend (show other bugs)
Version: unspecified
Platform: Neon Packages Linux
: NOR normal
Target Milestone: ---
Assignee: Aleix Pol
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2018-01-17 00:07 UTC by Nate Graham
Modified: 2018-02-22 20:46 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nate Graham 2018-01-17 00:07:28 UTC
[Discover with PackageKit, Snap, and Flatpak backends compiled from source on KDE Neon]

Steps to reproduce:
1. Add Flathub repo
2. Add GNOME nightly runtime repo (https://sdk.gnome.org/nightly/repo)
3. Add GNOME nightly apps repo (https://sdk.gnome.org/nightly/repo-apps)
4. Install gedit from Flathub
5. Install gedit from the GNOME nightly repo
6. Click the Launch button on the page for gedit from the GNOME nightly repo


Expected results:
- The GNOME nightly version of gedit launches


Actual results:
- The Flathub version of gedit launches


Reproducibility:
- Could not reproduce with Kdenlive when installed from Flathub and kdeapps. I could launch each independent version without issue.


Impact:
- This breaks the user scenario where a user wants to temporarily switch to a different version of a Flatpak app, perhaps to verify that a bug is fixed or see whether they like a newer version.
Comment 1 Nate Graham 2018-01-25 14:07:34 UTC
Still present as of the latest commits on the Plasma/5.12 branch.
Comment 2 Aleix Pol 2018-02-06 12:16:38 UTC
Can you check if you can reproduce with the CLI runtime?

flatpak run org.gnome.gedit//stable
flatpak run org.gnome.gedit//unstable
Comment 3 Aleix Pol 2018-02-22 18:46:47 UTC
Can you please answer what I asked on the last comment?
Also yesterday I fixed some issues when there's several of these. Can you check if you can still reproduce?
Comment 4 Nate Graham 2018-02-22 20:46:31 UTC
Sorry, I missed that request.

Indeed, I can no longer reproduce; this now works! Fantastic news.