Bug 388302 - Non-recurring all-day to-dos show up on wrong due date in agenda view
Summary: Non-recurring all-day to-dos show up on wrong due date in agenda view
Status: RESOLVED FIXED
Alias: None
Product: korganizer
Classification: Applications
Component: agendaview (weekview) (show other bugs)
Version: 5.9.2
Platform: unspecified Linux
: NOR normal with 40 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords: regression, reproducible
: 425313 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-12-28 18:10 UTC by Boian Berberov
Modified: 2020-10-28 10:40 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Screenshot of bug (36.15 KB, image/png)
2017-12-28 18:10 UTC, Boian Berberov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Boian Berberov 2017-12-28 18:10:26 UTC
Created attachment 109559 [details]
Screenshot of bug

Creating a new all-day todo shows up as due on the previous day.  When it becomes overdue it works correctly.  See image.
Comment 1 Boian Berberov 2017-12-31 21:08:55 UTC
Recurring to-dos seem to work correctly.
Comment 2 Boian Berberov 2018-01-30 00:25:50 UTC
Update for 5.7.1
Comment 3 Erik Quaeghebeur 2018-04-03 11:36:18 UTC
I can confirm this for 5.7.3.
Comment 4 Boian Berberov 2018-04-16 05:36:22 UTC
I'm marking this bug as both a "regression" and "reproducible".  There was a post from KDE encouraging users to triage.
Comment 5 MAG4 2018-04-27 10:07:27 UTC
We also confirm it for 5.7.3 in Debian Testing ...
Comment 6 Joachim Wagner 2018-08-19 11:49:43 UTC
Events seen to work correctly.

It's not just todos feshly created that appear one day early but also todos from an existing iCal calendar folder. Furthermore, if moving a todo item to another day with drag and drop it will also be shown one day early, except if moving it do the day it belongs. Then it covers the full day, hiding other entries of the day.

This is in 5.7.3 on openSUSE Leap 15.0.
Comment 7 Boian Berberov 2019-01-04 22:38:14 UTC
My Korganizer reports 5.10.0.

The highest "Version" I can set here is 5.9.2, so I am updating it to that.

Also changing "Platform" to "unspecified" since there isn't a "multiple" option.
Comment 8 Felix Leif Keppmann 2019-01-28 12:07:44 UTC
I can confirm this issue on Gentoo using KDE Frameworks 5.52.0, KDE Plasma 5.14.5, KDE Apps 18.08.3.

Version 5.9.3 reported by Kontact/Korganizer.

Fresh installation connected to an existing calendar through CalDav provided by a Nextcloud instance.

Full-day todos with due date are shown one day to early if they are not overdue. Overdue todos are shown at the current day.
Comment 9 MAG4 2020-01-16 11:50:09 UTC
We can confirm it for 5.12.3 in Debian Testing ...
Comment 10 gjditchfield 2020-06-18 17:47:33 UTC
Git commit 06b1cede77c8c62c24281935bf404b62f06d1c94 by Glen Ditchfield.
Committed on 18/06/2020 at 16:06.
Pushed by gditchfield into branch 'release/20.04'.

Display all-day to-dos on their due date in the agenda view

The agenda view displays non-recurring all-day to-dos that are not overdue
on the day before their due date.  Recurring to-dos and non-all-day to-dos
are displayed correctly, on their due dates.

`displayIncidence()` deliberately displays to-dos due at midnight in the
event view at the end of the previous day, but that should not be done for
all-day to-dos.  This patch adds an all-day check.

The patch opportunistically removes two `setTime()` calls that duplicate
work done in initializers, and tidies a third.
Related: bug 417982

M  +4    -6    src/agenda/agendaview.cpp

https://invent.kde.org/pim/eventviews/commit/06b1cede77c8c62c24281935bf404b62f06d1c94
Comment 11 Tom 2020-08-16 13:04:49 UTC
*** Bug 425313 has been marked as a duplicate of this bug. ***
Comment 12 MAG4 2020-10-28 10:40:43 UTC
Fixed for 5.15.2 in Debian Testing, thank you Glen!