Bug 384292 - Add possibility to select output device from tray menu
Summary: Add possibility to select output device from tray menu
Status: RESOLVED FIXED
Alias: None
Product: plasma-pa
Classification: Plasma
Component: applet (show other bugs)
Version: 5.10.5
Platform: Archlinux Linux
: NOR wishlist
Target Milestone: ---
Assignee: David Rosca
URL:
Keywords: usability
: 389240 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-09-02 17:50 UTC by Anton Latukha
Modified: 2018-04-05 09:55 UTC (History)
7 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Settings (80.95 KB, image/png)
2017-09-02 17:51 UTC, Anton Latukha
Details
Tray menu (38.13 KB, image/png)
2017-09-02 17:51 UTC, Anton Latukha
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Anton Latukha 2017-09-02 17:50:46 UTC
I think there is a sizeable portion of people that have several soundcards/outpus sinks.

Very often during conversations with people, I need to switch applications from PA to headphones and back. PA is on the separate soundcard, headphones are on studio mic (it is digital mic).
Setting accessible from applet settings.

The tray menu already has a button for dynamic switching of options.
Please, please, for applications, can you add audio devices select there, or the way you see it.

It would be cool, if application tab showed near the name of application gray text what sound sink is used, smaller and aligned left, so user intuitively understands that switch is accessible under that button (explained that in the second picture).


Thank you, David.
Comment 1 Anton Latukha 2017-09-02 17:51:23 UTC
Created attachment 107655 [details]
Settings
Comment 2 Anton Latukha 2017-09-02 17:51:46 UTC
Created attachment 107656 [details]
Tray menu
Comment 3 Christoph Feck 2018-02-20 00:21:26 UTC
*** Bug 389240 has been marked as a duplicate of this bug. ***
Comment 4 Christian (Fuchs) 2018-02-27 21:06:50 UTC
Hi, 

looks like I implemented that by accident, I wasn't aware there was a bug report / feature request for this. 

See https://phabricator.kde.org/D10901, I hope that's according to your likings.
Comment 5 David Rosca 2018-02-28 12:25:37 UTC
Git commit 359ec78cb6ff5d30d2a91e12b5b37c8f6112521d by David Rosca, on behalf of Christian Loosli.
Committed on 28/02/2018 at 12:24.
Pushed by drosca into branch 'master'.

Add "move to device" functionality to hamburger menu

This patch adds the possibility to choose a device for a playback / recording stream in the hamburger menu.
As per the discussion with the developers, the drag & drop functionality stays untouched and is still available.

This is added to be a bit more consistent with the kcm and to make the functionality easier to discover.

The menu is only shown when there are more than one possibilities to choose from in order to not confuse users.

Differential Revision: https://phabricator.kde.org/D10901

M  +31   -0    applet/contents/ui/ListItemBase.qml

https://commits.kde.org/plasma-pa/359ec78cb6ff5d30d2a91e12b5b37c8f6112521d
Comment 6 PiroXiline 2018-03-04 18:10:24 UTC
So cool!

Grateful.