Bug 382086 - Manage bookmarks
Summary: Manage bookmarks
Status: RESOLVED DUPLICATE of bug 300068
Alias: None
Product: krusader
Classification: Applications
Component: general (show other bugs)
Version: 2.4.0-beta3 "Single Step"
Platform: Ubuntu Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Krusader Bugs Distribution List
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-07-07 07:06 UTC by Ebbe Sønderhousen
Modified: 2018-05-06 00:16 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Not working menu entry (31.26 KB, image/png)
2017-07-07 07:06 UTC, Ebbe Sønderhousen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ebbe Sønderhousen 2017-07-07 07:06:16 UTC
Created attachment 106481 [details]
Not working menu entry

KDE 4.14.16
Ubuntu 16.04
Shortcut Ctrl-D (Bookmarks)
When I select "Manage Bookmarks" nothing happens.
In an earlier version, there were no problems.
Comment 1 Alex Bikadorov 2017-07-07 19:50:15 UTC
I'll add keditbookmarks to the INSTALL file.

*** This bug has been marked as a duplicate of bug 300068 ***
Comment 2 Toni Asensi Esteve 2017-07-08 08:09:25 UTC
> add keditbookmarks to the INSTALL file.

If it may be useful, I've gathered some additional information:

Debian has no keditbookmarks package, as it's seen in https://packages.debian.org/keditbookmarks

Ubuntu, Kubuntu, etc. have no keditbookmarks package until the 17.04 ("zesty") version, as it's seen in https://packages.ubuntu.com/keditbookmarks

Using the git version of Krusader under Kubuntu 17.04: if you press Ctrl+D then it works, you can add bookmarks, you can edit them, etc. and the package keditbookmarks is not installed. Notes.
- Executing
    dpkg -l | grep keditbookmarks
answers nothing (so keditbookmarks is not installed).
- Executing
    dpkg -l | grep konqueror
shows that konqueror is not installed:
    ii  kde-telepathy-send-file                         4:16.12.3-0ubuntu1                          amd64        KDE Telepathy dolphin/konqueror integration plugin

In the Konsole window where Krusader is launched, when Ctrl+D is pressed then no message error appears, but then if "Manage Bookmarks" is chosen we can see "keditbookmarks" mentioned in the Konsole window:
    keditbookmarks(4664)/kdeui (kdelibs): Attempt to use QAction "edit_undo" with KXMLGUIFactory!
    keditbookmarks(4664)/kdeui (kdelibs): Attempt to use QAction "edit_redo" with KXMLGUIFactory!
    BookmarkFolderView::bookmarkForIndex QModelIndex(0,0,0x560eb762ac10,BookmarkFolderViewFilterModel(0x560eb7629ac0) )
    BookmarkFolderView::bookmarkForIndex QModelIndex(0,0,0x560eb762ac10,BookmarkFolderViewFilterModel(0x560eb7629ac0) )
    QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No existe el archivo o el directorio
    QFileSystemWatcher: failed to add paths: /home/user/.config/ibus/bus
    Bus::open: Can not get ibus-daemon's address.
    IBusInputContext::createInputContext: no connection to ibus-daemon

Those were the tryings that were made :-). Thanks for Krusader!
Comment 3 Alex Bikadorov 2017-07-08 09:10:19 UTC
keditbookmarks seems to be in another package on Debian. Can you check which package includes /usr/bin/keditbookmarks ?
-> https://www.cyberciti.biz/faq/equivalent-of-rpm-qf-command/
Comment 4 Toni Asensi Esteve 2017-07-08 13:27:28 UTC
Hi!

> keditbookmarks seems to be in another package on Debian. Can you check which package includes /usr/bin/keditbookmarks ?
In Kubuntu 17.04 I executed 
$ type keditbookmarks
keditbookmarks está asociado (/usr/bin/keditbookmarks)
$ which keditbookmarks
/usr/bin/keditbookmarks
$ dpkg -S /usr/bin/keditbookmarks
kde-baseapps-bin: /usr/bin/keditbookmarks

So the package was kde-baseapps-bin
Comment 5 Toni Asensi Esteve 2017-07-08 13:49:25 UTC
Curiously:

When the package "kde-baseapps-bin" is installed in (K)Ubuntu 17.04 AMD64, the file
    /usr/bin/keditbookmarks
is installed (as it can be seen in https://packages.ubuntu.com/zesty/amd64/kde-baseapps-bin/filelist).

If the package "keditbookmarks" is installed in (K)Ubuntu 17.04 AMD64, the file
    /usr/bin/keditbookmarks
is also installed (as it can be seen in https://packages.ubuntu.com/zesty/amd64/keditbookmarks/filelist).
Comment 6 Toni Asensi Esteve 2017-07-08 16:56:28 UTC
Note: To see which files are included in a Debian package we can use, for example:
    https://packages.debian.org/kde-baseapps-bin
and then click on links until arriving for example to:
    https://packages.debian.org/sid/amd64/kde-baseapps-bin/filelist
Comment 7 Ebbe Sønderhousen 2017-07-09 07:49:39 UTC
I understand from the discussion in this thread that keditbookmarks is missing  on my VM-ubuntu.
I searched for "keditbookmarks" on my VM-ubuntu and there was only one hit: /usr/share/local/en_GB/LC_MESSAGES/keditbookmarks.
I'm not well versed in software packages and how to install them.
Can I use "sudo apt-get install keditbookmarks" to solve the problem or ...?
Comment 8 Alex Bikadorov 2017-07-09 09:09:43 UTC
I don't know about Ubuntu here. You either have to install the package "keditbookmarks" or if this is not available the (very old) "kde-baseapps-bin" package as Toni found out.
If you only have Krusader 2.4 available (current version is 2.6) it's probably the latter.

https://launchpad.net/ubuntu/+source/keditbookmarks

Ubuntu's package versions being behind everything else is getting annoying.