Bug 380799 - Konsole remembers window size across launches, but not position
Summary: Konsole remembers window size across launches, but not position
Status: RESOLVED DUPLICATE of bug 15329
Alias: None
Product: konsole
Classification: Applications
Component: general (show other bugs)
Version: 17.04.0
Platform: openSUSE Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-06-04 03:10 UTC by Nate Graham
Modified: 2019-08-28 15:26 UTC (History)
2 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Nate Graham 2017-06-04 03:10:09 UTC
Linux distro: openSUSE Tumbleweed
Plasma version: 5.10
Konsole version: 17.04.1

Steps to reproduce:
1. Open Konsole
2. Move and resize the window
3. Close Konsole
4. Open Konsole again


Expected results:
Upon being re-opened, Konsole should create a window the same size as the previously closed one, and in the same position.


Actual results:
The window size is remembered, but not the location; the new window always spawns at 0,0.


Additional information:
I know that I can set a special rule to force it to remember a certain location (and I do), but this shouldn't be necessary; the position should be remembered by default, automatically.

Also, I read in https://bugs.kde.org/show_bug.cgi?id=100962 Apparently it is the intended behavior that KDE applications remember their size but not position across launches. That was written 12 years ago, so maybe that's no longer the policy? If it, would like to propose a change. Having both size and position be remembered is the way most users expect things to work.
Comment 1 Christoph Feck 2017-06-13 20:18:39 UTC
> the new window always spawns at 0,0.

Even if your KWin settings default to "center"?

The obvious workaround is to use KWin rules to force an initial position.
Comment 2 Christoph Feck 2017-06-13 20:19:27 UTC
Revert accidental status change.
Comment 3 Nate Graham 2017-06-13 20:23:06 UTC
If I choose "Centered", then the window spawns in the center of the screen. But that's not what I want. I want it to spawn in the same location that it was in the last time I closed it. Size is already correctly remembered across launches in this manner, but location isn't.

I am aware of workarounds such as KWin positioning rules. Workarounds are great, but even greater is fixing the bug that requires the workaround! :)
Comment 4 Kishore Gopalakrishnan 2017-06-14 16:53:57 UTC
(In reply to Nate Graham from comment #3)
> If I choose "Centered", then the window spawns in the center of the screen.
> But that's not what I want. I want it to spawn in the same location that it
> was in the last time I closed it. Size is already correctly remembered
> across launches in this manner, but location isn't.
> 
> I am aware of workarounds such as KWin positioning rules. Workarounds are
> great, but even greater is fixing the bug that requires the workaround! :)

There is an option called placement option called 'smart', which if I understand correctly, will do what you want.
Comment 5 Nate Graham 2017-06-15 14:09:20 UTC
"Smart" is the default setting, and the one I'm using. If Smart is supposed to remember window position, then the bug here is that it's not--at least for Konsole.
Comment 6 Nate Graham 2017-08-27 23:48:00 UTC
Not limited to Konsole; this is a limitation of KWin itself, which controls window placement. Marking as a duplicate of https://bugs.kde.org/show_bug.cgi?id=384091

*** This bug has been marked as a duplicate of bug 384091 ***
Comment 7 Nate Graham 2019-08-28 15:26:48 UTC

*** This bug has been marked as a duplicate of bug 15329 ***