Bug 379303 - Cannot send mail from a distribution list
Summary: Cannot send mail from a distribution list
Status: RESOLVED FIXED
Alias: None
Product: kmail2
Classification: Applications
Component: composer (show other bugs)
Version: 5.4.3
Platform: Kubuntu Linux
: NOR grave with 20 votes (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
: 374883 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-04-28 07:31 UTC by Michael Barraclough
Modified: 2017-04-30 06:37 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Barraclough 2017-04-28 07:31:22 UTC
This appears to be the same bug which was reported as RESOLVED FIXED in Bug IDs 223034 and 334583. It is probably the same bug as reported in 374883 bit that refers to KMail 5.2.3 whereas I am referring to KMail 5.4.3 (the latest released version).

Being able to send emails to a Distribution List is a feature which any major email client must have. Please, please, please could this be fixed asap or I fear you will drive me back into the arms of Evolution or push me to Thunderbird.
Comment 1 Christophe Giboudeaux 2017-04-29 08:24:32 UTC
*** Bug 374883 has been marked as a duplicate of this bug. ***
Comment 2 Christophe Giboudeaux 2017-04-29 08:24:37 UTC
How do you create your distribution list ? in kaddressbook ?

Describing all the steps would be helpful.
Comment 3 Christophe Giboudeaux 2017-04-29 08:25:46 UTC
(note: I won't reopen bug 223034. the reporter doesn't want to receive emails about this issue anymore).
Comment 4 Mathieu MD 2017-04-29 09:10:52 UTC
> Describing all the steps would be helpful.

I did this in #223034#c61:

--------------------
With KMail 5.2.3, the list can be created, but email cannot be sent. When clicking on "Send", I get this warning popup:
"The email address you entered is not valid because it does not contain a '.'. You will not create valid messages if you do not change your address."

The distribution list is not expanded, and therefore KMail thinks that the DL name is an actual email address.

Example:
1. Create and populate a DL named "Family, Friends" (from KAddressBook)
2. Use the "Select..." button to add this DL in the "To:" field (from KMail)
3. Click on the "Send" button.

The popup will warn you (the above message) about the email address "Family@mycomputername".
--------------------
Comment 5 Christophe Giboudeaux 2017-04-29 10:40:21 UTC
Well, in recent kaddressbook versions, you can't create groups (I suppose that's what you call 'distribution list') with '.' or '@' in the name.
Comment 6 Michael Barraclough 2017-04-29 21:46:30 UTC
I am doing exactly the same as Mathieu MD describes. 

I do not think that this is a KAddressBook issue or that the restriction of not having an '@' in the group/distribution list name is relevant. KMail2 should be able to recognise that a group has been selected and to enter all the email addresses that belong to the group into the email's recipient list.
Comment 7 Christophe Giboudeaux 2017-04-29 22:15:26 UTC
No issue here. I created a group called 'test' and added a couple email addresses.

Then in KMail, I sent a mail to the 'test' contact and it was sent to all recipients in the group.

Having a @ or a dot in the group name matters. If the mailcomposer encounters one, it considers it is an email address (that's why these two symbols are not allowed anymore)
Comment 8 Michael Barraclough 2017-04-30 06:37:45 UTC
I tested what you said with my existing group and it did not work! So, I created a new test group and it did work!! I also noted that typedown of recipients worked for the new test group so I created a new individual and typedown worked for that individual, but not for all the other 500+ contacts, most of whom had been imported from Evolution, but about 20 of whom were new, created via KMail2.

Next, I exported the existing addressbook to VCARD, deleted the existing address book, created a new addressbook and imported the VCARDS. Now, typedown worked for all the contacts.

However, doing this I lost all the contact TAG information and lost the existing groups. Clearly all is still not working properly. I cannot say whether this is a KMail2 issue or a KAddressBook issue. As an end user I really don't care.