Bug 379300 - Gmail IMAP token/code not saved
Summary: Gmail IMAP token/code not saved
Status: RESOLVED FIXED
Alias: None
Product: Akonadi
Classification: Frameworks and Libraries
Component: Gmail resource (show other bugs)
Version: GIT (master)
Platform: Archlinux Linux
: NOR normal with 20 votes (vote)
Target Milestone: ---
Assignee: Daniel Vrátil
URL:
Keywords:
: 379320 379401 379625 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-04-28 00:41 UTC by tjbp
Modified: 2017-05-16 17:08 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
First pane (29.95 KB, image/png)
2017-04-28 00:41 UTC, tjbp
Details
Second pane (45.39 KB, image/png)
2017-04-28 00:42 UTC, tjbp
Details
Third pane (17.78 KB, image/png)
2017-04-28 00:42 UTC, tjbp
Details
Akonadi GMail problem: image (121.80 KB, image/png)
2017-04-28 21:29 UTC, xaltonon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tjbp 2017-04-28 00:41:56 UTC
Created attachment 105231 [details]
First pane

When adding a Gmail account as an IMAP resource with KMail, it now loads a small browser window to authenticate with Google. After successfully allowing the app permissions, the final pane includes a code that can't be pasted anywhere into KMail.
Comment 1 tjbp 2017-04-28 00:42:26 UTC
Created attachment 105232 [details]
Second pane
Comment 2 tjbp 2017-04-28 00:42:42 UTC
Created attachment 105233 [details]
Third pane
Comment 3 xaltonon 2017-04-28 21:29:06 UTC
Created attachment 105245 [details]
Akonadi GMail problem: image
Comment 4 Alexander White 2017-05-03 02:03:13 UTC
Forgive me if this isn't sufficient, but I'm experiencing the same issue.
Comment 5 Christoph Feck 2017-05-03 22:17:04 UTC
*** Bug 379320 has been marked as a duplicate of this bug. ***
Comment 6 Christoph Feck 2017-05-03 22:17:15 UTC
*** Bug 379401 has been marked as a duplicate of this bug. ***
Comment 7 Daniel Vrátil 2017-05-05 10:09:51 UTC
This has been fixed in libkgapi already: https://cgit.kde.org/libkgapi.git/commit/?id=68b89bce22d0da234345ccffb869ae6863592624
Comment 8 Isaac Salgueiro 2017-05-13 08:56:14 UTC
Works for me with libkpimgapicore5:17.04.1-0neon+16.04+build5
Comment 9 Daniel Vrátil 2017-05-16 17:08:37 UTC
*** Bug 379625 has been marked as a duplicate of this bug. ***