Bug 378385 - Reverse scroll direction, set up with synclient, is not working in Konsole window.
Summary: Reverse scroll direction, set up with synclient, is not working in Konsole wi...
Status: RESOLVED DUPLICATE of bug 355755
Alias: None
Product: konsole
Classification: Unclassified
Component: general (show other bugs)
Version: 16.12.3
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Konsole Developer
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-04-03 00:06 UTC by Mike Krutov
Modified: 2017-04-19 12:39 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mike Krutov 2017-04-03 00:06:32 UTC
This is different bug from https://bugs.kde.org/show_bug.cgi?id=342929 and others I've found in similiar or by keywords.

Summary is, I have a touchpad that is set up via .sh script on every startup of my system.

This touchpad is set up like this:

neko@mars : ~/bin
[0] % grep Scroll touchpad.sh 
synclient VertScrollDelta=-111
synclient HorizScrollDelta=-111



Negative VertScrollDelta property is responsible for reversing the scrolling direction (what is called "Natural Scrolling" in MacOS environment). 

Problem is, this setting is, for some reason, ignored in Konsole. When I scroll in the Konsole window, it always scrolls in unreversed direction, no matter what synclient setting and/or system settings setting do I have.
Comment 1 Mike Krutov 2017-04-03 00:08:58 UTC
Proper steps to reproduce:

1) get a touchpad

2) $synclient VertScrollDelta=-111

3) have a Konsole window with scrollbar

4) Scroll.

A thing to note is that scrolling through shell history is performed in same un-reversed way. Not sure how this feature is called, this happens when scrolling Konsole window is unscrollable (for example, after creating new konsole tab) - instead of doing nothing, one scrolls through his shell's history.
Comment 2 Mike Krutov 2017-04-03 00:29:22 UTC
It turned out that problem persists only for existing Konsole windows, e.g. script with configuration needs to be executed before starting Konsole.
Comment 3 Kurt Hindenburg 2017-04-19 12:39:25 UTC

*** This bug has been marked as a duplicate of bug 355755 ***