Bug 377739 - index.docbook:13: element link: validity error : IDREF attribute linkend references an unknownID "using-mainwindow-mapview"
Summary: index.docbook:13: element link: validity error : IDREF attribute linkend refe...
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Documentation (show other bugs)
Version: 5.5.0
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-17 15:17 UTC by Ritesh Raj Sarraf
Modified: 2020-08-04 11:43 UTC (History)
1 user (show)

See Also:
Latest Commit:
Version Fixed In: 7.1.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ritesh Raj Sarraf 2017-03-17 15:17:31 UTC
Hello Giles,

The 5.5.0 release of Digikam fails to build on Debian. Below is a snippet of the build failure.



[ 37%] Generating showfoto/index.cache.bz2                                            
cd /build/digikam-5.5.0/doc-translated/sv && /usr/bin/meinproc5 --check --cache /build/digikam-5.5.0/obj-x86_64-linux-gnu/doc-translated/sv/showfoto/index.cache.bz2 showfoto/index.docbook
[ 37%] Built target doc-translated-nl-digikam-index-cache-bz2                         
make -f doc-translated/uk/CMakeFiles/doc-translated-uk-digikam-index-cache-bz2.dir/build.make doc-translated/uk/CMakeFiles/doc-translated-uk-digikam-index-cache-bz2.dir/depend
make[3]: Entering directory '/build/digikam-5.5.0/obj-x86_64-linux-gnu'               
cd /build/digikam-5.5.0/obj-x86_64-linux-gnu && /usr/bin/cmake -E cmake_depends "Unix Makefiles" /build/digikam-5.5.0 /build/digikam-5.5.0/doc-translated/uk /build/digikam-5.5.0/obj-x86_64-li
nux-gnu /build/digikam-5.5.0/obj-x86_64-linux-gnu/doc-translated/uk /build/digikam-5.5.0/obj-x86_64-linux-gnu/doc-translated/uk/CMakeFiles/doc-translated-uk-digikam-index-cache-bz2.dir/Depend
Info.cmake --color=                                                                   
Scanning dependencies of target doc-translated-uk-digikam-index-cache-bz2             
make[3]: Leaving directory '/build/digikam-5.5.0/obj-x86_64-linux-gnu'                
make -f doc-translated/uk/CMakeFiles/doc-translated-uk-digikam-index-cache-bz2.dir/build.make doc-translated/uk/CMakeFiles/doc-translated-uk-digikam-index-cache-bz2.dir/build
make[3]: Entering directory '/build/digikam-5.5.0/obj-x86_64-linux-gnu'               
[ 37%] Generating digikam/index.cache.bz2                                             
cd /build/digikam-5.5.0/doc-translated/uk && /usr/bin/meinproc5 --check --cache /build/digikam-5.5.0/obj-x86_64-linux-gnu/doc-translated/uk/digikam/index.cache.bz2 digikam/index.docbook
index.docbook:13: element link: validity error : IDREF attribute linkend references an unknownID "using-mainwindow-mapview"
index.docbook:30: element link: validity error : IDREF attribute linkend references an unknownID "using-mainwindow-mapview"
Error: `xmllint --noout` outputted text                                               
doc-translated/sv/CMakeFiles/doc-translated-sv-showfoto-index-cache-bz2.dir/build.make:64: recipe for target 'doc-translated/sv/showfoto/index.cache.bz2' failed
make[3]: *** [doc-translated/sv/showfoto/index.cache.bz2] Error 1                 
make[3]: Leaving directory '/build/digikam-5.5.0/obj-x86_64-linux-gnu'                
CMakeFiles/Makefile2:15356: recipe for target 'doc-translated/sv/CMakeFiles/doc-translated-sv-showfoto-index-cache-bz2.dir/all' failed
make[2]: *** [doc-translated/sv/CMakeFiles/doc-translated-sv-showfoto-index-cache-bz2.dir/all]Error 2
make[2]: *** Waiting for unfinished jobs....                                          
Generating moc source digikamgui_src_automoc.dir/moc_datefolderview_HH2D2PE4NVIOH4.cpp                           
Generating moc source digikamgui_src_automoc.dir/moc_ddateedit_NT4QK2B5LOB6OM.cpp     
Generating moc source digikamgui_src_automoc.dir/moc_ddatepicker_54PZEAKNOUEXEG.cpp
Generating moc source digikamgui_src_automoc.dir/moc_ddatepicker_p_SSSA7QU66UE2ZW.cpp 
Generating moc source digikamgui_src_automoc.dir/moc_ddatepickerpop_SYOXOOGAO26PLJ.cpp
Generating moc source digikamgui_src_automoc.dir/moc_ddatetable_PW2ART5HUDAF5A.cpp   
Generating moc source digikamgui_src_automoc.dir/moc_ddatetable_p_MTOWJPYWNX3XFZ.cpp
Generating moc source digikamgui_src_automoc.dir/moc_ddatetimeedit_Z5PQWGONVTXQLV.cpp
Comment 1 caulier.gilles 2017-03-17 16:23:52 UTC

*** This bug has been marked as a duplicate of bug 377597 ***
Comment 2 caulier.gilles 2020-08-04 11:43:05 UTC
Fixed with 7.0.0