Bug 377597 - digikam 5.5 fails to build @ docs/sv
Summary: digikam 5.5 fails to build @ docs/sv
Status: RESOLVED FIXED
Alias: None
Product: digikam
Classification: Unclassified
Component: Documentation (show other bugs)
Version: 5.5.0
Platform: Other Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Digikam Developers
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2017-03-14 07:27 UTC by Antonio Rojas
Modified: 2020-08-04 11:42 UTC (History)
5 users (show)

See Also:
Latest Commit:
Version Fixed In: 7.1.0


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Antonio Rojas 2017-03-14 07:27:10 UTC
Building digikam 5.5, xmllint throws errors:

[ 40%] Generating digikam/index.cache.bz2
index.docbook:13: element link: validity error : IDREF attribute linkend references an unknown ID "using-mainwindow-mapview"
index.docbook:30: element link: validity error : IDREF attribute linkend references an unknown ID "using-mainwindow-mapview"
kf5.kdoctools: Error: `xmllint --noout` outputted text
make[2]: *** [doc-translated/sv/CMakeFiles/doc-translated-sv-showfoto-index-cache-bz2.dir/build.make:62: doc-translated/sv/showfoto/index.cache.bz2] Error 1
make[1]: *** [CMakeFiles/Makefile2:15591: doc-translated/sv/CMakeFiles/doc-translated-sv-showfoto-index-cache-bz2.dir/all] Error 2
make[1]: *** Waiting for unfinished jobs....
Comment 1 caulier.gilles 2017-03-14 08:21:12 UTC
Don't try to compile documentation translations for the moment. Only the English handbook compile fine. Use cmake option "-DDIGIKAMSC_COMPILE_DOC=OFF"

Gilles Caulier
Comment 2 Rex Dieter 2017-03-14 13:25:15 UTC
confirming.  other translations included (nl, uk) build/install fine, fwiw.
Comment 3 caulier.gilles 2017-03-14 13:35:32 UTC
well, it's a problem in translated docbook files extracted from svn repository...

But we don't check if docbook translations are fine while releasing. For the moment, handbook still under construction with large update.

Gilles Caulier
Comment 4 Rex Dieter 2017-03-14 13:51:47 UTC
Nevermind the "installs fine" part, similar issue as in the past, where showfoto gets installed as digikam, e.g.

foe example, doc-translated/nl/CMakeLists.txt contains:

KDOCTOOLS_CREATE_HANDBOOK( digikam/index.docbook INSTALL_DESTINATION ${HTML_INSTALL_DIR}/nl/ SUBDIR digikam )
KDOCTOOLS_CREATE_HANDBOOK( showfoto/index.docbook INSTALL_DESTINATION ${HTML_INSTALL_DIR}/nl/ SUBDIR digikam )
Comment 5 caulier.gilles 2017-03-17 16:23:52 UTC
*** Bug 377739 has been marked as a duplicate of this bug. ***
Comment 6 Burkhard Lück 2017-03-18 12:08:01 UTC
building nl, sv and uk digikam docbooks im master from sources works for me and the digikam and showfoto docbooks are properly installed to subdir digikam resp. showfoto
Looks like a tarball issue
Comment 7 Ritesh Raj Sarraf 2017-03-18 18:54:17 UTC
It seems that the 5.5.0 release lost Keyboard Shortcuts too. Can others, who've successfully built, confirm ?

I'm running Digikam under GNOME 3.22
Comment 8 caulier.gilles 2020-08-04 11:42:35 UTC
Fixed with 7.0.0