Bug 377441 - When hovering a file it does not unselect
Summary: When hovering a file it does not unselect
Status: RESOLVED FIXED
Alias: None
Product: plasmashell
Classification: Unclassified
Component: Folder (show other bugs)
Version: 5.8.6
Platform: Other Linux
: NOR normal
Target Milestone: 1.0
Assignee: Eike Hein
URL:
Keywords:
: 377348 377601 377630 377668 377681 377797 377881 (view as bug list)
Depends on:
Blocks:
 
Reported: 2017-03-09 23:24 UTC by Nicolas L.
Modified: 2017-03-24 13:00 UTC (History)
11 users (show)

See Also:
Latest Commit:
Version Fixed In: 5.8.7


Attachments
Snapshot when hovering files (240.92 KB, image/png)
2017-03-09 23:25 UTC, Nicolas L.
Details
icon background stays after click (143.84 KB, image/gif)
2017-03-22 08:51 UTC, Alex
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicolas L. 2017-03-09 23:24:05 UTC
Since Plasma 5.8.6 ( when using folderview ) the file is selected and hovering the second does not unselect the first one.

Tested with Breeze and oxygen themes
Comment 1 Nicolas L. 2017-03-09 23:25:16 UTC
Created attachment 104479 [details]
Snapshot when hovering files
Comment 2 Kai Uwe Broulik 2017-03-10 09:34:57 UTC
Affects 5.9 branch only
Comment 3 Kai Uwe Broulik 2017-03-10 09:35:19 UTC

*** This bug has been marked as a duplicate of bug 377348 ***
Comment 4 David Edmundson 2017-03-10 09:55:32 UTC
Git commit 547a34d346695295ce05499ae355203414412993 by David Edmundson.
Committed on 10/03/2017 at 09:50.
Pushed by davidedmundson into branch 'master'.

Handle applyPrefixes with an empty string

Summary:
When setting an empty QStringList as prefix, it can lead to unexpected results, such as the prefix not changing.

Reviewers: #plasma

Subscribers: plasma-devel, #frameworks

Tags: #plasma, #frameworks

Differential Revision: https://phabricator.kde.org/D5000

M  +7    -1    src/declarativeimports/core/framesvgitem.cpp

https://commits.kde.org/plasma-framework/547a34d346695295ce05499ae355203414412993
Comment 5 Kai Uwe Broulik 2017-03-10 13:41:18 UTC
Git commit b7ce1a4bc1d050ee03837bac77d1a31c3b84c175 by Kai Uwe Broulik.
Committed on 10/03/2017 at 13:40.
Pushed by broulik into branch 'Plasma/5.8'.

[Folder View] Explicitly set prefix as empty in normal state

Somehow with FrameSvg optimizations State no longer manages to reset the property back to its original state when state is reset.
FIXED-IN: 5.8.7

Differential Revision: https://phabricator.kde.org/D4998

M  +2    -0    containments/desktop/package/contents/ui/FolderItemDelegate.qml

https://commits.kde.org/plasma-desktop/b7ce1a4bc1d050ee03837bac77d1a31c3b84c175
Comment 6 Kai Uwe Broulik 2017-03-10 20:58:46 UTC
*** Bug 377348 has been marked as a duplicate of this bug. ***
Comment 7 Nicolas L. 2017-03-12 08:11:38 UTC
i tested and i confirm this is now fixed with this commit.
Comment 8 TOM Harrison 2017-03-15 07:07:44 UTC
*** Bug 377601 has been marked as a duplicate of this bug. ***
Comment 9 Kai Uwe Broulik 2017-03-15 08:28:02 UTC
*** Bug 377630 has been marked as a duplicate of this bug. ***
Comment 10 Kai Uwe Broulik 2017-03-16 10:41:57 UTC
*** Bug 377668 has been marked as a duplicate of this bug. ***
Comment 11 Kai Uwe Broulik 2017-03-17 10:04:21 UTC
*** Bug 377681 has been marked as a duplicate of this bug. ***
Comment 12 simonizor 2017-03-18 16:06:06 UTC
This is not fixed; I am using KDE neon User Edition 5.9 x86_64 with all of the latest updates, and I still experience this exact issue.
Comment 13 Kai Uwe Broulik 2017-03-18 16:54:06 UTC
A version that contains the fix hasn't been released yet. Plasma 5.9.4 is due Tuesday.
Comment 14 me 2017-03-19 09:55:18 UTC
i got an update on fc24 overnight that seems to have fixed the issue.  so my desktop icons are acting normally again.
Comment 15 Kai Uwe Broulik 2017-03-21 12:43:31 UTC
*** Bug 377881 has been marked as a duplicate of this bug. ***
Comment 16 Alex 2017-03-22 08:51:57 UTC
Created attachment 104679 [details]
icon background stays after click

Now mouse over is fixed but background stays after clicking icon. Clicking on empty desktop space clears selection. I'm not sure if it's intentional or bug.
Comment 17 David Fernández 2017-03-23 08:54:22 UTC
System updated yesterday, not fixed yet.
___________________________________________________________________________
$ cat /etc/*release
DISTRIB_ID=neon
DISTRIB_RELEASE=16.04
DISTRIB_CODENAME=xenial
DISTRIB_DESCRIPTION="KDE neon LTS User Edition 5.8"
NAME="KDE neon LTS"
VERSION="5.8"
ID=neon
ID_LIKE="ubuntu debian"
PRETTY_NAME="KDE neon LTS User Edition 5.8"
VERSION_ID="16.04"
HOME_URL="http://neon.kde.org/"
SUPPORT_URL="http://neon.kde.org/"
BUG_REPORT_URL="http://bugs.kde.org/"
VERSION_CODENAME=xenial
UBUNTU_CODENAME=xenial
Comment 18 Kai Uwe Broulik 2017-03-23 09:07:35 UTC
For KDE Neon LTS you need to wait for either Plasma 5.8.7 or next Frameworks release, sorry.
Comment 19 Nicolas L. 2017-03-23 12:54:44 UTC
or do this change yourself 

https://cgit.kde.org/plasma-desktop.git/commit/?id=b7ce1a4bc1d050ee03837bac77d1a31c3b84c175

you will see it fixes the issue
Comment 20 David Fernández 2017-03-23 15:43:42 UTC
Thanx a lot, Kal & Nicolas L.
Comment 21 David Fernández 2017-03-23 15:44:44 UTC
(In reply to Nicolas L. from comment #19)
> or do this change yourself 
> 
> https://cgit.kde.org/plasma-desktop.git/commit/
> ?id=b7ce1a4bc1d050ee03837bac77d1a31c3b84c175
> 
> you will see it fixes the issue

Nicolas L.: I have applied the changes to the specified file and it works correctly again.

Thank you for the information.

Regards.
Comment 22 Kai Uwe Broulik 2017-03-24 13:00:40 UTC
*** Bug 377797 has been marked as a duplicate of this bug. ***