Bug 376837 - Konqueror crash after trying to access any website
Summary: Konqueror crash after trying to access any website
Status: RESOLVED WORKSFORME
Alias: None
Product: konqueror
Classification: Applications
Component: general (show other bugs)
Version: 5.0.97
Platform: Ubuntu Linux
: NOR crash (vote)
Target Milestone: ---
Assignee: Konqueror Developers
URL:
Keywords: drkonqi
Depends on:
Blocks:
 
Reported: 2017-02-23 10:14 UTC by Petru Szemereczki
Modified: 2021-01-16 04:35 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petru Szemereczki 2017-02-23 10:14:46 UTC
Application: konqueror (5.0.97)

Qt Version: 5.7.1
Frameworks Version: 5.31.0
Operating System: Linux 4.4.0-64-generic x86_64
Distribution: KDE neon User Edition 5.9

-- Information about the crash:
- What I was doing when the application crashed:
I tried to access a web page (gmail) and it crashed suddenly. I tried again, and it crashed again. I tried with a reboot, but it didn't work.

- Custom settings of the application:
I have installed KGet, which haves integration in Konqueror, but the extension is not shown in Konqueror.

The crash can be reproduced every time.

-- Backtrace:
Application: Konqueror (konqueror), signal: Aborted
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[Current thread is 1 (Thread 0x7f50f7f87900 (LWP 3038))]

Thread 6 (Thread 0x7f50dadbf700 (LWP 3054)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:225
#1  0x00007f5104739936 in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#2  0x00007f51047351ea in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#3  0x00007f5104738b48 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f51005e26ba in start_thread (arg=0x7f50dadbf700) at pthread_create.c:333
#5  0x00007f510930e82d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 5 (Thread 0x7f50db5c0700 (LWP 3053)):
#0  0x00007f50fe5058fb in g_main_context_prepare () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1  0x00007f50fe5062bb in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f50fe50649c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f510495975b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f51049040ba in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f5104733f64 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f5107c18377 in ?? () from /usr/lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#7  0x00007f5104738b48 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f51005e26ba in start_thread (arg=0x7f50db5c0700) at pthread_create.c:333
#9  0x00007f510930e82d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 4 (Thread 0x7f50ec85a700 (LWP 3042)):
#0  0x00007f5109302b5d in poll () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007f50fe50638c in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2  0x00007f50fe50649c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3  0x00007f510495975b in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#4  0x00007f51049040ba in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f5104733f64 in QThread::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#6  0x00007f5109a63735 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5DBus.so.5
#7  0x00007f5104738b48 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#8  0x00007f51005e26ba in start_thread (arg=0x7f50ec85a700) at pthread_create.c:333
#9  0x00007f510930e82d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 3 (Thread 0x7f50ed8ae700 (LWP 3041)):
#0  pthread_cond_timedwait@@GLIBC_2.3.2 () at ../sysdeps/unix/sysv/linux/x86_64/pthread_cond_timedwait.S:225
#1  0x00007f50ef95ce44 in ?? () from /usr/lib/nvidia-378/libGLX_nvidia.so.0
#2  0x00007f50ee67a394 in ?? () from /usr/lib/nvidia-378/libnvidia-glcore.so.378.13
#3  0x00007f50ef95c12c in ?? () from /usr/lib/nvidia-378/libGLX_nvidia.so.0
#4  0x00007f51005e26ba in start_thread (arg=0x7f50ed8ae700) at pthread_create.c:333
#5  0x00007f510930e82d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 2 (Thread 0x7f50f5659700 (LWP 3039)):
#0  0x00007f5109302b5d in poll () at ../sysdeps/unix/syscall-template.S:84
#1  0x00007f50fff60c62 in ?? () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#2  0x00007f50fff628d7 in xcb_wait_for_event () from /usr/lib/x86_64-linux-gnu/libxcb.so.1
#3  0x00007f50f7bbcd79 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5XcbQpa.so.5
#4  0x00007f5104738b48 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#5  0x00007f51005e26ba in start_thread (arg=0x7f50f5659700) at pthread_create.c:333
#6  0x00007f510930e82d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:109

Thread 1 (Thread 0x7f50f7f87900 (LWP 3038)):
[KCrash Handler]
#6  0x00007f510923d428 in __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:54
#7  0x00007f510923f02a in __GI_abort () at abort.c:89
#8  0x00007f510471f811 in QMessageLogger::fatal(char const*, ...) const () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#9  0x00007f50c768bea6 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5WebEngineCore.so.5
#10 0x00007f50c768741d in ?? () from /usr/lib/x86_64-linux-gnu/libQt5WebEngineCore.so.5
#11 0x00007f50c7688fa5 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5WebEngineCore.so.5
#12 0x00007f50c767969e in ?? () from /usr/lib/x86_64-linux-gnu/libQt5WebEngineCore.so.5
#13 0x00007f50c767c54e in QtWebEngineCore::WebContentsAdapter::WebContentsAdapter(content::WebContents*) () from /usr/lib/x86_64-linux-gnu/libQt5WebEngineCore.so.5
#14 0x00007f50d965dfb1 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5WebEngineWidgets.so.5
#15 0x00007f50d965eb84 in QWebEnginePage::QWebEnginePage(QObject*) () from /usr/lib/x86_64-linux-gnu/libQt5WebEngineWidgets.so.5
#16 0x00007f50d96aedd2 in ?? () from /usr/lib/x86_64-linux-gnu/libkwebenginepartlib.so
#17 0x00007f50d96a7e42 in ?? () from /usr/lib/x86_64-linux-gnu/libkwebenginepartlib.so
#18 0x00007f50d969c3b9 in WebEnginePart::WebEnginePart(QWidget*, QObject*, QByteArray const&, QStringList const&) () from /usr/lib/x86_64-linux-gnu/libkwebenginepartlib.so
#19 0x00007f50d98dcc6e in ?? () from /usr/lib/x86_64-linux-gnu/qt5/plugins/kf5/parts/webenginepart.so
#20 0x00007f510965019f in ?? () from /usr/lib/x86_64-linux-gnu/libkdeinit5_konqueror.so
#21 0x00007f510963bb67 in KonqFrame::attach(KonqViewFactory const&) () from /usr/lib/x86_64-linux-gnu/libkdeinit5_konqueror.so
#22 0x00007f51096277fc in KonqView::switchView(KonqViewFactory&) () from /usr/lib/x86_64-linux-gnu/libkdeinit5_konqueror.so
#23 0x00007f51096289c2 in KonqView::changePart(QString const&, QString const&, bool) () from /usr/lib/x86_64-linux-gnu/libkdeinit5_konqueror.so
#24 0x00007f5109670964 in KonqMainWindow::openView(QString, QUrl const&, KonqView*, KonqOpenURLRequest const&) () from /usr/lib/x86_64-linux-gnu/libkdeinit5_konqueror.so
#25 0x00007f5109624173 in ?? () from /usr/lib/x86_64-linux-gnu/libkdeinit5_konqueror.so
#26 0x00007f5109624c64 in ?? () from /usr/lib/x86_64-linux-gnu/libkdeinit5_konqueror.so
#27 0x00007f5107f54172 in KRun::mimeTypeDetermined(QString const&) () from /usr/lib/x86_64-linux-gnu/libKF5KIOWidgets.so.5
#28 0x00007f51084e4628 in KParts::BrowserRun::slotBrowserMimetype(KIO::Job*, QString const&) () from /usr/lib/x86_64-linux-gnu/libKF5Parts.so.5
#29 0x00007f51049311f6 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#30 0x00007f5107bf5fc7 in KIO::TransferJob::mimetype(KIO::Job*, QString const&) () from /usr/lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#31 0x00007f5107bf60ef in KIO::TransferJob::slotMimetype(QString const&) () from /usr/lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#32 0x00007f5107bf76ed in ?? () from /usr/lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#33 0x00007f5104930e89 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#34 0x00007f5107bc5355 in KIO::SlaveInterface::mimeType(QString const&) () from /usr/lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#35 0x00007f5107bc694b in KIO::SlaveInterface::dispatch(int, QByteArray const&) () from /usr/lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#36 0x00007f5107bc54a7 in KIO::SlaveInterface::dispatch() () from /usr/lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#37 0x00007f5107bca731 in KIO::Slave::gotInput() () from /usr/lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#38 0x00007f5107c578e5 in ?? () from /usr/lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#39 0x00007f5104930e89 in QMetaObject::activate(QObject*, int, int, void**) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#40 0x00007f5107b66f20 in ?? () from /usr/lib/x86_64-linux-gnu/libKF5KIOCore.so.5
#41 0x00007f5104931d99 in QObject::event(QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#42 0x00007f5105434ecc in QApplicationPrivate::notify_helper(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#43 0x00007f510543c8c6 in QApplication::notify(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Widgets.so.5
#44 0x00007f51049060c8 in QCoreApplication::notifyInternal2(QObject*, QEvent*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#45 0x00007f510490878b in QCoreApplicationPrivate::sendPostedEvents(QObject*, int, QThreadData*) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#46 0x00007f5104959333 in ?? () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#47 0x00007f50fe506197 in g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#48 0x00007f50fe5063f0 in ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#49 0x00007f50fe50649c in g_main_context_iteration () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
#50 0x00007f510495973f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#51 0x00007f51049040ba in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#52 0x00007f510490c6cc in QCoreApplication::exec() () from /usr/lib/x86_64-linux-gnu/libQt5Core.so.5
#53 0x00007f510969fee0 in kdemain () from /usr/lib/x86_64-linux-gnu/libkdeinit5_konqueror.so
#54 0x00007f5109228830 in __libc_start_main (main=0x4006e0, argc=1, argv=0x7ffd20819d08, init=<optimized out>, fini=<optimized out>, rtld_fini=<optimized out>, stack_end=0x7ffd20819cf8) at ../csu/libc-start.c:291
#55 0x0000000000400719 in _start ()

Possible duplicates by query: bug 375284, bug 366235, bug 364721, bug 364342, bug 364090.

Reported using DrKonqi
Comment 1 Justin Zobel 2020-12-17 05:27:01 UTC
Thank you for the crash report.

As it has been a while since this was reported, can you please test and confirm if this issue is still occurring or if this bug report can be marked as resolved.

I have set the bug status to "needsinfo" pending your response, please change back to "reported" or "resolved/worksforme" when you respond, thank you.
Comment 2 Bug Janitor Service 2021-01-01 04:36:23 UTC
Dear Bug Submitter,

This bug has been in NEEDSINFO status with no change for at least
15 days. Please provide the requested information as soon as
possible and set the bug status as REPORTED. Due to regular bug
tracker maintenance, if the bug is still in NEEDSINFO status with
no change in 30 days the bug will be closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

If you have already provided the requested information, please
mark the bug as REPORTED so that the KDE team knows that the bug is
ready to be confirmed.

Thank you for helping us make KDE software even better for everyone!
Comment 3 Bug Janitor Service 2021-01-16 04:35:26 UTC
This bug has been in NEEDSINFO status with no change for at least
30 days. The bug is now closed as RESOLVED > WORKSFORME
due to lack of needed information.

For more information about our bug triaging procedures please read the
wiki located here:
https://community.kde.org/Guidelines_and_HOWTOs/Bug_triaging

Thank you for helping us make KDE software even better for everyone!