Bug 373628 - systemsettings5 crashes when closing or going back
Summary: systemsettings5 crashes when closing or going back
Status: RESOLVED FIXED
Alias: None
Product: systemsettings
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Platform: Debian testing Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: Unassigned bugs mailing-list
URL:
Keywords:
: 344942 373160 374042 374475 374489 374534 374556 374648 374675 374742 374837 374851 374885 374893 374941 374982 374999 375032 375039 375041 375063 375178 375182 375203 375261 375434 375435 375470 375475 375476 375486 375576 375620 375629 375636 375688 375768 375777 375788 375832 375841 375891 375899 375903 375920 375925 375935 375942 375955 376004 376012 376042 376078 376135 376151 376152 376166 376171 376323 376358 376392 376410 376414 376442 376458 376475 376492 376524 376532 376535 376603 376924 376960 376971 377077 377851 378067 378830 451905 (view as bug list)
Depends on:
Blocks:
 
Reported: 2016-12-13 23:51 UTC by Bernhard Übelacker
Modified: 2022-03-26 16:25 UTC (History)
85 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
Debugging session. (61.61 KB, text/plain)
2016-12-13 23:51 UTC, Bernhard Übelacker
Details
Minimal testcase (7.09 KB, application/download)
2016-12-19 15:22 UTC, Bernhard Übelacker
Details
Colors crash backtrace (7.00 KB, text/plain)
2017-02-11 08:28 UTC, Tony
Details
added systemsettings5-20170211-163357.kcrash.txt (16.34 KB, text/plain)
2017-02-12 15:45 UTC, André Verwijs
Details
attachment-18114-0.html (996 bytes, text/html)
2017-02-20 11:10 UTC, André Verwijs
Details
New crash information added by DrKonqi (11.38 KB, text/plain)
2018-02-09 18:14 UTC, flatron
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bernhard Übelacker 2016-12-13 23:51:47 UTC
Created attachment 102773 [details]
Debugging session.

On my Debian testing desktop I noticed a crash when browsing in
systemsettings to the lock screen configuration and trying to go
back or closing the application.

Please see attached file at the end for backtrace of the crash.

After "some time" looking into it I believe that the crash occours
because of the following events:

- ScreenLockerKcmForm constructor calls QQmlContext::setContextProperty
  (configDialog). That way a pointer to ScreenLockerKcmForm get stored as
  some Qml/QV4 objects (QObjectWrapper).

- ScreenLockerKcmForm destructor is called.
- The inherited QWidget destructor is called.
- The QObjectPrivate member declarativeData is set to 0 (qwidget.cpp:1679)
- QObjectPrivate::deleteChildren is called.

- The QObjectPrivate member currentChildBeingDeleted is set to the next one
  to be deleted. (qobject.cpp:1968)

  Unfortunately is declarativeData and currentChildBeingDeleted sharing
  the same memory - therefore declarativeData is now not 0 anymore.
  (qobject_p.h:236)

- One of the childs tries to clean up the Qml/QV4 magic.

- Now in QObjectWrapper::destroyObject a QQmlData pointer is retrieved.
  That way the QObject pointer currentChildBeingDeleted is now retrieved via
  declarativeData as a QQmlData pointer.


Can someone at least reproduce the crash?
Is there something I should include in another debugging session?

I think this also is somehow related to the crash filed in bug #361236.
At least it ends in the same QV4::Value::as member (qv4value_p.h:351).


Kind regards,
Bernhard
Comment 1 Bernhard Übelacker 2016-12-19 15:22:49 UTC
Created attachment 102875 [details]
Minimal testcase

This test creates a main window with a single QQuickWidget.
Via setContextProperty the pointer to the MainWindow instance is stored.
If at Qml side a property of this instance is accessed we get this
crash in the destructor.
(An exmple gdb run on my machine is included.)
Comment 2 Martin Flöser 2016-12-19 16:54:10 UTC
please provide that test case to the Qt developers through their bugtracker. Here it won't help.
Comment 3 Bernhard Übelacker 2016-12-19 17:50:34 UTC
Thank you for the feedback.
I created https://bugreports.qt.io/browse/QTBUG-57714.
Comment 4 Martin Flöser 2016-12-19 20:53:59 UTC
Thanks for forwarding!
Comment 5 Christoph Feck 2017-01-04 13:10:38 UTC
Bug accepted upstream.
Comment 6 Christoph Feck 2017-01-04 13:13:17 UTC
*** Bug 344942 has been marked as a duplicate of this bug. ***
Comment 7 Christoph Feck 2017-01-10 18:39:42 UTC
*** Bug 374475 has been marked as a duplicate of this bug. ***
Comment 8 Christoph Feck 2017-01-10 18:39:58 UTC
*** Bug 374489 has been marked as a duplicate of this bug. ***
Comment 9 Christoph Feck 2017-01-10 18:40:23 UTC
*** Bug 374534 has been marked as a duplicate of this bug. ***
Comment 10 Christoph Feck 2017-01-10 18:40:48 UTC
*** Bug 374556 has been marked as a duplicate of this bug. ***
Comment 11 Christoph Feck 2017-01-10 18:41:11 UTC
*** Bug 374648 has been marked as a duplicate of this bug. ***
Comment 12 Christoph Feck 2017-01-10 18:41:27 UTC
*** Bug 374675 has been marked as a duplicate of this bug. ***
Comment 13 Christoph Feck 2017-01-10 18:41:45 UTC
*** Bug 374837 has been marked as a duplicate of this bug. ***
Comment 14 Christoph Feck 2017-01-10 18:55:26 UTC
*** Bug 374742 has been marked as a duplicate of this bug. ***
Comment 15 Christoph Feck 2017-01-19 14:28:04 UTC
*** Bug 375261 has been marked as a duplicate of this bug. ***
Comment 16 Christoph Feck 2017-01-19 14:28:46 UTC
*** Bug 374982 has been marked as a duplicate of this bug. ***
Comment 17 Christoph Feck 2017-01-19 14:28:59 UTC
*** Bug 374999 has been marked as a duplicate of this bug. ***
Comment 18 Christoph Feck 2017-01-19 14:29:13 UTC
*** Bug 375032 has been marked as a duplicate of this bug. ***
Comment 19 Christoph Feck 2017-01-19 14:29:27 UTC
*** Bug 375039 has been marked as a duplicate of this bug. ***
Comment 20 Christoph Feck 2017-01-19 14:29:41 UTC
*** Bug 375041 has been marked as a duplicate of this bug. ***
Comment 21 Christoph Feck 2017-01-19 14:29:56 UTC
*** Bug 375063 has been marked as a duplicate of this bug. ***
Comment 22 Christoph Feck 2017-01-19 14:30:14 UTC
*** Bug 375178 has been marked as a duplicate of this bug. ***
Comment 23 Christoph Feck 2017-01-19 14:30:29 UTC
*** Bug 375182 has been marked as a duplicate of this bug. ***
Comment 24 Christoph Feck 2017-01-19 14:30:44 UTC
*** Bug 375203 has been marked as a duplicate of this bug. ***
Comment 25 Christoph Feck 2017-01-25 16:46:21 UTC
*** Bug 375434 has been marked as a duplicate of this bug. ***
Comment 26 Christoph Feck 2017-01-25 16:46:33 UTC
*** Bug 375435 has been marked as a duplicate of this bug. ***
Comment 27 Christoph Feck 2017-01-25 16:46:44 UTC
*** Bug 375470 has been marked as a duplicate of this bug. ***
Comment 28 Christoph Feck 2017-01-25 16:46:56 UTC
*** Bug 375475 has been marked as a duplicate of this bug. ***
Comment 29 Christoph Feck 2017-01-25 16:47:07 UTC
*** Bug 375476 has been marked as a duplicate of this bug. ***
Comment 30 Christoph Feck 2017-01-25 16:47:20 UTC
*** Bug 375486 has been marked as a duplicate of this bug. ***
Comment 31 Christoph Feck 2017-02-01 23:02:15 UTC
*** Bug 374885 has been marked as a duplicate of this bug. ***
Comment 32 Christoph Feck 2017-02-01 23:02:32 UTC
*** Bug 375576 has been marked as a duplicate of this bug. ***
Comment 33 Christoph Feck 2017-02-01 23:02:49 UTC
*** Bug 375620 has been marked as a duplicate of this bug. ***
Comment 34 Christoph Feck 2017-02-01 23:03:00 UTC
*** Bug 375636 has been marked as a duplicate of this bug. ***
Comment 35 Christoph Feck 2017-02-01 23:03:11 UTC
*** Bug 375688 has been marked as a duplicate of this bug. ***
Comment 36 Christoph Feck 2017-02-01 23:03:24 UTC
*** Bug 375768 has been marked as a duplicate of this bug. ***
Comment 37 Christoph Feck 2017-02-01 23:03:36 UTC
*** Bug 375777 has been marked as a duplicate of this bug. ***
Comment 38 Christoph Feck 2017-02-01 23:03:48 UTC
*** Bug 375788 has been marked as a duplicate of this bug. ***
Comment 39 Christoph Feck 2017-02-01 23:03:55 UTC
*** Bug 375832 has been marked as a duplicate of this bug. ***
Comment 40 ttv200 2017-02-07 07:49:30 UTC
*** Bug 376042 has been marked as a duplicate of this bug. ***
Comment 41 ttv200 2017-02-07 07:49:58 UTC
*** Bug 376078 has been marked as a duplicate of this bug. ***
Comment 42 ttv200 2017-02-07 07:51:03 UTC
*** Bug 376012 has been marked as a duplicate of this bug. ***
Comment 43 ttv200 2017-02-07 07:51:53 UTC
*** Bug 375935 has been marked as a duplicate of this bug. ***
Comment 44 ttv200 2017-02-07 07:52:01 UTC
*** Bug 375955 has been marked as a duplicate of this bug. ***
Comment 45 ttv200 2017-02-07 07:52:32 UTC
*** Bug 375899 has been marked as a duplicate of this bug. ***
Comment 46 ttv200 2017-02-07 07:54:20 UTC
*** Bug 376004 has been marked as a duplicate of this bug. ***
Comment 47 ttv200 2017-02-07 07:55:40 UTC
*** Bug 375942 has been marked as a duplicate of this bug. ***
Comment 48 ttv200 2017-02-07 07:57:08 UTC
*** Bug 375925 has been marked as a duplicate of this bug. ***
Comment 49 ttv200 2017-02-07 07:57:54 UTC
*** Bug 375920 has been marked as a duplicate of this bug. ***
Comment 50 ttv200 2017-02-07 07:57:59 UTC
*** Bug 375903 has been marked as a duplicate of this bug. ***
Comment 51 ttv200 2017-02-07 07:58:10 UTC
*** Bug 375891 has been marked as a duplicate of this bug. ***
Comment 52 ttv200 2017-02-07 07:58:54 UTC
*** Bug 375841 has been marked as a duplicate of this bug. ***
Comment 53 ttv200 2017-02-07 11:04:26 UTC
*** Bug 373160 has been marked as a duplicate of this bug. ***
Comment 54 Christoph Feck 2017-02-07 20:09:28 UTC
*** Bug 374893 has been marked as a duplicate of this bug. ***
Comment 55 Kai Uwe Broulik 2017-02-09 16:59:07 UTC
*** Bug 376166 has been marked as a duplicate of this bug. ***
Comment 56 Kai Uwe Broulik 2017-02-09 16:59:30 UTC
*** Bug 376171 has been marked as a duplicate of this bug. ***
Comment 57 Kai Uwe Broulik 2017-02-09 16:59:36 UTC
*** Bug 376135 has been marked as a duplicate of this bug. ***
Comment 58 Kai Uwe Broulik 2017-02-09 16:59:41 UTC
*** Bug 376152 has been marked as a duplicate of this bug. ***
Comment 59 David Edmundson 2017-02-09 17:39:30 UTC
We now have a workaround that we can do for Plasma 5.9.2. 

Unfortunately we need to do it for every single module that crashes.

It seems that whilst the only KCMs that crash are all QML KCMs, it's not the case that all QML KCMs crash.

Currently I know of KWin decoration and screen locker.

Can people please list any other module that may need fixing, and I'll try and write a patch.

1) part 1 https://phabricator.kde.org/D4533
Comment 60 Christoph Feck 2017-02-10 01:18:01 UTC
*** Bug 376151 has been marked as a duplicate of this bug. ***
Comment 61 David Edmundson 2017-02-10 09:55:25 UTC
Git commit 29179f115c81ff7128bb5430cb27ef7b65f46b33 by David Edmundson.
Committed on 10/02/2017 at 09:52.
Pushed by davidedmundson into branch 'Plasma/5.9'.

Avoid a crash on Kwin decoration KCM teardown

Summary:
As described in https://bugreports.qt.io/browse/QTBUG-57714  exposing a
QWidget as a context item to QtQuick can crash. Especially as the
engine's context property gets deleted whilst deleting the parent item.

This patch reworks the code so that the models are exposed to QML
directly rather than going through a QWidget.

Test Plan:
Pressing back whilst in the decoration KCM used to crash every time, now it doesn't.
I still have the buttons.

Reviewers: #plasma, graesslin

Reviewed By: #plasma, graesslin

Subscribers: graesslin, cfeck, plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D4533

M  +4    -16   kcmkwin/kwindecoration/kcm.cpp
M  +0    -7    kcmkwin/kwindecoration/kcm.h
M  +3    -3    kcmkwin/kwindecoration/qml/Buttons.qml

https://commits.kde.org/kwin/29179f115c81ff7128bb5430cb27ef7b65f46b33
Comment 62 David Edmundson 2017-02-10 10:01:09 UTC
Git commit 51c4d6c8db8298dbd471fa91de6cb97bf8b4287a by David Edmundson.
Committed on 10/02/2017 at 10:00.
Pushed by davidedmundson into branch 'Plasma/5.9'.

Fix crash in Screen Locker KCM on teardown

Summary:
As described in https://bugreports.qt.io/browse/QTBUG-57714  exposing a
QWidget as a context item to QtQuick can crash. Especially as the
engine's context property gets deleted whilst deleting the parent item.

This patch reworks the code so that exposed properties go through a
proxy QObject.

Test Plan:
Pressing back whilst in the screenlocker KCM used to crash every time,
now it doesn't.

Also changed the wallpaper type, new settings appeared, I went from flat
image to a specific wallpaper, and then locked my screen.

Reviewers: #plasma, graesslin

Reviewed By: #plasma, graesslin

Subscribers: plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D4535

M  +6    -1    kcm/kcm.cpp
M  +30   -3    kcm/kcm.h

https://commits.kde.org/kscreenlocker/51c4d6c8db8298dbd471fa91de6cb97bf8b4287a
Comment 63 David Edmundson 2017-02-10 12:59:38 UTC
Git commit 2601fa10725284feb5bcc78006250c0aa92f92dd by David Edmundson.
Committed on 10/02/2017 at 12:59.
Pushed by davidedmundson into branch 'Plasma/5.8'.

Fix crash in Screen Locker KCM on teardown

Summary:
As described in https://bugreports.qt.io/browse/QTBUG-57714  exposing a
QWidget as a context item to QtQuick can crash. Especially as the
engine's context property gets deleted whilst deleting the parent item.

This patch reworks the code so that exposed properties go through a
proxy QObject.

Test Plan:
Pressing back whilst in the screenlocker KCM used to crash every time,
now it doesn't.

Also changed the wallpaper type, new settings appeared, I went from flat
image to a specific wallpaper, and then locked my screen.

Reviewers: #plasma, graesslin

Reviewed By: #plasma, graesslin

Subscribers: plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D4535

M  +6    -1    kcm/kcm.cpp
M  +30   -3    kcm/kcm.h

https://commits.kde.org/kscreenlocker/2601fa10725284feb5bcc78006250c0aa92f92dd
Comment 64 David Edmundson 2017-02-10 13:01:17 UTC
Git commit 70d2fb2378d636ef6d052da08417b27c99182fb0 by David Edmundson.
Committed on 10/02/2017 at 13:01.
Pushed by davidedmundson into branch 'Plasma/5.8'.

Avoid a crash on Kwin decoration KCM teardown

Summary:
As described in https://bugreports.qt.io/browse/QTBUG-57714  exposing a
QWidget as a context item to QtQuick can crash. Especially as the
engine's context property gets deleted whilst deleting the parent item.

This patch reworks the code so that the models are exposed to QML
directly rather than going through a QWidget.

Test Plan:
Pressing back whilst in the decoration KCM used to crash every time, now it doesn't.
I still have the buttons.

Reviewers: #plasma, graesslin

Reviewed By: #plasma, graesslin

Subscribers: graesslin, cfeck, plasma-devel

Tags: #plasma

Differential Revision: https://phabricator.kde.org/D4533

M  +4    -16   kcmkwin/kwindecoration/kcm.cpp
M  +0    -7    kcmkwin/kwindecoration/kcm.h
M  +3    -3    kcmkwin/kwindecoration/qml/Buttons.qml

https://commits.kde.org/kwin/70d2fb2378d636ef6d052da08417b27c99182fb0
Comment 65 Tony 2017-02-11 08:28:28 UTC
Created attachment 103970 [details]
Colors crash backtrace

Add "Colors" to the list.
Comment 66 Kai Uwe Broulik 2017-02-11 09:20:55 UTC
@Tony: Thanks, you seem to be running a very recent git snapshot, right? I did a fix for KHintsSettings (in plasma integration) so changing the color scheme at runtime would properly repainting QML parts.

This exposed a bug in KCModuleQml which would unconditionally update the colors even though the QML container window was already gone. I bet you had a QML-based KCM opened (most likely the Desktop Effects one) before you changed the colors? This is fixed in kcmutils: https://cgit.kde.org/kcmutils.git/commit/
Comment 67 Bernhard Übelacker 2017-02-11 10:19:28 UTC
Just as a information.
Attached to the upstream bug QTBUG-57714 is a patch against
qtdeclarative-opensource-src-5.7.1 to attempt to fix the problem there.
In my short tests it worked as expected.
Comment 68 ttv200 2017-02-12 15:31:22 UTC
*** Bug 376392 has been marked as a duplicate of this bug. ***
Comment 69 ttv200 2017-02-12 15:31:31 UTC
*** Bug 376358 has been marked as a duplicate of this bug. ***
Comment 70 ttv200 2017-02-12 15:32:01 UTC
*** Bug 376323 has been marked as a duplicate of this bug. ***
Comment 71 ttv200 2017-02-12 15:32:18 UTC
*** Bug 376208 has been marked as a duplicate of this bug. ***
Comment 72 ttv200 2017-02-12 15:32:53 UTC
*** Bug 375629 has been marked as a duplicate of this bug. ***
Comment 73 ttv200 2017-02-12 15:33:00 UTC
*** Bug 374941 has been marked as a duplicate of this bug. ***
Comment 74 ttv200 2017-02-12 15:34:05 UTC
*** Bug 374851 has been marked as a duplicate of this bug. ***
Comment 75 ttv200 2017-02-12 15:34:49 UTC
*** Bug 374042 has been marked as a duplicate of this bug. ***
Comment 76 André Verwijs 2017-02-12 15:43:56 UTC
have the same with TW 2017.02.11
Comment 77 André Verwijs 2017-02-12 15:45:42 UTC
Created attachment 104005 [details]
added systemsettings5-20170211-163357.kcrash.txt

hope this helps..
Comment 78 tempel.julian 2017-02-12 16:20:01 UTC
(In reply to André Verwijs from comment #76)
> have the same with TW 2017.02.11

Me too.
Comment 79 Kai Uwe Broulik 2017-02-14 15:30:18 UTC
*** Bug 376475 has been marked as a duplicate of this bug. ***
Comment 80 Christoph Feck 2017-02-17 02:20:52 UTC
*** Bug 376410 has been marked as a duplicate of this bug. ***
Comment 81 Christoph Feck 2017-02-17 02:21:00 UTC
*** Bug 376414 has been marked as a duplicate of this bug. ***
Comment 82 Christoph Feck 2017-02-17 02:21:09 UTC
*** Bug 376442 has been marked as a duplicate of this bug. ***
Comment 83 Christoph Feck 2017-02-17 02:21:17 UTC
*** Bug 376458 has been marked as a duplicate of this bug. ***
Comment 84 Christoph Feck 2017-02-17 02:21:26 UTC
*** Bug 376492 has been marked as a duplicate of this bug. ***
Comment 85 Christoph Feck 2017-02-17 02:21:36 UTC
*** Bug 376524 has been marked as a duplicate of this bug. ***
Comment 86 Christoph Feck 2017-02-17 02:21:44 UTC
*** Bug 376532 has been marked as a duplicate of this bug. ***
Comment 87 Christoph Feck 2017-02-17 02:21:53 UTC
*** Bug 376535 has been marked as a duplicate of this bug. ***
Comment 88 ttv200 2017-02-20 07:19:31 UTC
I can confirm that the bug fixed on:
openSUSE Tumbleweed (rolling) with:
  KDE Plasma 5.9.2
  Qt 5.7.1
  KDE Frameworks 5.30.0

Mark as resolved?
Comment 89 ttv200 2017-02-20 07:19:58 UTC
*** Bug 376603 has been marked as a duplicate of this bug. ***
Comment 90 ttv200 2017-02-20 07:20:20 UTC
*** Bug 376582 has been marked as a duplicate of this bug. ***
Comment 91 André Verwijs 2017-02-20 11:09:53 UTC
Created attachment 104122 [details]
attachment-18114-0.html

I'll have to check... need to update TW to the latest packages....

..

Op 20 feb. 2017 08:19 schreef <bugzilla_noreply@kde.org>:

https://bugs.kde.org/show_bug.cgi?id=373628

--- Comment #88 from ttv200@gmail.com ---
I can confirm that the bug fixed on:
openSUSE Tumbleweed (rolling) with:
  KDE Plasma 5.9.2
  Qt 5.7.1
  KDE Frameworks 5.30.0

Mark as resolved?

--
You are receiving this mail because:
You are on the CC list for the bug.
Comment 92 Christoph Feck 2017-03-02 22:46:56 UTC
*** Bug 376924 has been marked as a duplicate of this bug. ***
Comment 93 Christoph Feck 2017-03-02 23:10:24 UTC
*** Bug 376960 has been marked as a duplicate of this bug. ***
Comment 94 Christoph Feck 2017-03-02 23:12:11 UTC
*** Bug 376971 has been marked as a duplicate of this bug. ***
Comment 95 Christoph Feck 2017-03-02 23:12:44 UTC
*** Bug 377077 has been marked as a duplicate of this bug. ***
Comment 96 Christoph Feck 2017-03-21 13:36:59 UTC
*** Bug 377851 has been marked as a duplicate of this bug. ***
Comment 97 Christoph Feck 2017-03-31 16:05:31 UTC
*** Bug 378067 has been marked as a duplicate of this bug. ***
Comment 98 Christoph Feck 2017-04-26 11:15:35 UTC
*** Bug 378830 has been marked as a duplicate of this bug. ***
Comment 99 Bernhard Übelacker 2017-05-16 08:13:25 UTC
Just a note for completeness:
Upstream bug [QTBUG-57714] got now closed and a fix got commited [1].
It is included since Qt release v5.9.0-beta2 and in the v5.8 branch waiting
for the next v5.8.x release.

And in duplicate [QTBUG-58562] is a commit mentioned [2] as the patch causing
this issue which on the other side is said to be the fix for [361236].

[QTBUG-57714] https://bugreports.qt.io/browse/QTBUG-57714
[QTBUG-58562] https://bugreports.qt.io/browse/QTBUG-58562
[361236] https://bugs.kde.org/show_bug.cgi?id=361236#c113
[1] http://code.qt.io/cgit/qt/qtdeclarative.git/commit/?id=d438be92dd7068fef94ce98e1ec039fe0ef4f3b3
[2] http://code.qt.io/cgit/qt/qtdeclarative.git/commit/?id=4d375f3f2b95bfcb322402df3525db6cc7a723ce
Comment 100 flatron 2018-02-09 18:14:57 UTC
Created attachment 110490 [details]
New crash information added by DrKonqi

systemsettings5 (5.12.0) using Qt 5.9.3

- What I was doing when the application crashed:

crash when clic    /Bureau virtuels/Réglages par défaut"

-- Backtrace (Reduced):
#6  0x00007f3c0c7f7428 in __GI_raise (sig=sig@entry=6) at ../sysdeps/unix/sysv/linux/raise.c:54
#7  0x00007f3c0c7f902a in __GI_abort () at abort.c:89
[...]
#9  0x00007f3c0c844651 in malloc_printerr (ar_ptr=0x7ffd2b54e5f0, ptr=0x1fc854f, str=0x7f3c0c9532e0 "malloc(): memory corruption (fast)", action=3) at malloc.c:5006
#10 _int_malloc (av=av@entry=0x7f3c0cb86b20 <main_arena>, bytes=bytes@entry=28) at malloc.c:3386
#11 0x00007f3c0c846184 in __GI___libc_malloc (bytes=28) at malloc.c:2913
Comment 101 Nate Graham 2022-03-26 16:25:54 UTC
*** Bug 451905 has been marked as a duplicate of this bug. ***