Bug 373534 - git master - Project Bin disappears when changing framerate from project settings [screenshot included]
Summary: git master - Project Bin disappears when changing framerate from project sett...
Status: RESOLVED FIXED
Alias: None
Product: kdenlive
Classification: Applications
Component: User Interface (show other bugs)
Version: git-master
Platform: Archlinux Linux
: VHI major (vote)
Target Milestone: ---
Assignee: Jean-Baptiste Mardelle
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-11 19:22 UTC by Unknown
Modified: 2016-12-15 19:31 UTC (History)
3 users (show)

See Also:
Latest Commit:
Version Fixed In:


Attachments
screenshot of issue (724.93 KB, image/png)
2016-12-11 19:22 UTC, Unknown
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Unknown 2016-12-11 19:22:35 UTC
Created attachment 102731 [details]
screenshot of issue

Details: When I've imported a video clip that's 23.976fps, and I change the project settings framerate from 29.97 to 23.98, the Project Bin section containing all of the clips disappears, and the top toolbar is centered in the widget. See screenshot for example.

Steps to reproduce:
1. Import 23.976 video clip (in this case, The Time Machine from 1960 :) )
2. In the top header menu, go to "Project > Project Settings".
3. Change framerate (in this case, from my default 29.97fps to 23.98fps). Click OK.
4. Click "Continue" when the confirmation window appears.

What happens:
In the Project Bin widget, the container section showing all of the project clips and media disappears. ALSO, trying to go into Project Settings again and change the framerate back results in Kdenlive crashing.

What should happen:
No disappearing of Project Bin components, and no crashing.

Bug discovered while using Kdenlive 17.03.70 git master AUR on Antergos (Arch) Linux x64, GNOME 3.22.2 desktop environment, Xorg 1.18.4, kernel 4.8.12-13 ARCH.
Comment 1 Jean-Baptiste Mardelle 2016-12-15 18:02:58 UTC
Git commit 2b7a70dd0194959c5fc79232ec9bdf81d25a5666 by Jean-Baptiste Mardelle.
Committed on 15/12/2016 at 18:02.
Pushed by mardelle into branch 'Applications/16.12'.

Fix bin closing on fps change

M  +1    -1    src/doc/kdenlivedoc.cpp

https://commits.kde.org/kdenlive/2b7a70dd0194959c5fc79232ec9bdf81d25a5666
Comment 2 farid 2016-12-15 18:05:55 UTC
Thanks JB, will this make it for 16.12?

Cheers
Comment 3 Jean-Baptiste Mardelle 2016-12-15 18:21:12 UTC
On Thursday, December 15, 2016 7:05:55 PM CET, farid wrote:
> https://bugs.kde.org/show_bug.cgi?id=373534
>
> --- Comment #2 from farid <snd.noise@gmail.com> ---
> Thanks JB, will this make it for 16.12?

No, the official 16.12 code that will be available to download will not 
include all patches commited after the 8th of december, when the 16.12 tag 
was set.

So all fixes made since the 9th of december will be for the official 
16.12.1 release (release on the 12th of january).

However the AppImage and snap package that I am preparing right now (that 
should be ready to download tomorrow) will contain all patches until today.

regards
jb
Comment 4 farid 2016-12-15 18:27:10 UTC
We should include this issues in the release then, right? or they only affect few users to be considered?
Comment 5 Jean-Baptiste Mardelle 2016-12-15 18:41:23 UTC
On Thursday, December 15, 2016 7:27:10 PM CET, farid wrote:
> https://bugs.kde.org/show_bug.cgi?id=373534

Yes, it could be a good idea to add something like this:

-------------------

known issues (solved in git): 
* Project bin disappears when changing project frame rate (bug #373534)
* Timeline guides cannot be edited (bug #373468)

These issues will be fixed in Kdenlive 16.12.1

-------------------

What do you think?

regards
jb
Comment 6 Unknown 2016-12-15 18:44:00 UTC
As long as the public is aware that you're aware of the problem, and it's been fixed in an update that they'll receive soon, then I think that works.

Can the master git branch be updated, too, so I can confirm the fix on my end, please?
Comment 7 farid 2016-12-15 18:45:28 UTC
(In reply to Jean-Baptiste Mardelle from comment #5)
> On Thursday, December 15, 2016 7:27:10 PM CET, farid wrote:
> > https://bugs.kde.org/show_bug.cgi?id=373534
> 
> Yes, it could be a good idea to add something like this:
> 
> -------------------
> 
> known issues (solved in git): 
> * Project bin disappears when changing project frame rate (bug #373534)
> * Timeline guides cannot be edited (bug #373468)
> 
> These issues will be fixed in Kdenlive 16.12.1
> 
> -------------------
> 
> What do you think?
> 
> regards
> jb


perfect
Comment 8 farid 2016-12-15 18:46:22 UTC
(In reply to Jesse from comment #6)
> As long as the public is aware that you're aware of the problem, and it's
> been fixed in an update that they'll receive soon, then I think that works.
> 
> Can the master git branch be updated, too, so I can confirm the fix on my
> end, please?

in arch you can download the kdenlive-git package from aur, probably it will have been updated.
Comment 9 farid 2016-12-15 19:01:08 UTC
(In reply to Jean-Baptiste Mardelle from comment #5)
> On Thursday, December 15, 2016 7:27:10 PM CET, farid wrote:
> > https://bugs.kde.org/show_bug.cgi?id=373534
> 
> Yes, it could be a good idea to add something like this:
> 
> -------------------
> 
> known issues (solved in git): 
> * Project bin disappears when changing project frame rate (bug #373534)
> * Timeline guides cannot be edited (bug #373468)
> 
> These issues will be fixed in Kdenlive 16.12.1
> 
> -------------------
> 
> What do you think?
> 
> regards
> jb

Also this is a known issue or arch centric?

https://bugs.kde.org/show_bug.cgi?id=373531
Comment 10 Unknown 2016-12-15 19:30:48 UTC
Confirmed fix, you guys rock!
Comment 11 farid 2016-12-15 19:31:36 UTC
(In reply to Jesse from comment #10)
> Confirmed fix, you guys rock!

just jb ;)