Bug 373341 - kMail2 unread messages quick filter - messages disappear after clicking
Summary: kMail2 unread messages quick filter - messages disappear after clicking
Status: RESOLVED NOT A BUG
Alias: None
Product: kmail2
Classification: Applications
Component: search (show other bugs)
Version: 5.3.0
Platform: Fedora RPMs Linux
: NOR normal (vote)
Target Milestone: ---
Assignee: kdepim bugs
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-12-06 09:16 UTC by a.key
Modified: 2016-12-07 14:41 UTC (History)
0 users

See Also:
Latest Commit:
Version Fixed In:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description a.key 2016-12-06 09:16:20 UTC
This is basically a copy of this bug report: https://bugs.kde.org/show_bug.cgi?id=259813 since the old one is filed against an unmaintained  4.9 version.

Clicking on a message filtered through quick filter "Unread" marks the message as read and removes it from the list of filtered messages. 

To reproduce:
1.Have at least 1 unread message in the inbox/folder
2.Click on the quick filter icon
3.Tick the "Unread" quick filter icon
4.Select any message from the list of "Unread"
5.The message contents is displayed in the message preview pane but within a second it's marked as read and disappears from the list of filtered messages

Desired behavior:
At step 4, after clicking on a filtered/found message it should get marked as read but remain on the list of filtered messages.
Comment 1 a.key 2016-12-06 09:20:34 UTC
Even more interesting behavior can be noted in akregator which may be related...
When using the "Unread" quick filter there and setting a focus on any filtered message the message is set to read and disappears from the list but unlike in kmail2 focus is automatically set to the next message in the list which quickly gets set as "read" and removed from the list...
This behavior continues until there are no "unread" messages on the list which happens very quickly.
Comment 2 Christoph Feck 2016-12-07 14:41:13 UTC
There is no need to create a new bug report when just the version can be updated (which I just did).